Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 592026 - x11-base/xorg-drivers - add video_cards_i965 USE
Summary: x11-base/xorg-drivers - add video_cards_i965 USE
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Matt Turner
URL:
Whiteboard:
Keywords:
: 695588 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-08-24 15:09 UTC by Brian Evans
Modified: 2020-02-03 09:41 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Evans Gentoo Infrastructure gentoo-dev 2016-08-24 15:09:43 UTC
Debian and Ubuntu are moving away from the stagnant xf86-video-intel in favor of the modesetting driver built into xorg-server for all Gen4+ cards. [1][2]

We could easily change to this setup by adding video_cards_i965 and adjusting the dependency to:

video_cards_intel?  ( video_cards_i965? ( ~x11-base/xorg-server-${PV}[glamor] )
 !video_cards_i965? ( x11-drivers/xf86-video-intel )
 )

The glamor requirement keeps hardware acceleration.

The only drawback is that x11-apps/xbacklight does not work with modesetting.
However I have added sys-power/acpilight to compensate for this which uses the same syntax but manipulates the kernel interfaces.

This was tested to work by klausman@gentoo.org (Blackb|rd on IRC) and others.


[1] https://www.phoronix.com/scan.php?page=news_item&px=Ubuntu-Debian-Abandon-Intel-DDX
[2] https://tjaalton.wordpress.com/2016/07/23/intel-graphics-gen4-and-newer-now-defaults-to-modesetting-driver-on-x/
Comment 1 Chí-Thanh Christopher Nguyễn gentoo-dev 2016-08-24 15:22:21 UTC
If you set VIDEO_CARDS="i965" in make.conf you will already today get that.

The glamor flag for xorg-server is not strictly required, only if you want 2D acceleration, and it is enabled by default in the desktop profile.
Comment 2 Brian Evans Gentoo Infrastructure gentoo-dev 2016-08-24 15:32:30 UTC
(In reply to Chí-Thanh Christopher Nguyễn from comment #1)
> If you set VIDEO_CARDS="i965" in make.conf you will already today get that.
> 
> The glamor flag for xorg-server is not strictly required, only if you want
> 2D acceleration, and it is enabled by default in the desktop profile.

Unfortunately, other packages look for just video_cards_intel for different purposes so i965 alone is not enough to have a low impact.

The current recommendation to users is to set VIDEO_CARDS="intel i965" so a change here would have minimal impact
Comment 3 Michael Palimaka (kensington) gentoo-dev 2016-09-21 15:09:27 UTC
I support this change, modesetting is a much better option lately.
Comment 4 Brian Evans Gentoo Infrastructure gentoo-dev 2016-09-21 15:17:30 UTC
We should at least do:

video_cards_intel? ( !video_cards_i965? ( x11-drivers/xf86-video-intel ) )

If you don't think the glamor bit is needed.
Comment 5 Matt Turner gentoo-dev 2016-10-24 23:58:37 UTC
Committed as

commit 0f26449868d8412b9629ee3b7cd4ba18427b5b36
Author: Matt Turner <mattst88@gentoo.org>
Date:   Mon Oct 24 16:20:31 2016 -0700

    x11-base/xorg-drivers: Add VIDEO_CARDS=i965.
    
    This changes the default for i965 to modesetting/glamor (part of the
    xserver) from xf86-video-intel. xf86-video-intel is still used for
    i8xx/i915/i945.
    
    Bug: https://bugs.gentoo.org/show_bug.cgi?id=592026

I elected to depend on ~x11-base/xorg-server-${PV}[glamor] if i965 is set because users are unlikely to have USE=glamor set already and are equally unlikely to be happy about not having any acceleration.

I made the commit to xorg-drivers-9999, so it'll propagate into the 1.19 release once that's in-tree.
Comment 6 Jason A. Donenfeld gentoo-dev 2016-11-15 20:19:24 UTC
x11-drivers/xf86-video-intel is still above and beyond modesetting. It has significant advantages that modesetting will probably never catch up with. While stagnant for a long period, they are now emerging from that period with more man power. For all intents and purposes, x11-drivers/xf86-video-intel should remain the default.
Comment 7 Matt Turner gentoo-dev 2016-11-15 21:36:32 UTC
(In reply to Jason A. Donenfeld from comment #6)
> x11-drivers/xf86-video-intel is still above and beyond modesetting. It has
> significant advantages that modesetting will probably never catch up with.

Hard to respond to vague speculation.

> While stagnant for a long period, they are now emerging from that period
> with more man power. 

I have no idea why you believe that. I don't see any data to support that.

> For all intents and purposes,
> x11-drivers/xf86-video-intel should remain the default.

I strongly disagree.

So do Debian and Ubuntu. Fedora patches xf86-video-intel to bail and use modesetting+glamor on SKL+.

Feel free to continue the discussion on #gentoo-desktop.
Comment 8 Aric Belsito 2017-01-25 22:23:56 UTC
Just my two cents -- like Jason, I'm not particularly happy that this change was made.

The xf86-video-intel driver currently works on my haswell machine and just because Ubuntu/Debian and Fedora have moved away from using that driver because they aren't willing to hear user complaints about broken video doesn't mean that we should follow suit or that the driver is dead.

I actually have more experience with the intel kernel driver breaking than xf86-video-intel, and switching to modesetting does not fix that.

Will stop commenting now and check out #gentoo-desktop
Comment 9 Matt Turner gentoo-dev 2017-01-25 22:30:33 UTC
All you have to do if you want to use xf86-video-intel is... install xf86-video-intel.
Comment 10 Brian Evans Gentoo Infrastructure gentoo-dev 2017-02-08 19:39:24 UTC
*** Bug 608654 has been marked as a duplicate of this bug. ***
Comment 11 Stefano 2017-05-07 16:52:45 UTC
As a note for future people wandering by, modesetting fails at DRI if one of the dimensions of your virtual display is > 2048.

https://ubuntuforums.org/showthread.php?t=1155417

(which for me is the deal breaker in going back to intel)
Comment 12 Brian Evans Gentoo Infrastructure gentoo-dev 2017-05-07 19:19:59 UTC
(In reply to Stefano from comment #11)
> As a note for future people wandering by, modesetting fails at DRI if one of
> the dimensions of your virtual display is > 2048.
> 
> https://ubuntuforums.org/showthread.php?t=1155417
> 
> (which for me is the deal breaker in going back to intel)

Strangely enough, the link you provide is about xf86-video-intel and not xorg-server's modesetting which this bug is about.
Comment 13 Brian Evans Gentoo Infrastructure gentoo-dev 2019-09-24 20:11:38 UTC
*** Bug 695588 has been marked as a duplicate of this bug. ***
Comment 14 Ingo Brunberg 2019-12-15 10:04:20 UTC
Now that iris is coming to replace i965 for modern intel hardware, I request that exactly the same change is done for iris.

Simple reason: If I have my VIDEO_CARDS only set to "intel iris" I need to explicitly add use flag "video_cards_i965" to xorg-drivers to omit pulling in xf86-video-intel.
Comment 15 Ingo Brunberg 2020-02-03 09:41:47 UTC
Before opening a new bug I again ask here to add a video_cards_iris with the same function as video_cards_i965.

Or maybe better revert the addition of video_cards_i965 and pull in xf86-video-intel only for video_cards_i915. What do you think?