Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 591552 - dev-util/electron-0.36.12-r3 uses bundled libs
Summary: dev-util/electron-0.36.12-r3 uses bundled libs
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Elvis Pranskevichus
URL:
Whiteboard:
Keywords:
Depends on: 525560 459932
Blocks:
  Show dependency tree
 
Reported: 2016-08-17 21:10 UTC by xela
Modified: 2017-03-30 13:18 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description xela 2016-08-17 21:10:02 UTC
Despite I was told that evolution is a actually a fork of Chromium (I don't doubt this), I think it can be unbundled more than of a current state. Right now it compiles its own v8, protobuf, mesa and maybe bunch of other packages we already have in the system. More of that, most of them resides in a "thirdparty" directory, which I think eases the task. I will also file a bug on the electron's github to ask about modification of their gyp files right there (to write less Gentoo-specific patches).

Reproducible: Always

Steps to Reproduce:
1. emerge electron;
2. Enjoy compilation of 12461 files, while at least third of them already exists in your system compiled;
3. Upvote this bug :)
Actual Results:  
Filled this bug report

Expected Results:  
It should have emerged faster!
Comment 2 Elvis Pranskevichus 2016-08-17 22:16:33 UTC
> I think it can be unbundled more

Not really.  Everything that is possible to unbundle is already unbundled: [1].  The remaining bundled libs all have upstream blockers [2].

Also, even if you managed to remove the remaining deps, that wouldn't help much.  Chromium is _huge_.


[1] https://github.com/gentoo/gentoo/blob/master/dev-util/electron/electron-0.36.12-r3.ebuild#L67

[2] https://github.com/gentoo/gentoo/blob/master/dev-util/electron/electron-0.36.12-r3.ebuild#L67
Comment 3 Kristian Fiskerstrand (RETIRED) gentoo-dev 2016-08-17 23:00:36 UTC
(In reply to Elvis Pranskevichus from comment #2)
> > I think it can be unbundled more
> 
> Not really.  Everything that is possible to unbundle is already unbundled:
> [1].  The remaining bundled libs all have upstream blockers [2].
> 

Then downstream should work with upstream to resolve the blockers. Patches should be submitted the the underlying libraries etc. Embedded libraries are fundamentally bad, in particular if it is due to internal patches.
Comment 4 Elvis Pranskevichus 2016-08-17 23:27:04 UTC
> Then downstream should work with upstream to resolve the blockers. Patches should be submitted the the underlying libraries etc. Embedded libraries are fundamentally bad, in particular if it is due to internal patches.

Most umbundling blockers already have the associated bugs, and are handled by the Gentoo Chromium project, who are the actual downstream here. The electron ebuild is fundamentally based on their work.  As such, this is really a meta bug, that's unlikely to ever be resolved, as Google breaks things with every release, and doesn't generally give priority to support compatibility with system libs.
Comment 5 xela 2016-08-18 12:24:12 UTC
They have closed upstream issue related to this, insisting of using their own forks and bundling them, so maybe it can be effortless now...that's just sad that in 2016 people still don't want to use shared code.
Comment 6 Elvis Pranskevichus 2017-03-30 13:18:06 UTC
Closing with CANTFIX.  Electron unbundles all libs that are _possible_ to unbundle.