Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 590382 - net-misc/openssh-7.3_p1[kerberos] GSSAPI patch breaks compile: sshconnect2.c: undefined reference to `get_canonical_hostname'
Summary: net-misc/openssh-7.3_p1[kerberos] GSSAPI patch breaks compile: sshconnect2.c:...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
: 590414 (view as bug list)
Depends on:
Blocks: 590202
  Show dependency tree
 
Reported: 2016-08-03 08:14 UTC by Hanspeter Spalinger
Modified: 2016-08-04 00:37 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (net-misc:openssh-7.3_p1:20160803-080534.log,194.63 KB, text/plain)
2016-08-03 08:14 UTC, Hanspeter Spalinger
Details
emerge --info (emerge.info,6.08 KB, application/x-info)
2016-08-03 08:15 UTC, Hanspeter Spalinger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hanspeter Spalinger 2016-08-03 08:14:30 UTC
Created attachment 442378 [details]
build log

Due to bugreport
 http://bugs.gentoo.org/165444
 https://bugzilla.mindrot.org/show_bug.cgi?id=1008
a patch was introduced net-misc/openssh/files/openssh-7.2_p1-GSSAPI-dns.patch
+   const char *gss_host;
+
+   if (options.gss_trust_dns)
+       gss_host = get_canonical_hostname(1);
+   else
+       gss_host = authctxt->host;

Unfortunately the function get_canonical_hostname was removed, comment in Changelog:

commit 885fb2a44ff694f01e4f6470f803629e11f62961
Author: Darren Tucker <dtucker@zip.com.au>
Date:   Tue Mar 8 11:58:43 2016 +1100

    auth_get_canonical_hostname in portable code.
    
    "refactor canohost.c" replaced get_canonical_hostname, this makes the
    same change to some portable-specific code.

commit 95767262caa6692eff1e1565be1f5cb297949a89
Author: djm@openbsd.org <djm@openbsd.org>
Date:   Mon Mar 7 19:02:43 2016 +0000

    upstream commit
    
    refactor canohost.c: move functions that cache results closer
     to the places that use them (authn and session code). After this, no state is
     cached in canohost.c
    
    feedback and ok markus@
    
    Upstream-ID: 5f2e4df88d4803fc8ec59ec53629105e23ce625e

So with the patch this breaks gssapi as mentioned in the mindrot.org burgreport.
Comment 1 Hanspeter Spalinger 2016-08-03 08:15:37 UTC
Created attachment 442380 [details]
emerge --info
Comment 2 Eugene Shalygin 2016-08-03 18:55:18 UTC
*** Bug 590414 has been marked as a duplicate of this bug. ***