Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 590174 - app-office/libreoffice-bin-5.1.4.2 needs to have its poppler dependency updated
Summary: app-office/libreoffice-bin-5.1.4.2 needs to have its poppler dependency updated
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Andreas K. Hüttel
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-01 04:46 UTC by Raymond Jennings
Modified: 2016-08-16 21:58 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Raymond Jennings 2016-08-01 04:46:11 UTC
libreoffice-bin needs to have its poppler dependency updated.

I had to remove it to process a world update and libreoffice-bin is depending on an obsolete version of poppler, causing a conflict with the current installed version.
Comment 1 Jonas Stein gentoo-dev 2016-08-01 18:35:11 UTC
which version of libreoffice-bin?
Comment 2 Raymond Jennings 2016-08-01 19:30:08 UTC
5.1.4.2
Comment 3 Andreas K. Hüttel gentoo-dev 2016-08-01 21:18:20 UTC
(In reply to shentino from comment #0)
> libreoffice-bin needs to have its poppler dependency updated.
> 
> I had to remove it to process a world update and libreoffice-bin is
> depending on an obsolete version of poppler, causing a conflict with the
> current installed version.

So which version of poppler do you have?
Comment 4 Raymond Jennings 2016-08-02 01:22:46 UTC
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

app-text/poppler:0

  (app-text/poppler-0.45.0:0/62::gentoo, ebuild scheduled for merge) pulled in by
    app-text/poppler:0/62 required by (app-office/libreoffice-bin-5.1.4.2:0/0::gentoo, ebuild scheduled for merge)
                    ^^^^^                                                                                                                             

  (app-text/poppler-0.46.0-r1:0/63::gentoo, installed) pulled in by
    >=app-text/poppler-0.12.3-r3:0/63= required by (app-text/texlive-core-2014-r4:0/0::gentoo, installed)
                                ^^^^^^                                                                                                       
    (and 1 more with the same problem)
Comment 5 Raymond Jennings 2016-08-02 01:33:58 UTC
Btw, aren't shared libraries supposed to be dynamically linked?  Why does libreoffice-bin have to depend on an exact version of poppler anyway?  Shouldn't the current version be backward compatible with the version libreoffice-bin was linked against?
Comment 6 Oleh 2016-08-11 03:43:39 UTC
it's a downside of having rolling release. it's because poppler (and other libs) bumped independently of libreoffice-bin... the last one need permanent regeneration, specially when you use ~arch. That's the fact you have to bear. libreoffice-bin is a special binary that built against certain "slice" of libraries versions (and normlly only stable versions), so when library updated, say, poppler or glew, for example, lo-bin will not work properly. To workaround this, either slower pace of lib bumps needed or lo-bin needed continous bumps, which is quite time and power consuming task.