Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 589852 - net-im/ejabberd-16.04: crashed unexpectedly
Summary: net-im/ejabberd-16.04: crashed unexpectedly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Amadeusz Żołnowski
URL: https://github.com/processone/ejabber...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-27 15:21 UTC by Toralf Förster
Modified: 2017-05-28 13:33 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
error.log (bdbadc6628e9,3.71 KB, text/html)
2016-07-27 15:21 UTC, Toralf Förster
Details
crash.log (78c609145f4c,16.45 KB, text/html)
2016-07-27 15:21 UTC, Toralf Förster
Details
ejabberd.yml (ejabberd.yml,16.22 KB, application/x-yaml)
2016-08-06 09:23 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2016-07-27 15:21:16 UTC
Created attachment 441736 [details]
error.log

well, will attch both crash.og and error.log, I'm unsure about the culprit however

# emerge --info ejabberd
Portage 2.2.28 (python 3.4.3-final-0, hardened/linux/amd64, gcc-4.9.3, glibc-2.22-r4, 4.6.4-hardened-r3 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.6.4-hardened-r3-x86_64-Intel-R-_Core-TM-_i7-3770_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16156124 total,   2704140 free
KiB Swap:   16777212 total,  16724748 free
Timestamp of repository gentoo: Wed, 27 Jul 2016 14:45:21 +0000
sh bash 4.3_p42-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p42-r1::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.10-r1::gentoo, 3.4.3-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.19.1::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.69::gentoo
sys-devel/automake:       1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r4::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/gentoo
    priority: 1

local
    location: /usr/local/portage
    masters: gentoo
    priority: 2

aidecoe
    location: /usr/local/overlay/aidecoe
    sync-type: git
    sync-uri: https://github.com/aidecoe/aidecoe-overlay.git
    masters: gentoo
    priority: 3

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going=y --nospinner --tree --quiet-build"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs compress-build-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo http://mirror.leaseweb.com/gentoo/ ftp://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/ ftp://mirror.leaseweb.com/gentoo/ http://ftp.uni-erlangen.de/pub/mirrors/gentoo "
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j6"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="acl amd64 berkdb bzip2 cli cracklib crypt cxx dnssec dri gdbm hardened iconv ipv6 justify logrotate mbox mmx mmxext mod_irc mod_muc mod_statsdx modules multilib ncurses nls nptl openmp pam pax_kernel pcre pie png pwquality readline scrypt seccomp session sse sse2 sse3 sse4 sse4.1 sse4.2 ssl ssp tcpd threads tor-hardening tracepath traceroute truetype unicode urandom vim-syntax xattr xtpax zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

net-im/ejabberd-16.04::gentoo was built with the following:
USE="nls zlib -captcha -debug -full-xml -hipe -ldap -mssql -mysql -odbc -pam -postgres -redis -riak -roster-gw -sqlite" ABI_X86="64"
Comment 1 Toralf Förster gentoo-dev 2016-07-27 15:21:33 UTC
Created attachment 441738 [details]
crash.log
Comment 2 Toralf Förster gentoo-dev 2016-07-27 15:22:03 UTC
and fwiw :

dev-lang/erlang-18.3::gentoo was built with the following:
USE="ssl -compat-ethread -doc -emacs -halfword -hipe -java -kpoll (-libressl) -odbc -sctp -smp -systemd -tk -wxwidgets" ABI_X86="64"
Comment 3 Toralf Förster gentoo-dev 2016-07-27 17:29:24 UTC
in the info.log I got (snipped the user name)

2016-07-25 09:54:36.572 [info] <0.495.0>@ejabberd_listener:accept:333 (#Port<0.24154>) Accepted connection 2A02:8108:4A40:8D98:9424:E9BE:ABBA:B672:61395 -> 2A01:4F8:190:514A::2:5222
2016-07-25 09:54:36.895 [info] <0.14095.0>@ejabberd_c2s:wait_for_feature_request:782 ({socket_state,fast_tls,{tlssock,#Port<0.24154>,#Port<0.24155>},<0.14094.0>}) Failed authentication for <snip>@jabber.zwiebeltoralf.de from 2A02:8108:4A40:8D98:9424:E9BE:ABBA:B672
2016-07-25 09:54:38.652 [info] <0.495.0>@ejabberd_listener:accept:333 (#Port<0.24156>) Accepted connection 2A02:8108:4A40:8D98:9424:E9BE:ABBA:B672:61403 -> 2A01:4F8:190:514A::2:5222
2016-07-25 09:54:38.937 [info] <0.14097.0>@ejabberd_c2s:wait_for_feature_request:782 ({socket_state,fast_tls,{tlssock,#Port<0.24156>,#Port<0.24157>},<0.14096.0>}) Failed authentication for <snip>@jabber.zwiebeltoralf.de from 2A02:8108:4A40:8D98:9424:E9BE:ABBA:B672
2016-07-25 09:54:57.864 [info] <0.495.0>@ejabberd_listener:accept:333 (#Port<0.24158>) Accepted connection 2A02:8108:4A40:8D98:9424:E9BE:ABBA:B672:61422 -> 2A01:4F8:190:514A::2:5222
2016-07-25 09:54:58.191 [error] <0.14099.0> gen_fsm <0.14099.0> in state wait_for_feature_request terminated with reason: bad argument in call to crypto:sha_mac_n(error, <<79,103,224,133,46,244,34,23,98,95,199,199,141,33,206,62,0,0,0,1>>, 20) in scram:hi/3 line 73
Comment 4 Amadeusz Żołnowski gentoo-dev 2016-08-03 21:15:00 UTC
Could you describe context a bit more? In which circumstances it happened? Are you doing something unusual? I am going to forward bug upstream and that information may be useful for them.
Comment 5 Toralf Förster gentoo-dev 2016-08-05 08:46:28 UTC
(In reply to Amadeusz Żołnowski from comment #4)

I reset a users password to a new one and he tried to login and to send my a message. The issue happened just once. The guy itself had have :

ChatSecure 3.2.3
Created by Chris Ballinger u. David Chiles

iOS 9.3.3 (13G34)

libotr 4.1.1
libgpg-error 1.21
libgcrypt 1.6.5
tor 0.2.7.6
OpenSSL 1.0.2g 1 Mar 2016
libevent 2.0.22-stable
Comment 6 Amadeusz Żołnowski gentoo-dev 2016-08-05 15:45:06 UTC
(In reply to Toralf Förster from comment #5)
> (In reply to Amadeusz Żołnowski from comment #4)
> 
> I reset a users password to a new one and he tried to login and to send my a
> message. The issue happened just once. The guy itself had have :

Thanks. Which authentication mechanism do you use? How you've changed the password? At the moment of changing password, has the user been logged in (probably no) or was trying to log in? Could you provide excerpts of your config related to registration and authentication? Was the user connecting via tor?

Have you tried to reproduce the issue, e.g. by creating new account and changing password to the same one you've changed for that user?
Comment 7 Toralf Förster gentoo-dev 2016-08-06 09:23:34 UTC
Created attachment 442662 [details]
ejabberd.yml

attached is the config.

Unfortunately I cannot say when exactly the crash happened - the user contacted me too late. A subsequent attempt of him to connect succeeded and the behaviour doesn't occurred again in the mean while.
Comment 8 Amadeusz Żołnowski gentoo-dev 2016-09-14 06:28:31 UTC
The URL to forum doesn't seem to be really relevant to the issue.
Comment 9 Amadeusz Żołnowski gentoo-dev 2016-09-14 06:31:21 UTC
I have reported the issue upstream, but unless there's something obvious in logs to developers, I doubt it's going to be resolved since even you cannot reproduce it.
Comment 10 Amadeusz Żołnowski gentoo-dev 2017-01-26 21:49:01 UTC
From <https://github.com/processone/ejabberd/issues/1295#issuecomment-275319371>:
> By the way, did you report the issue to ChatSecure? Because this is also a client issue.
Comment 11 Amadeusz Żołnowski gentoo-dev 2017-05-28 13:33:32 UTC
From <https://github.com/processone/ejabberd/issues/1295#issuecomment-279127552>:
> After some investigation, I found that the password contains a control character (\n) and SASLprep doesn't allow such characters.

And it has been fixed on 12 Feb. It is fixed in ejabberd-17.04 which has just been added to the tree.