Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 589546 - >=www-servers/tomcat:8.5[doc] - javadoc doesn't support the "failonwarning" attribute
Summary: >=www-servers/tomcat:8.5[doc] - javadoc doesn't support the "failonwarning" a...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Java team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-23 16:34 UTC by jeremiah
Modified: 2016-07-24 13:59 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jeremiah 2016-07-23 16:34:59 UTC
Originally misreported as part of #586732

Tomcat slots 8.5 and 9 with doc USE flag enabled (tested on 8.5.3, 8.5.4, and 9.0.0_alpha9) require the "failonwarning" feature introduced in ant-1.9.4 (see <https://archive.apache.org/dist/ant/RELEASE-NOTES-1.9.4.html> under "Other changes" at entry #4, which references <https://bz.apache.org/bugzilla/show_bug.cgi?id=55015>)

using >=dev-java/ant-core-1.9.5_pre::poly-c (1.9.4 is unavailable) rather than =dev-java/ant-core-1.9.2::gentoo resolves this particular bug

Recommended action is to add "doc? >=dev-java/ant-core-1.9.4" to the DEPEND section for >=www-server/tomcat:8.5

Reproducible: Always