Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 58904 - gnustep-base/gnustep-back 0.8.8 compile fails NSGraphicsContext.h: No such file or directory
Summary: gnustep-base/gnustep-back 0.8.8 compile fails NSGraphicsContext.h: No such fi...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gnustep herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-07-30 09:34 UTC by Hans-Christian Armingeon
Modified: 2004-09-23 20:38 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hans-Christian Armingeon 2004-07-30 09:34:17 UTC
/usr/GNUstep/System/Library/Makefiles/mkinstalldirs .
cp ../config.h .
Making all in subprojects of bundle libgnustep-back...
make[2]: Entering directory `/var/tmp/portage/gnustep-back-0.8.8/work/gnustep-back-0.8.8/Source/gsc'
Making all for subproject gsc...
 Compiling file gscolors.c ...
 Compiling file GSContext.m ...
distcc[1878] ERROR: compile /var/tmp/portage/gnustep-back-0.8.8/temp/fakehome/.ccache/GSContext.tmp.jathgentoo.1830.mi on triton/4 failed
cc1: warning: "-fgnu-runtime" is valid for ObjC but not for C/C++
cc1: warning: "-fconstant-string-class=" is valid for ObjC but not for C/C++
GSContext.m:26:37: warning: AppKit/AppKitExceptions.h: No such file or directory
GSContext.m:27:38: warning: AppKit/NSAffineTransform.h: No such file or directory
GSContext.m:28:28: warning: AppKit/NSColor.h: No such file or directory
GSContext.m:29:27: warning: AppKit/NSView.h: No such file or directory
GSContext.m:30:29: warning: AppKit/NSWindow.h: No such file or directory
GSContext.m:31:36: warning: AppKit/GSDisplayServer.h: No such file or directory
In file included from GSContext.m:41:
../../Headers/gsc/GSContext.h:31:38: warning: AppKit/NSGraphicsContext.h: No such file or directory
In file included from GSContext.m:43:
../../Headers/gsc/GSGState.h:30:77: warning: AppKit/NSGraphicsContext.h: No such file or directory
In file included from GSContext.m:41:
../../Headers/gsc/GSContext.h:44: error: cannot find interface declaration for `NSGraphicsContext', superclass of `GSContext'
make[3]: *** [shared_obj/GSContext.o] Error 1
make[2]: *** [gsc.all.subproject.variables] Error 2
make[2]: Leaving directory `/var/tmp/portage/gnustep-back-0.8.8/work/gnustep-back-0.8.8/Source/gsc'
make[1]: *** [libgnustep-back.all.bundle.variables] Error 2
make[1]: Leaving directory `/var/tmp/portage/gnustep-back-0.8.8/work/gnustep-back-0.8.8/Source'
make: *** [internal-all] Error 2

!!! ERROR: gnustep-base/gnustep-back-0.8.8 failed.
!!! Function egnustepmake, Line 86, Exitcode 2
!!! emake failed



Reproducible: Always
Steps to Reproduce:
1.
2.
3.



Expected Results:  
 

Portage 2.0.50-r9 (default-x86-1.4, gcc-3.3.4, glibc-2.3.4.20040619-r0, 
2.6.7-gentoo-r9) 
================================================================= 
System uname: 2.6.7-gentoo-r9 i686 mobile AMD Athlon(tm) XP 2500+ 
Gentoo Base System version 1.5.1 
distcc 2.16 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) 
[enabled] 
ccache version 2.3 [enabled] 
Autoconf: sys-devel/autoconf-2.59-r4 
Automake: sys-devel/automake-1.8.5-r1 
ACCEPT_KEYWORDS="x86 ~x86" 
AUTOCLEAN="yes" 
CFLAGS="-O3 -march=athlon-4 -O3 -fomit-frame-pointer -funroll-loops -pipe" 
CHOST="i686-pc-linux-gnu" 
COMPILER="gcc3" 
CONFIG_PROTECT="/etc /lib/modules /usr/NX/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.1/share/config /usr/kde/3.2/share/config /usr/kde/3.3/share/config /usr/kde/3/share/config/usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/bind /var/qmail/control /var/spool/fax/etc /var/vpopmail/domains /var/vpopmail/etc" 
CONFIG_PROTECT_MASK="/etc/afs/C /etc/afs/afsws /etc/gconf /etc/terminfo /etc/env.d" 
CXXFLAGS="-O3 -march=athlon-4 -O3 -fomit-frame-pointer -funroll-loops -pipe" 
DISTDIR="/usr/portage/distfiles" 
FEATURES="autoaddcvs buildpkg ccache distcc sandbox" 
GENTOO_MIRRORS="ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/" 
MAKEOPTS="-j2" 
PKGDIR="/usr/portage/packages" 
PORTAGE_TMPDIR="/var/tmp" 
PORTDIR="/usr/portage" 
PORTDIR_OVERLAY="/usr/local/portage" 
SYNC="rsync://rsync.gentoo.org/gentoo-portage" 
USE="3dnow X aalib acl acpi afs aim alsa apache2 apm arts audiofile avi berkdb 
bidi bonobo caps cdparanoia cdr codecs crypt cscope cups curl cyrus dga 
directfb divx4linux doc dts dvd dvdr edl emacs encode esd ethereal evo f77 
faad fam fbcon fbdev fdftk fftw flac flash fltk foomaticdb freetds gb gcj gdbm 
ggi gif gimpprint gmp gnome gnutls gphoto2 gpm gps gstreamer gtk gtk2 gtkhtml 
guile icq idea imagemagic imagemagick imap imlib informix innodb ipv6 jabber 
jack jack-tmpfs java javamail jikes jks joystick jpeg junit kde kerberos 
ladcca lcms ldap libcaca libg++ libgda libwww linguas_de lirc live lzo mad 
maildir maildrop mailwrapper matroska mbox mcal memlimit mikmod mmx motif 
mozcalendar mozilla mozsvg mpeg mpi msn mysql mythtv nas ncurses netcdf 
network neural nls oav objc oci8 odbc offensive oggvorbis opengl oscar oss pam 
pcmcia pcsc-lite pda pdflib perl pic plotutils png pnp postgres ppds prelude 
procmail python qt quicktime readline rtc ruby samba sasl scanner sdl slang 
slp smartcard smime sndfile snmp socks5 speex spell sse ssl svg svga szip 
tcltk tcpd tetex tga theora tiff transcode truetype usb v4l v4l2 vda vhosts 
wifi wmf wxwindows x86 xinerama xml xml2 xmms xosd xprint xv xvid yahoo yaz 
zlib"
Comment 1 Sven Rubben 2004-08-09 10:48:22 UTC
Same thing happens to me with gnustep-base/gnustep-back-0.8.5-r1.

The only gnustep packages I have are:
# equery list "gnustep*" 
Searching for package 'gnustep*' in all categories among:
 * installed packages
[I--] [  ] gnustep-base/gnustep-make-1.6.0 (0)
[I--] [  ] gnustep-base/gnustep-base-1.6.0 (0)
[I--] [  ] gnustep-base/gnustep-gui-0.8.5-r1 (0)
Comment 2 mccary 2004-09-09 16:18:45 UTC
i confirm this error, except i am trying to emerge gnustep-back-0.8.5-r1.
Comment 3 Hans-Christian Armingeon 2004-09-10 09:01:10 UTC
Can somebody successfully compile gnustep-base/gnustep-back-0.8.8 ?

Hello maintainer, still living? [I don't want to offend you, even when chances are high that I did]

Johnny
Comment 4 Armando Di Cianno (RETIRED) gentoo-dev 2004-09-10 10:58:24 UTC
Hello, yes, I'm still alive; no offense taken, it was a fair question.  I actually just joined up at the end of June to take care of the GNUstep, and related, ebuilds.  I seriously use it everyday, so I am quite serious about good support for it in Gentoo.

I had-had my newest ebuilds pretty much done, but 1.10 release of -make and -base were recently releases (ebuilds done, not in portage yet), and I'm getting together a good base of apps to include in the first major upload.  The problem is , the old ebuilds and gnustep.eclass have so many problems, that I'm hesitant to try and fix them at all.

Expect some sort of update recently.  If -gui and -back reach a stable release before I'm done with the slew of changes I'm making to have fully compliant ebuilds, then I will add those in as well (cvs pull-and-tar versions at the moment.)  I have been saying this for a while, but keep your fingers crossed, things will soon get in there.  I hope I'm not a liar this time! ;-)
Comment 5 Hans-Christian Armingeon 2004-09-10 11:05:15 UTC
Thanks.

Johnny
Comment 6 Armando Di Cianno (RETIRED) gentoo-dev 2004-09-23 20:38:21 UTC
newer package available