Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 588182 - gnome-3.20 doesn't honor mouse natural scrolling setting
Summary: gnome-3.20 doesn't honor mouse natural scrolling setting
Status: RESOLVED DUPLICATE of bug 580474
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
Depends on:
Reported: 2016-07-06 19:11 UTC by Anton Gubarkov
Modified: 2016-07-24 13:05 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

Mouse and touchpad settings (Снимок экрана от 2016-07-09 12-40-58.png,35.91 KB, image/png)
2016-07-09 09:43 UTC, Anton Gubarkov
Xorg.log (Xorg.0.log,29.59 KB, text/plain)
2016-07-20 13:40 UTC, Anton Gubarkov

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Gubarkov 2016-07-06 19:11:28 UTC
the scrolling always moves the scrollbar not the content. Worked ok in 3.18
Comment 1 Kobboi 2016-07-08 21:01:34 UTC
Using 3.20 for a couple of months now, no idea what you are describing. Did notice some applications scrolling in the wrong direction, but that was only on wayland
Comment 2 Anton Gubarkov 2016-07-09 09:43:45 UTC
Created attachment 440170 [details]
Mouse and touchpad settings

Natural scrolling is enabled
Comment 3 Anton Gubarkov 2016-07-09 09:46:30 UTC
I expect that when I swipe my two fingers over the touchpad, the content of the window moves in the direction I move my fingers. This worked ok in 3.18. 

Now, when I swipe two fingers, I move the scroll bar in the direction of the swipe. The content moves in the opposite direction. This happens now always, regardless of the setting I indicated in the previous screenshot.
Comment 4 Mart Raudsepp gentoo-dev 2016-07-19 15:39:16 UTC
In 3.20 mouse and touchpad settings only work for libinput, so xf86-input-libinput driver in case of Xorg.
Are you using something different? If yes, this is probably a duplicate of bug 580474 where we track on getting this driver chosen better out of the box.
Comment 5 Mart Raudsepp gentoo-dev 2016-07-19 15:39:53 UTC
I believe if you aren't using libinput, gnome-control-center when launched from terminal will spit out a warning there. I would prefer it give a notification in the GUI, but yeah.
Comment 6 Anton Gubarkov 2016-07-20 08:46:02 UTC
indeed, I'm using synaptics

And the gnome-control-center gives a warning in the term

(gnome-control-center:7966): mouse-cc-panel-WARNING **: Detected synaptics X driver, please migrate to libinput
Comment 7 Anton Gubarkov 2016-07-20 10:57:44 UTC
Can you recommend the best way to migrate?

I've changed /ect/portage/make.conf
#INPUT_DEVICES="evdev synaptics"
ans asked to update world with --changed-use

Portage suggested 
[ebuild   R    ] x11-base/xorg-drivers-1.18-r1::gentoo  INPUT_DEVICES="-acecad -aiptek -elographics -evdev* -fpit -hyperpen -joystick -keyboard (-libinput) -mouse -mutouch -penmount -synaptics* -tslib -vmmouse -void -wacom" VIDEO_CARDS="intel nvidia -amdgpu -apm -ast -chips -cirrus -dummy -epson -fbdev -fglrx (-freedreno) (-geode) -glint -i128 (-i740) -mach64 -mga -neomagic -nouveau -nv (-omap) (-omapfb) -qxl -r128 -radeon -radeonsi -rendition -s3 -s3virge -savage -siliconmotion -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx (-tegra) -tga -trident -tseng -vesa -via -virtualbox -vmware (-voodoo)" 0 KiB

I wonder what blocks my libinput input device spec from make.conf.
Comment 8 Anton Gubarkov 2016-07-20 13:39:55 UTC
I tried to remove xf86-input-evdev xf86-input-synaptics and emerged xf86-input-libinput.

As a result, my touchpad stopped working. 
When I run gnome on wayland, touchpad works ok, natural scroll works ok, but gnome is very unstable.
Comment 9 Anton Gubarkov 2016-07-20 13:40:42 UTC
Created attachment 441212 [details]
Comment 10 Mart Raudsepp gentoo-dev 2016-07-20 17:30:57 UTC
I think libinput stuff from INPUT_DEVICES might still be stable masked due to missing stabilizations for some arches or something. You can just install the driver without having it pulled in via meta packages from INPUT_DEVICES, as you seem to have done by now.
I don't know about non-working touchpads, they should work fine with xf86-input-libinput to my knowledge. What stuff do you have in /etc/X11/xorg.conf and /etc/X11/xorg.conf.d/ ?
Comment 11 Anton Gubarkov 2016-07-20 18:22:18 UTC
no /etc/X11/xorg.conf

r9-008cln log # cat  /etc/X11/xorg.conf.d/*
# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "us,ru"
        Option "XkbVariant" ","
Section "Files"
	ModulePath "/usr/lib64/xorg/modules"
# Example xorg.conf.d snippet that assigns the touchpad driver
# to all touchpads. See xorg.conf.d(5) for more information on
# InputClass.
# DO NOT EDIT THIS FILE, your distribution will likely overwrite
# it when updating. Copy (and rename) this file into
# /etc/X11/xorg.conf.d first.
# Additional options may be added in the form of
#   Option "OptionName" "value"
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
#       MatchDevicePath "/dev/input/event*"

Section "InputClass"
        Identifier "touchpad ignore duplicates"
        MatchIsTouchpad "on"
        MatchOS "Linux"
        MatchDevicePath "/dev/input/mouse*"
        Option "Ignore" "on"

# This option enables the bottom right corner to be a right button on clickpads
# and the right and middle top areas to be right / middle buttons on clickpads
# with a top button area.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Default clickpad buttons"
        MatchDriver "synaptics"
#        Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
        Option "SoftButtonAreas" "0 0 0 0 0 0 0 0"
#        Option "SecondarySoftButtonAreas" "58% 0 0 8% 42% 58% 0 8%"
	Option "PalmDetect" "true"

# This option disables software buttons on Apple touchpads.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Disable clickpad buttons on Apple touchpads"
        MatchProduct "Apple|bcm5974"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "0 0 0 0 0 0 0 0"
Section "Module"
#    Load           "glx"
#    Load           "extmod"
#    Load           "record"
#    Load           "dbe"
#    Load           "dri"
#    Load           "dri2"
    Disable        "noveau"
    Disable        "xinerama"

# from

Section "InputClass"
    Identifier "Plantronics"
    MatchVendor "Plantronics"
    Option "ButtonMapping" "0"
Comment 12 Mart Raudsepp gentoo-dev 2016-07-20 18:30:24 UTC
that cat * doesn't show what part is from what file.
Mostly wondering from what file and why the part with this chunk is from:

Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
Comment 13 Anton Gubarkov 2016-07-20 19:24:26 UTC
I don't remember why this snippet was there... The file dated back 2014. 
I have removed it and my touchpad works as expected now. Thanks!
Comment 14 Pacho Ramos gentoo-dev 2016-07-24 13:05:57 UTC

*** This bug has been marked as a duplicate of bug 580474 ***