Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 588176 - app-text/pdftk broken after @world update
Summary: app-text/pdftk broken after @world update
Status: RESOLVED DUPLICATE of bug 562568
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Java team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-06 16:48 UTC by gentoo
Modified: 2017-05-14 07:27 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gentoo 2016-07-06 16:48:54 UTC
PdfTk got broken while updating the system with emerge -uDN @world.
After the emerge:

mfld@home $ pdftk
pdftk: error while loading shared libraries: libgcj.so.14: cannot open shared object file: No such file or directory

The package only depends on gcc, and requires the libgcj library at runtime:

mfld@home $ equery g pdftk
 * Searching for pdftk ...

 * dependency graph for app-text/pdftk-2.02
 `--  app-text/pdftk-2.02  amd64 
   `--  sys-devel/gcc-4.9.3  (sys-devel/gcc) amd64  [gcj]
[ app-text/pdftk-2.02 stats: packages (2), max depth (1) ]

But the version 14 of that library was not more present.

Problem solved by emerging manually with emerge -1 pdftk, to force the update of the libgjc reference to the right & latest version.
Comment 1 Dennis Schridde 2017-05-13 16:12:10 UTC
Could you please change the subject to include "app-text/pdftk" and the actual error message?
Comment 2 gentoo 2017-05-14 07:26:35 UTC
The problem reported here is already tracked by the more general issue https://bugs.gentoo.org/show_bug.cgi?id=562568, that explains that pdftk actually depends on gcj that has been removed from gcc package.
Comment 3 gentoo 2017-05-14 07:27:09 UTC

*** This bug has been marked as a duplicate of bug 562568 ***