Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 588126 - media-sound/meterbridge-0.9.3 : jf_meters.c:(.text+<snip>): undefined reference to `set_rgba'
Summary: media-sound/meterbridge-0.9.3 : jf_meters.c:(.text+<snip>): undefined referen...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Professional Audio Applications Maintainers
URL:
Whiteboard:
Keywords:
: 566484 (view as bug list)
Depends on:
Blocks: gcc-5
  Show dependency tree
 
Reported: 2016-07-06 07:10 UTC by Toralf Förster
Modified: 2016-07-26 09:04 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-history.txt (emerge-history.txt,337.74 KB, text/plain)
2016-07-06 07:10 UTC, Toralf Förster
Details
environment (environment,101.63 KB, text/plain)
2016-07-06 07:10 UTC, Toralf Förster
Details
media-sound:meterbridge-0.9.3:20160705-235442.log (media-sound:meterbridge-0.9.3:20160705-235442.log,13.18 KB, text/plain)
2016-07-06 07:10 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2016-07-06 07:10:43 UTC
x86_64-pc-linux-gnu-gcc -Wall -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT  -DPKG_DATA_DIR=\"/usr/share/meterbridge\" -march=native -O2 -pipe  -Wl,-O1 -Wl,--as-needed -o meterbridge main.o linedraw.o vu_meters.o ppm_meters.o dpm_meters.o jf_meters.o scope.o envelopes.o find_image.o gl_utils.o -lm -ljack -lpthread -lSDL -lpthread -lGL -lSDL_image -lm -lpthread 
jf_meters.o: In function `gfx_thread_jf':
jf_meters.c:(.text+0x41a): undefined reference to `set_rgba'
collect2: error: ld returned 1 exit status
make[2]: *** [Makefile:362: meterbridge] Error 1
make[2]: Leaving directory '/var/tmp/portage/media-sound/meterbridge-0.9.3/work/meterbridge-0.9.3/src'


$ cat emerge-info.txt
  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named amd64-plasma-unstable_20160630-090750) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------

  make.conf: USE="pax_kernel xtpax -cdinstall -oci8 -bindist alsa cairo cddb dvb extraengine -ffmpeg ftp glamor gstreamer gtk gudev ibus jadetex -kerberos latex ldap logrotate minizip modplug mpeg mssql pcre16 postgres pwquality python rdoc sdl sourceview sql sqlite -ssl system-ffmpeg system-libs system-llvm tcl thinkpad tls usb usbredir v4l2 -vala -wav wxwidgets xa xkb xz ziffy"

  -----------------------------------------------------------------

Portage 2.3.0 (python 3.4.4-final-0, default/linux/amd64/13.0/desktop/plasma, gcc-5.4.0, glibc-2.23-r2, 4.5.7-hardened-r7 x86_64)
=================================================================
System uname: Linux-4.5.7-hardened-r7-x86_64-Intel-R-_Core-TM-_i7-3770_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16155844 total,   2903916 free
KiB Swap:   16777212 total,  16717832 free
Timestamp of repository gentoo: Tue, 05 Jul 2016 22:02:41 +0000
sh bash 4.3_p46
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p46::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.0-r1::gentoo
dev-lang/python:          2.7.11-r2::gentoo, 3.4.4::gentoo
dev-util/cmake:           3.5.2-r1::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.2-r1::gentoo
sys-apps/openrc:          0.21.1::gentoo
sys-apps/sandbox:         2.10-r2::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.9.6-r4::gentoo, 1.10.3-r2::gentoo, 1.11.6-r2::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo, 5.4.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.6::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: 1

local
    location: /usr/local/portage
    masters: gentoo
    priority: 2

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/grs/systems.conf /etc/omega.conf /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.3/conf /var/lib/hsqldb /var/rancid/.cloginrc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--verbose-conflicts --color=n --nospinner --tree --quiet-build"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox parallel-fetch preserve-libs protect-owned sandbox sfperms strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cddb cdr cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvb dvd dvdr emboss encode exif extraengine fam firefox flac fortran ftp gdbm gif glamor gpm gstreamer gtk gudev ibus iconv ipv6 jadetex jpeg kde kipi latex lcms ldap libnotify logrotate mad minizip mmx mmxext mng modplug modules mp3 mp4 mpeg mssql multilib ncurses nls nptl ogg opengl openmp pam pango pax_kernel pcre pcre16 pdf phonon plasma png policykit postgres ppds pwquality python qml qt3support qt4 qt5 rdoc readline sdl seccomp semantic-desktop session sourceview spell sql sqlite sse sse2 startup-notification svg system-ffmpeg system-libs system-llvm tcl tcpd thinkpad tiff tls truetype udev udisks unicode upower usb usbredir v4l2 vorbis widgets wxwidgets x264 xa xattr xcb xcomposite xinerama xkb xml xscreensaver xtpax xv xvid xz ziffy zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2016-07-06 07:10:50 UTC
Created attachment 439836 [details]
emerge-history.txt
Comment 2 Toralf Förster gentoo-dev 2016-07-06 07:10:52 UTC
Created attachment 439838 [details]
environment
Comment 3 Toralf Förster gentoo-dev 2016-07-06 07:10:55 UTC
Created attachment 439840 [details]
media-sound:meterbridge-0.9.3:20160705-235442.log
Comment 4 Erik Mackdanz gentoo-dev 2016-07-26 02:40:42 UTC
Bad linkage patched in 557adf681b85f1673b3c6bc19e605b2c92f0e3ad
Comment 5 Erik Mackdanz gentoo-dev 2016-07-26 02:46:37 UTC
*** Bug 566484 has been marked as a duplicate of this bug. ***
Comment 6 Tobias Klausmann gentoo-dev 2016-07-26 09:04:09 UTC
Shouldn't the .h also be patched, for consistency?