Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 588058 - [science overlay] sci-libs/arpack-3.1.5 - can't reemerge arpack after removal of cblas-reference
Summary: [science overlay] sci-libs/arpack-3.1.5 - can't reemerge arpack after removal...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-05 09:18 UTC by Juergen Rose
Modified: 2016-10-09 15:05 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Rose 2016-07-05 09:18:39 UTC
I removed cblas-reference with 'emerge -v --depclean cblas-reference'.
The subsequent 'emerge -p @preserved-rebuild' want to reinstall the following packages:

root@sysresccd:/(4)# emerge -p @preserved-rebuild

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] sci-libs/arpack-3.1.5 
[ebuild   R    ] sci-libs/armadillo-6.700.5 
[ebuild   R    ] sci-libs/iml-1.0.5 
[ebuild   R    ] sci-libs/linbox-1.3.2-r2 
[ebuild   R    ] sci-libs/cholmod-2.1.2 
[ebuild   R    ] sci-mathematics/sage-7.2 
...

The reinstallation atleast of arpack fails due to missing lapack:

root@sysresccd:/(12)# MAKEOPTS=-j1 emerge -v1 arpack

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] sci-libs/arpack-3.1.5::gentoo  USE="doc examples -mpi -static-libs" 0 KiB
...
checking for dummy main to link with Fortran 77 libraries... none
checking for Fortran 77 name-mangling scheme... lower case, underscore, no extra underscore
checking for sgemm_ in -lf77blas... yes
checking for cheev_... no
checking for cheev_ in -llapack... no
checking for cheev_ in -llapack_rs6k... no
configure: error: Cannot find LAPACK libraries


I have atlas and mkl installed:
root@sysresccd:/(15)# qlist -Iv atlas mkl
sci-libs/atlas-3.11.38-r1
sci-libs/mkl-11.3.2.181


eselect-lapack is not installed and I can not installe it due to conflicts with several other packages:
root@sysresccd:/(13)# qlist -Iv eselect-lapack
root@sysresccd:/(14)# emerge -pv1  eselect-lapack

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] app-eselect/eselect-lapack-0.1::gentoo  0 KiB
[blocks B      ] app-eselect/eselect-lapack ("app-eselect/eselect-lapack" is blocking sci-libs/gsl-2.1, virtual/lapack-3.6, sci-libs/mkl-11.3.2.181)
[blocks B      ] app-eselect/eselect-lapack ("app-eselect/eselect-lapack" is blocking sci-libs/atlas-3.11.38-r1)

Total: 1 package (1 new), Size of downloads: 0 KiB
Conflict: 2 blocks (2 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sci-libs/mkl-11.3.2.181:0/0::science, installed) pulled in by
    sci-libs/mkl required by (sci-libs/armadillo-6.700.5:0/6::science, installed)
    sci-libs/mkl required by (dev-python/numexpr-2.5:0/0::gentoo, installed)
    sci-libs/mkl[int64?,abi_x86_32(-)?,abi_x86_64(-)?] (sci-libs/mkl[abi_x86_64(-)]) required by (virtual/blas-2.1-r5:0/0::science, installed)
    sci-libs/mkl[int64?,abi_x86_32(-)?,abi_x86_64(-)?] (sci-libs/mkl[abi_x86_64(-)]) required by (virtual/lapack-3.6:0/0::science, installed)

  (app-eselect/eselect-lapack-0.1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    eselect-lapack

  (sci-libs/atlas-3.11.38-r1:0/0::science, installed) pulled in by
    sci-libs/atlas[lapack] required by (sci-libs/armadillo-6.700.5:0/6::science, installed)

  (sci-libs/gsl-2.1:0/19::science, installed) pulled in by
    sci-libs/gsl required by (sci-mathematics/gmp-ecm-6.4.4-r2:0/0::sage-on-gentoo, installed)
    sci-libs/gsl:0= required by (dev-python/cvxopt-1.1.8:0/0::sage-on-gentoo, installed)
    >=sci-libs/gsl-1.15 required by (media-video/guvcview-2.0.3:0/0::gentoo, installed)
...
  (virtual/lapack-3.6:0/0::science, installed) pulled in by
    =virtual/lapack-3.6 required by (sci-libs/arpack-3.1.5:0/0::gentoo, installed)
    virtual/lapack required by (sci-libs/cholmod-2.1.2:0/0::gentoo, installed)
    virtual/lapack required by (dev-python/cvxopt-1.1.8:0/0::sage-on-gentoo, installed)
...


I tried to reemerge mkl, which fails due to bug https://bugs.gentoo.org/show_bug.cgi?id=587338. 

I will now try to reemerge atlas.
Comment 1 François Bissey 2016-07-16 20:26:59 UTC
You are using the science overlay. lapack from the science overlay uses the alternatives framework inside eselect. It doesn't use a separate `eselect-lapack` module.
It looks like you have atlas eselected for blas but nothing for lapack. What does
eselect lapack list
reports?