Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 587902 - net-misc/guacamole-server-0.9.9 : /.../ undefined reference to `dlopen'
Summary: net-misc/guacamole-server-0.9.9 : /.../ undefined reference to `dl...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Andreas Schürch
Depends on:
Blocks: gcc-5
  Show dependency tree
Reported: 2016-07-03 18:45 UTC by Toralf Förster
Modified: 2016-07-12 09:11 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

emerge-history.txt (emerge-history.txt,247.05 KB, text/plain)
2016-07-03 18:45 UTC, Toralf Förster
environment (environment,93.16 KB, text/plain)
2016-07-03 18:45 UTC, Toralf Förster
net-misc:guacamole-server-0.9.9:20160703-180710.log (net-misc:guacamole-server-0.9.9:20160703-180710.log,35.83 KB, text/plain)
2016-07-03 18:45 UTC, Toralf Förster

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2016-07-03 18:45:25 UTC
/bin/sh ../../libtool  --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc -Werror -Wall -pedantic -I../../src/common -I../../src/libguac -march=native -O2 -pipe -lpthread  -Wl,-O1 -Wl,--as-needed -o guacd guacd-daemon.o guacd-client.o guacd-client-map.o guacd-conf-args.o guacd-conf-file.o guacd-conf-parse.o guacd-log.o  ../../src/common/ ../../src/libguac/ 
libtool: link: x86_64-pc-linux-gnu-gcc -Werror -Wall -pedantic -I../../src/common -I../../src/libguac -march=native -O2 -pipe -Wl,-O1 -Wl,--as-needed -o .libs/guacd guacd-daemon.o guacd-client.o guacd-client-map.o guacd-conf-args.o guacd-conf-file.o guacd-conf-parse.o guacd-log.o  ../../src/common/.libs/libguac_common.a /var/tmp/portage/net-misc/guacamole-server-0.9.9/work/guacamole-server-0.9.9/s
/var/tmp/portage/net-misc/guacamole-server-0.9.9/work/guacamole-server-0.9.9/src/libguac/.libs/ undefined reference to `dlopen'

$ cat emerge-info.txt

  This is an unstable amd64 chroot image (named amd64-13.0-unstable_20160630-190015) at a hardened host acting as a tinderbox.


  make.conf: USE="pax_kernel xtpax -cdinstall -oci8 -bindist btrfs cairo cddb cgi cgoups clang consolekit cups dot drmkms ecc egl eglfs ftp graphtft gtk gtk3 havege introspection -kerberos lapack latex llvm lzma melt -mp3 mssql multimedia multitarget mysql mysqli offensive ogg openssl pdo pkcs11 postscript sdl source sourceview spice sqlite3 -ssl -swscale system-cairo system-ffmpeg system-jpeg tk uml uxa v4l2 xetex xinetd zenmap"


Portage 2.3.0 (python 3.4.4-final-0, default/linux/amd64/13.0, gcc-5.4.0, glibc-2.23-r2, 4.5.7-hardened-r7 x86_64)
System uname: Linux-4.5.7-hardened-r7-x86_64-Intel-R-_Core-TM-_i7-3770_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16155844 total,    800440 free
KiB Swap:   16777212 total,  16734248 free
Timestamp of repository gentoo: Sun, 03 Jul 2016 15:42:34 +0000
sh bash 4.3_p46
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p46::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.0-r1::gentoo
dev-lang/python:          2.7.11-r2::gentoo, 3.4.4::gentoo
sys-apps/baselayout:      2.2-r1::gentoo
sys-apps/openrc:          0.21.1::gentoo
sys-apps/sandbox:         2.10-r2::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.9.6-r4::gentoo, 1.11.6-r2::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo, 5.4.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r2::gentoo

    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://
    priority: 1

    location: /usr/local/portage
    masters: gentoo
    priority: 2

ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=native -O2 -pipe"
CONFIG_PROTECT="/etc /etc/omega.conf /usr/share/config /var/rancid/.cloginrc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/apache2-php7.0/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cgi-php7.0/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/php/cli-php7.0/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
EMERGE_DEFAULT_OPTS="--verbose-conflicts --color=n --nospinner --tree --quiet-build"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox parallel-fetch preserve-libs protect-owned sandbox sfperms strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS=" rsync:// rsync://"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
USE="acl amd64 berkdb btrfs bzip2 cairo cddb cgi cgoups clang cli consolekit cracklib crypt cups cxx dot dri drmkms ecc egl eglfs fortran ftp gdbm graphtft gtk gtk3 havege iconv introspection ipv6 lapack latex llvm lzma melt mmx mmxext modules mssql multilib multimedia multitarget mysql mysqli ncurses nls nptl offensive ogg openmp openssl pam pax_kernel pcre pdo pkcs11 postscript readline sdl seccomp session source sourceview spice sqlite3 sse sse2 system-cairo system-ffmpeg system-jpeg tcpd tk uml unicode uxa v4l2 xattr xetex xinetd xtpax zenmap zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 Toralf Förster gentoo-dev 2016-07-03 18:45:31 UTC
Created attachment 439580 [details]
Comment 2 Toralf Förster gentoo-dev 2016-07-03 18:45:34 UTC
Created attachment 439582 [details]
Comment 3 Toralf Förster gentoo-dev 2016-07-03 18:45:36 UTC
Created attachment 439584 [details]
Comment 4 Andreas Schürch gentoo-dev 2016-07-04 07:26:36 UTC
Do other (c/c++) things still build for you? - Looks like a damaged glibc!?
Comment 5 Toralf Förster gentoo-dev 2016-07-04 09:04:06 UTC
(In reply to Andreas Schürch from comment #4)
oh yes :
tinderbox@ms-magpie ~ $ qlop -u -l -f amd64-13.0-unstable_20160630-190015/var/log/emerge.log | grep -c 'Jul  4'

currently builds:

    Mon Jul  4 10:47:24 2016  >>> emerge (1 of 3) sci-physics/thepeg-1.9.2 to /
    Mon Jul  4 10:56:23 2016  >>> emerge (2 of 3) sci-physics/looptools-2.8 to /
    Mon Jul  4 10:57:04 2016  >>> emerge (3 of 3) sci-physics/herwig++-2.7.1-r1 to /
Comment 6 Andreas Schürch gentoo-dev 2016-07-04 14:43:25 UTC
I tried to reproduce this error, but it works for me in every tried config.
(amd64-nonmultilib-stage3 chroot updated to ~amd64)
What is so special with your chroot?!? -I don't think it has to do with the hardened-kernel on the host!?
Why does it happen in that chroot, but it didn't happen on the other chroot from bug 587386?
I don't see strange c/ld/use flags nor anything else obvious... Do you use flags per package or something that isn't shown in your emerge --info here?!?
Comment 7 Toralf Förster gentoo-dev 2016-07-05 08:02:45 UTC
(In reply to Andreas Schürch from comment #6)
well, it builds at 3#6 chroot images - so I'd assume a USE flag combination - therefore I wouldn't blame the hardened for that.

FWIW this image is based on default/linux/amd64/13.0 and not a default/linux/amd64/13.0/no-multilib

I could schedule a setup of a new one image with the same USE flags if needed.
Comment 8 Andreas Schürch gentoo-dev 2016-07-05 10:48:47 UTC
(In reply to Toralf Förster from comment #7)
> I could schedule a setup of a new one image with the same USE flags if
> needed.
Yes please, as I rebuilt world already with gcc 5.4.0 and the USEs and flags from your emerge --info above and still couldn't reproduce.
Comment 9 Toralf Förster gentoo-dev 2016-07-09 09:18:42 UTC
(In reply to Andreas Schürch from comment #8)
new image, same use flags, same emerge packages list :

/bin/sh ../../libtool  --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc -Werror -Wall -pedantic -I../../src/common -I../../src/libguac -march=native -O2 -pipe -lpthread  -Wl,-O1 -Wl,--as-needed -o guacd guacd-daemon.o guacd-client.o guacd-client-map.o guacd-conf-args.o guacd-conf-file.o guacd-conf-parse.o guacd-log.o  ../../src/common/ ../../src/libguac/
libtool: link: x86_64-pc-linux-gnu-gcc -Werror -Wall -pedantic -I../../src/common -I../../src/libguac -march=native -O2 -pipe -Wl,-O1 -Wl,--as-needed -o .libs/guacd guacd-daemon.o guacd-client.o guacd-client-map.o guacd-conf-args.o guacd-conf-file.o guacd-conf-parse.o guacd-log.o  ../../src/common/.libs/libguac_common.a /var/tmp/portage/net-misc/guacamole-server-0.9.9/work/guacamole-server-0.9.9/src/libguac/.libs/ ../../src/libguac/.libs/ -lcairo -ljpeg -lpng -lpthread -lossp-uuid -lwebp
/var/tmp/portage/net-misc/guacamole-server-0.9.9/work/guacamole-server-0.9.9/src/libguac/.libs/ undefined reference to `dlopen'
/var/tmp/portage/net-misc/guacamole-server-0.9.9/work/guacamole-server-0.9.9/src/libguac/.libs/ undefined reference to `dlclose'
/var/tmp/portage/net-misc/guacamole-server-0.9.9/work/guacamole-server-0.9.9/src/libguac/.libs/ undefined reference to `dlerror'
/var/tmp/portage/net-misc/guacamole-server-0.9.9/work/guacamole-server-0.9.9/src/libguac/.libs/ undefined reference to `dlsym'
collect2: error: ld returned 1 exit status
make[2]: *** [Makefile:503: guacd] Error 1
Comment 10 Andreas Schürch gentoo-dev 2016-07-11 19:27:10 UTC
I'm a bit baffled... I could reproduce it now with a multilib stage and USE=-ssl!
I will look into it...
Comment 11 Andreas Schürch gentoo-dev 2016-07-12 09:11:12 UTC
Ok, we just depend on USE=ssl if the multilib USE is set.
That should do it for now... :-)

Thanks for reporting!