Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 58790 - wget isn't required in the macos profile's system definition.
Summary: wget isn't required in the macos profile's system definition.
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: PPC All
: High minor (vote)
Assignee: osx porters
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-07-29 08:26 UTC by Ed Schouten
Modified: 2005-02-06 13:33 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ed Schouten 2004-07-29 08:26:39 UTC
Hello guys,

I've installed Gentoo for Mac OS on my PowerBook. It all works great, but I have a comment on the profile used.

Because Mac OS doesn't have 'wget' installed by default, FETCHCOMMAND and RESUMECOMMAND in the profile are changed to 'curl'. Because you get 'wget' by default when running 'emerge system', it would be nicer to see FETCHCOMMAND listed in make.conf, so you can change it back to 'wget' easier.

Reproducible: Always
Steps to Reproduce:
1. Install Gentoo for Mac OS

Actual Results:  
RESUMECOMMAND and FETCHCOMMAND are defined in
/usr/portage/profiles/default-macos-10.3/make.defaults

Expected Results:  
RESUMECOMMAND and FETCHCOMMAND should not be defined in
/usr/portage/profiles/default-macos-10.3/make.defaults
Comment 1 Brian Harring gentoo-dev 2004-07-29 08:33:18 UTC
Err... curl is what's available initially.  Pulling in wget shouldn't be required in the profile like it is.

What you're after is having portage determine that wget is available, and override the existing fetchcommand/resumecommand... which isn't going to happen w/out a lot of argueing regarding the usefulness of it.

Directing this to osx since it's an issue w/ their profile.
Comment 2 Pieter Van den Abeele (RETIRED) gentoo-dev 2004-07-29 09:22:58 UTC
The situation is:

both make.globals and make.conf have the FETCH thing set to curl because that one is installed out of the box. wget is fancier, and the request is to have globals set to wget and .conf set to curl initially, to allow this to be changed more easily later on. 

I've put wget and nano in the system profile, to make give the system the gentoo feel, and maybe make things easier documentation wise. Ideas, thoughts?
Comment 3 Hasan Khalil (RETIRED) gentoo-dev 2004-08-11 00:54:33 UTC
If it's not really required, should it even be in system? Many gentoo users don't want the bloat. I think it should be an option (to emerge wget and use it with portage thereafter).

Anyone else have thoughts on this?
Comment 4 Pieter Van den Abeele (RETIRED) gentoo-dev 2004-08-11 15:27:46 UTC
I'll remove wget from the profile. 

Pieter
Comment 5 Kito (RETIRED) gentoo-dev 2004-12-01 18:42:21 UTC
done.
Comment 6 Hasan Khalil (RETIRED) gentoo-dev 2005-02-06 13:33:25 UTC
Closing out bugs that've been resolved for a while now...