Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 587376 - dev-util/eric-5.5.2 failed on src_install
Summary: dev-util/eric-5.5.2 failed on src_install
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal major with 2 votes (vote)
Assignee: Qt Bug Alias
URL:
Whiteboard:
Keywords: PATCH, PMASKED
: 594302 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-06-28 07:11 UTC by Mike Hiretsky
Modified: 2016-12-21 05:17 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch for the eric-5.5.2.ebuild (eric-5.5.2.ebuild.patch,143 bytes, patch)
2016-07-13 19:34 UTC, Per Pascal Seeland
Details | Diff
A patch that replaces the faulty sed command (eric-5.install.patch,4.54 KB, patch)
2016-07-13 19:36 UTC, Per Pascal Seeland
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Hiretsky 2016-06-28 07:11:24 UTC
Failed to install eric-5.5.2

Traceback (most recent call last):
  File "install.py", line 1421, in <module>
    main(sys.argv)
  File "install.py", line 1400, in main
    res = installEric()
  File "install.py", line 757, in installEric
    os.path.join(dst, "eric5" + marker + ".png"))
  File "install.py", line 562, in shutilCopy
    shutil.copy(src, dst)
  File "/usr/lib/python2.7/shutil.py", line 119, in copy
    copyfile(src, dst)
  File "/usr/lib/python2.7/shutil.py", line 82, in copyfile
    with open(src, 'rb') as fsrc:
IOError: [Errno 2] No such file or directory: u'./icons/default/eric5.png'

Reproducible: Always

Steps to Reproduce:
1. emerge =dev-utils/eric-5.5.2




A bug appeared in the ebuild with bugfix https://bugs.gentoo.org/show_bug.cgi?id=542488. Probably command sed -i -e 's/eric"/eric5"/' changes not only eric.*.png files.
Comment 1 7of9 2016-06-29 16:50:53 UTC
Can confirm, suffering from exactly the same issue.
Comment 2 Per Pascal Seeland 2016-07-13 19:34:24 UTC
Created attachment 440618 [details, diff]
Patch for the eric-5.5.2.ebuild

Apply a patch that replaces the sed command
Comment 3 Per Pascal Seeland 2016-07-13 19:36:40 UTC
Created attachment 440620 [details, diff]
A patch that replaces the faulty sed command

The patch replaces the sed command. The issue with the sed command is that it matches to much. Installing breaks, because the source directory for the images is changed from eric to eric5.
Comment 4 Brian Evans Gentoo Infrastructure gentoo-dev 2016-09-19 17:14:22 UTC
*** Bug 594302 has been marked as a duplicate of this bug. ***
Comment 5 Pál Csányi 2016-09-19 18:32:40 UTC
I can confirm too.
Comment 6 Israel G. Lugo 2016-10-18 18:54:13 UTC
Same here, dev-util/eric-5.5.2 breaks with:

Installing eric5 ...
Could not install './default.e4k'.
Could not install './default_Mac.e4k'.
An internal error occured.  Please report all the output of the program,
including the following traceback, to eric-bugs@eric-ide.python-projects.org.

Traceback (most recent call last):
  File "install.py", line 1421, in <module>
    main(sys.argv)
  File "install.py", line 1400, in main
    res = installEric()
  File "install.py", line 757, in installEric
    os.path.join(dst, "eric5" + marker + ".png"))
  File "install.py", line 562, in shutilCopy
    shutil.copy(src, dst)
  File "/usr/lib64/python2.7/shutil.py", line 119, in copy
    copyfile(src, dst)
  File "/usr/lib64/python2.7/shutil.py", line 82, in copyfile
    with open(src, 'rb') as fsrc:
IOError: [Errno 2] No such file or directory: u'./icons/default/eric5.png'

There is already a patch by Per Pascal Grube, for 3 months now. Can we please have this fix incorporated to Portage?
Comment 7 Dmitry Meleshkin 2016-12-06 17:21:29 UTC
I can confirm this bug
Comment 8 Jonas Stein gentoo-dev 2016-12-07 21:37:00 UTC
confirmed by several users.
Comment 9 Davide Pesavento gentoo-dev 2016-12-21 05:17:43 UTC
eric:5 has been masked for removal. Please use eric:6