Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 586732 - >=www-servers/tomcat-8.0.36 - failure in compile phase: ${S}/build.xml:1616: javadoc doesn't support the "failonwarning" attribute
Summary: >=www-servers/tomcat-8.0.36 - failure in compile phase: ${S}/build.xml:1616: ...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Java team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-22 16:26 UTC by Markus Wernig
Modified: 2018-08-06 21:22 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ebuild error output (tomcat-8.0.36-build-errors.txt,38.61 KB, text/plain)
2016-06-22 16:29 UTC, Markus Wernig
Details
complete build log (build.log.xz,4.74 KB, application/x-xz)
2016-06-27 22:35 UTC, Markus Wernig
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Wernig 2016-06-22 16:26:54 UTC
www-servers/tomcat-8.0.36 does not ebuild because of errors in javadoc call.

There are multiple errors in the output (see below).

The errors also appear when ebuilding 8.0.35, but there they don't result in the build being aborted. No errors in 8.0.33.

USE flags for www-servers/tomcat:

 U I
 + - doc
 + - extra-webapps
 - - source
 - - test



Reproducible: Always




$ emerge --info
Portage 2.3.0_rc1 (python 3.4.4-final-0, default/linux/amd64/13.0/desktop/plasma, gcc-5.3.0, glibc-2.23-r2, 4.6.2-gentoo x86_64)
=================================================================
System uname: Linux-4.6.2-gentoo-x86_64-Intel-R-_Core-TM-_i7-6820HQ_CPU_@_2.70GHz-with-gentoo-2.2
KiB Mem:    16230364 total,   6881416 free
KiB Swap:    8388604 total,   8388604 free
Timestamp of repository gentoo: Wed, 22 Jun 2016 15:00:01 +0000
sh bash 4.3_p42-r2
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p42-r2::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.0-r1::gentoo
dev-lang/python:          2.7.11-r2::gentoo, 3.4.4::gentoo, 3.5.1-r2::gentoo
dev-util/cmake:           3.5.2-r1::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.21::gentoo
sys-apps/sandbox:         2.10-r2::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.11.6-r2::gentoo, 1.12.6-r1::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo, 5.3.0::gentoo, 5.4.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.6::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync                                                                                                                                 
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage                                                                                                
    priority: -1000                                                                                                                                  
                                                                                                                                                     
ACCEPT_KEYWORDS="amd64 ~amd64"                                                                                                                       
ACCEPT_LICENSE="*"                                                                                                                                   
CBUILD="x86_64-pc-linux-gnu"                                                                                                                         
CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"                                                                                                
CHOST="x86_64-pc-linux-gnu"                                                                                                                          
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/hsqldb"                                                                                                                                      
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask-write=y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://sunsite.cnlab-switch.ch/ftp/mirror/gentoo/ ftp://sunsite.cnlab-switch.ch/mirror/gentoo/ http://de-mirror.org/gentoo/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 bash-completion berkdb bluetooth branding bzip2 cairo caps cdda cdr cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif glamor gpm gstreamer gtk http iconv imap ipv6 jce jpeg kde kipi lcms ldap libav libnotify mad mmx mmxext mng modules mp3 mp4 mpeg multilib multitarget ncurses networkmanager nls nptl nss ogg opengl openmp otr pam pango pcre pcsc pcsc-lite pdf phonon plasma png policykit ppds pulseaudio qml qt3support qt4 qt5 readline sdl seccomp session spell sse sse2 sse3 sse4_1 sse4_2 ssl ssse3 startup-notification subversion svg synaptics tcpd tiff tools truetype udev udisks unicode upower usb utils vorbis widgets wxwidgets x264 xattr xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ABI_X86="64 32" ALSA_CARDS="hda-intel usb-audio" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="all" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc efi-64" INPUT_DEVICES="keyboard mouse evdev synaptics void alps" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en de" NETBEANS_MODULES="apisupport java javafx profiler websvccommon enterprise" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="fbdev intel nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Markus Wernig 2016-06-22 16:29:01 UTC
Created attachment 438446 [details]
ebuild error output
Comment 2 Alex Xu (Hello71) 2016-06-26 15:42:54 UTC
please attach full build.log. xz compress if necessary.
Comment 3 Markus Wernig 2016-06-27 22:35:52 UTC
Created attachment 439028 [details]
complete build log

complete build log added
Comment 4 Martin von Gagern 2016-06-28 06:42:35 UTC
Same here for www-servers/tomcat-9.0.0_alpha8. I guess it requires a newer version of Ant or something like that to build its documentation:

javadoc:

BUILD FAILED
/var/tmp/portage/www-servers/tomcat-9.0.0_alpha8/work/apache-tomcat-9.0.0.M8-src
/build.xml:1444: javadoc doesn't support the "failonwarning" attribute

Total time: 17 seconds
 * ERROR: www-servers/tomcat-9.0.0_alpha8::gentoo failed (compile phase):
 *   eant failed

This is using dev-java/ant-1.9.2 and dev-java/ant-core-1.9.2 installed 2013, which seems pretty ancient compared to ant 1.9.7 available upstream. So perhaps bug #571110 will already resolve this. If so, declaring an updated dependency in the tomcat ebould would help.
Comment 5 James Le Cuirot gentoo-dev 2016-06-30 13:54:48 UTC
This is only the second time I've heard of the old Ant version not working. I guess this will give us the push we need. :)
Comment 6 jeremiah 2016-07-15 21:50:45 UTC
It's not entirely the Ant version.

>=ant-1.9.5_pre::poly-c gets rid of the failonwarning issue that is present on >=tomcat:8.5, as that was introduced in ant-1.9.4 (see <https://archive.apache.org/dist/ant/RELEASE-NOTES-1.9.4.html>), but the failure to recognize javax.wsdl* and javax.xml.rpc* packages remains.

javax.wsdl* and javax.xml.rpc* are JavaEE packages, so it may be some JavaEE component dependency.

BTW, >=tomcat:8.5 needs to be marked with "doc? >=dev-java/ant-core-1.9.4".
Comment 7 jeremiah 2016-07-23 16:41:31 UTC
I've filed the failonwarning issue as bug 589546. Please revert the title as the failonwarning issue was not a part of the original bug report and is not present in tomcat-8.0.36
Comment 8 silver_ghost 2018-04-20 17:35:58 UTC
I have the same problem with www-servers/tomcat-9.0.5[extra-webapps].
Comment 9 silver_ghost 2018-04-20 21:18:05 UTC
(In reply to silver_ghost from comment #8)
> I have the same problem with www-servers/tomcat-9.0.5[extra-webapps].

There is mistake. There should be www-servers/tomcat-9.0.5[doc].
Comment 10 Max Nokhrin 2018-08-06 21:22:01 UTC
(In reply to jeremiah from comment #6)
> BTW, >=tomcat:8.5 needs to be marked with "doc? >=dev-java/ant-core-1.9.4".

I guess a new bug to bump ant-core to latest version is also required.  bug #662980 has been filed