Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 586712 - dev-libs/apr-1.5.2 - libtool: Version mismatch error. This is libtool 2.4.6, but the definition of this LT_INIT comes from libtool 2.4.2.
Summary: dev-libs/apr-1.5.2 - libtool: Version mismatch error. This is libtool 2.4.6,...
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-22 14:16 UTC by Martin Mokrejš
Modified: 2021-03-31 23:33 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,38.15 KB, text/plain)
2016-07-11 09:16 UTC, Martin Mokrejš
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Mokrejš 2016-06-22 14:16:48 UTC
/scratch/mmokrejs/gentoo/bin/bash /scratch/mmokrejs/gentoo/var/tmp/portage/dev-libs/apr-1.5.2/work/apr-1.5.2/libtool --silent --mode=compile x86_64-pc-linux-gnu-gcc -pthread  -O2 -pipe -O2 -pipe -march=native -DHAVE_CONFIG_H  -DLINUX -D_REENTRANT -D_GNU_SOURCE   -I./include -I/scratch/mmokrejs/gentoo/var/tmp/portage/dev-libs/apr-1.5.2/work/apr-1.5.2/include/arch/unix -I./include/arch/unix -I/scratch/mmokrejs/gentoo/var/tmp/portage/dev-libs/apr-1.5.2/work/apr-1.5.2/include/arch/unix -I/scratch/mmokrejs/gentoo/var/tmp/portage/dev-libs/apr-1.5.2/work/apr-1.5.2/include -I/scratch/mmokrejs/gentoo/var/tmp/portage/dev-libs/apr-1.5.2/work/apr-1.5.2/include/private -I/scratch/mmokrejs/gentoo/var/tmp/portage/dev-libs/apr-1.5.2/work/apr-1.5.2/include/private  -o passwd/apr_getpass.lo -c passwd/apr_getpass.c && touch passwd/apr_getpass.lo
/scratch/mmokrejs/gentoo/bin/bash /scratch/mmokrejs/gentoo/var/tmp/portage/dev-libs/apr-1.5.2/work/apr-1.5.2/libtool --silent --mode=compile x86_64-pc-linux-gnu-gcc -pthread  -O2 -pipe -O2 -pipe -march=native -DHAVE_CONFIG_H  -DLINUX -D_REENTRANT -D_GNU_SOURCE   -I./include -I/scratch/mmokrejs/gentoo/var/tmp/portage/dev-libs/apr-1.5.2/work/apr-1.5.2/include/arch/unix -I./include/arch/unix -I/scratch/mmokrejs/gentoo/var/tmp/portage/dev-libs/apr-1.5.2/work/apr-1.5.2/include/arch/unix -I/scratch/mmokrejs/gentoo/var/tmp/portage/dev-libs/apr-1.5.2/work/apr-1.5.2/include -I/scratch/mmokrejs/gentoo/var/tmp/portage/dev-libs/apr-1.5.2/work/apr-1.5.2/include/private -I/scratch/mmokrejs/gentoo/var/tmp/portage/dev-libs/apr-1.5.2/work/apr-1.5.2/include/private  -o strings/apr_cpystrn.lo -c strings/apr_cpystrn.c && touch strings/apr_cpystrn.lo
libtool: Version mismatch error.  This is libtool 2.4.6, but the
libtool: definition of this LT_INIT comes from libtool 2.4.2.
libtool: You should recreate aclocal.m4 with macros from libtool 2.4.6
libtool: and run autoconf again.
make[1]: *** [Makefile:135: tools/gen_test_char.lo] Error 63
make[1]: *** Waiting for unfinished jobs....
libtool: Version mismatch error.  This is libtool 2.4.6, but the
libtool: definition of this LT_INIT comes from libtool 2.4.2.
libtool: You should recreate aclocal.m4 with macros from libtool 2.4.6
libtool: and run autoconf again.
make[1]: *** [/scratch/mmokrejs/gentoo/var/tmp/portage/dev-libs/apr-1.5.2/work/apr-1.5.2/build/apr_rules.mk:206: passwd/apr_getpass.lo] Error 63
libtool: Version mismatch error.  This is libtool 2.4.6, but the
libtool: definition of this LT_INIT comes from libtool 2.4.2.
libtool: You should recreate aclocal.m4 with macros from libtool 2.4.6
libtool: and run autoconf again.
make[1]: *** [/scratch/mmokrejs/gentoo/var/tmp/portage/dev-libs/apr-1.5.2/work/apr-1.5.2/build/apr_rules.mk:206: strings/apr_cpystrn.lo] Error 63
make[1]: Leaving directory '/scratch/mmokrejs/gentoo/var/tmp/portage/dev-libs/apr-1.5.2/work/apr-1.5.2'
make: *** [/scratch/mmokrejs/gentoo/var/tmp/portage/dev-libs/apr-1.5.2/work/apr-1.5.2/build/apr_rules.mk:118: all-recursive] Error 1
 * ERROR: dev-libs/apr-1.5.2::gentoo_prefix failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=dev-libs/apr-1.5.2::gentoo_prefix'`,
 * the complete build log and the output of `emerge -pqv '=dev-libs/apr-1.5.2::gentoo_prefix'`.
 * The complete build log is located at '/scratch/mmokrejs/gentoo/var/tmp/portage/dev-libs/apr-1.5.2/temp/build.log'.
 * The ebuild environment file is located at '/scratch/mmokrejs/gentoo/var/tmp/portage/dev-libs/apr-1.5.2/temp/environment'.
 * Working directory: '/scratch/mmokrejs/gentoo/var/tmp/portage/dev-libs/apr-1.5.2/work/apr-1.5.2'
 * S: '/scratch/mmokrejs/gentoo/var/tmp/portage/dev-libs/apr-1.5.2/work/apr-1.5.2'

>>> Failed to emerge dev-libs/apr-1.5.2, Log file:



# emerge --info '=dev-libs/apr-1.5.2::gentoo_prefix'
Portage 2.2.28-prefix (python 2.7.11-final-0, prefix/linux/amd64, gcc-5.3.0, unavailable, 2.6.32-573.12.1.el6.Bull.88.x86_64 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-2.6.32-573.12.1.el6.Bull.88.x86_64-x86_64-Intel-R-_Xeon-R-_CPU_E5-2670_0_@_2.60GHz-with-redhat-6.4-Santiago
KiB Mem:   131942764 total, 111566940 free
KiB Swap:   65536128 total,  64440608 free
Timestamp of repository gentoo_prefix: Mon, 20 Jun 2016 21:57:56 +0000
sh bash 4.3_p39
ld GNU ld (Gentoo 2.24 p1.3) 2.24
app-shells/bash:          4.3_p39::gentoo_prefix
dev-java/java-config:     2.2.0-r3::gentoo_prefix
dev-lang/perl:            5.24.0-r1::gentoo_prefix
dev-lang/python:          2.7.11::gentoo_prefix
dev-util/cmake:           3.5.2-r1::gentoo_prefix
dev-util/pkgconfig:       0.29.1::gentoo_prefix
sys-devel/autoconf:       2.69::gentoo_prefix
sys-devel/automake:       1.13.4::gentoo_prefix, 1.14.1::gentoo_prefix, 1.15::gentoo_prefix
sys-devel/binutils:       2.24-r2::gentoo_prefix
sys-devel/gcc:            4.2.4-r2::gentoo_prefix, 4.8.5::gentoo_prefix, 4.9.3::gentoo_prefix, 5.3.0::gentoo_prefix
sys-devel/gcc-config:     1.8-r1::gentoo_prefix
sys-devel/libtool:        2.4.6-r1::gentoo_prefix
sys-devel/make:           4.2.1::gentoo_prefix
sys-kernel/linux-headers: 4.6::gentoo_prefix (virtual/os-headers)
Repositories:

gentoo_prefix
    location: /scratch/mmokrejs/gentoo/usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.prefix.bitzolder.nl/gentoo-portage-prefix
    priority: -1000
    aliases: gentoo

science
    location: /scratch/mmokrejs/gentoo/var/lib/layman/science
    masters: gentoo_prefix
    priority: 0

haskell
    location: /scratch/mmokrejs/gentoo/var/lib/layman/haskell
    masters: gentoo_prefix
    priority: 1

x-layman
    location: /scratch/mmokrejs/gentoo/var/lib/layman
    masters: gentoo_prefix
    priority: 2

ACCEPT_KEYWORDS="~amd64-linux"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -O2 -pipe -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -O2 -pipe -march=native"
DISTDIR="/scratch/mmokrejs/gentoo/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs case-insensitive-fs collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles force-prefix merge-sync news parallel-fetch preserve-libs protect-owned sfperms strict unknown-features-warn unmerge-logs unmerge-orphans unprivileged userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.wheel.sk/ http://ftp.fi.muni.cz/pub/linux/gentoo/ http://gentoo.mirror.web4u.cz/ rsync://gentoo.mirror.dkm.cz/gentoo/ ftp://gentoo.mirror.web4u.cz/"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j4"
PKGDIR="/scratch/mmokrejs/gentoo/usr/portage/packages"
PORTAGE_CONFIGROOT="/scratch/mmokrejs/gentoo/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/scratch/mmokrejs/gentoo/var/tmp"
USE="amd64 berkdb bzip2 cli cracklib crypt cxx dri fortran gdbm iconv ipv6 mmx mmxext modules ncurses nls nptl openmp pcre prefix prefix-guest readline seccomp session sse sse2 ssl tcpd unicode zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Martin Mokrejš 2016-07-11 09:16:54 UTC
Created attachment 440338 [details]
build.log
Comment 2 Martin Pecka 2016-11-10 09:16:26 UTC
I confirm this installing gentoo prefix on gentoo with apr-1.5.2, which seems to be exactly the same as the reporter's environment.
Comment 3 Martin Pecka 2016-11-10 09:57:50 UTC
The same happens when installing apr-1.5.0-r2 or apr-1.5.1-r1
Comment 4 Martin Pecka 2016-11-10 11:33:31 UTC
Workaround: downgrade libtool to 2.4.2-r1 :)
Comment 5 Martin Mokrejš 2016-11-10 12:15:22 UTC
 $ emerge =sys-devel/libtool-2.4.2-r1
                                                                                                                                                             [ebuild     UD ] sys-devel/libtool-2.4.2-r1 [2.4.6-r2] USE="-static-libs% {-test%}" 
[blocks B      ] <sys-devel/libtool-2.4.3-r2:2 ("<sys-devel/libtool-2.4.3-r2:2" is blocking dev-libs/libltdl-2.4.6)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-devel/libtool-2.4.2-r1:2/2::gentoo, ebuild scheduled for merge) pulled in by
    sys-devel/libtool required by (dev-scheme/guile-2.0.12-r1:12/22::gentoo, installed)
    =sys-devel/libtool-2.4.2-r1

  (dev-libs/libltdl-2.4.6:0/0::gentoo, installed) pulled in by
    dev-libs/libltdl:0/0= required by (dev-scheme/guile-2.0.12-r1:12/22::gentoo, installed)
    dev-libs/libltdl:0 required by (media-gfx/graphviz-2.38.0-r1:0/0::gentoo, installed)
    dev-libs/libltdl:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-libs/libltdl:0[abi_x86_64(-)]) required by (sys-cluster/openmpi-1.10.3-r2:0/0::science, installed)

Seems I will better wait for a proper fix of "some package".
Comment 6 Philippe Michaud-Boudreault 2017-01-09 09:20:20 UTC
I am affected by this as well. Running a Gentoo prefix on macOS Sierra.
apr is the package that bombs currently.
Comment 7 Philippe Michaud-Boudreault 2017-01-09 09:23:11 UTC
$ emerge =sys-devel/libtool-2.4.2-r1

This seems to work as a workaround.
Comment 8 Peter Draganov 2018-01-13 20:39:14 UTC
I have the same problem and I cannot apply workaround:
# emerge --ask --oneshot =sys-devel/libtool-2.4.2-r1

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "=sys-devel/libtool-2.4.2-r1".
Comment 9 Sam James archtester gentoo-dev Security 2021-03-31 23:33:02 UTC
(In reply to Philippe Michaud-Boudreault from comment #6)
> I am affected by this as well. Running a Gentoo prefix on macOS Sierra.
> apr is the package that bombs currently.

I've installed apr-1.7.0-r1 on macOS Big Sur successfully. Is this still an issue?