Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 586324 - media-libs/libmodplug: fails to play some xm files correctly
Summary: media-libs/libmodplug: fails to play some xm files correctly
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-18 19:36 UTC by Nick
Modified: 2016-06-21 20:45 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
The music file which plays improperly in applications using libmodplug (mph.xm,7.56 KB, audio/x-xm)
2016-06-18 19:36 UTC, Nick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nick 2016-06-18 19:36:14 UTC
Created attachment 437964 [details]
The music file which plays improperly in applications using libmodplug

The background music in games-arcade/vor does not play correctly (some of the notes do not play) when the modplug use flag is set in media-libs/
sdl-mixer instead of the mikmod use flag (it plays correctly if it is compiled using libmikmod).

The problem also occurs when playing the file in vlc (uses libmodplug).
Comment 1 Mr. Bones. (RETIRED) gentoo-dev 2016-06-21 20:45:08 UTC
Looks like a clear bug in libmodplug.

https://www.a1k0n.net/2015/11/09/javascript-ft2-player.html plays the file correctly. ;-)