Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 586112 (kf-5.23.0-stable) - KDE Frameworks 5.23.0 stabilisation
Summary: KDE Frameworks 5.23.0 stabilisation
Status: RESOLVED FIXED
Alias: kf-5.23.0-stable
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks: plasma-5.6.5-stable
  Show dependency tree
 
Reported: 2016-06-16 18:25 UTC by Michael Palimaka (kensington)
Modified: 2016-07-25 18:33 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
kf-5.23.0-stabilisation v1 (kf-5.23.0-stabilisation,2.36 KB, text/plain)
2016-06-16 18:25 UTC, Michael Palimaka (kensington)
Details
kf-5.23.0-stabilisation v2 (kf-5.23.0-stabilisation,2.38 KB, text/plain)
2016-06-19 15:17 UTC, Michael Palimaka (kensington)
Details
kf-5.23.0-stabilisation v3 (kf-5.23.txt,2.38 KB, text/plain)
2016-07-04 18:33 UTC, Johannes Huber
Details
kf-5.23.0-stabilisation v4 (kf-5.23.txt,2.38 KB, text/plain)
2016-07-18 20:29 UTC, Johannes Huber
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Palimaka (kensington) gentoo-dev 2016-06-16 18:25:07 UTC
Created attachment 437754 [details]
kf-5.23.0-stabilisation v1

Please see attached list.

Target KEYWORDS="amd64 x86".
Comment 1 Andreas Sturmlechner gentoo-dev 2016-06-16 22:56:16 UTC
toralf pointed out that oxygen-5.5.5 and breeze-5.5.5 depend on <frameworkintegration-5.22.0 (platformtheme was split out into plasma-integration). It might be possible to introduce revbumps with plasma-integration dependency, even if it pulls in 5.6.4 - at least a test build was fine (no runtime testing).
Comment 2 Michael Palimaka (kensington) gentoo-dev 2016-06-19 15:17:35 UTC
Created attachment 438026 [details]
kf-5.23.0-stabilisation v2

Add new kde-frameworks revision bumps.
Comment 3 Johannes Huber gentoo-dev 2016-07-04 18:33:54 UTC
Created attachment 439714 [details]
kf-5.23.0-stabilisation v3

Fix package atoms: s/~/=/
Comment 4 Johannes Huber gentoo-dev 2016-07-04 18:36:37 UTC
@Frank: If you want there is another list to check :). Thanks in advance.
Comment 5 Frank Krömmelbein 2016-07-05 16:39:57 UTC
(In reply to Johannes Huber from comment #4)
> @Frank: If you want there is another list to check :). Thanks in advance.

Tested on stable AMD64 system.
No objections from my side :-)
Comment 6 Frank Krömmelbein 2016-07-06 08:46:28 UTC
I must sadly correct myself. On my second stable PC, portage complains about kde-frameworks/frameworkintegration-5.23.0

caused by the RDEPEND line:
<kde-frameworks/frameworkintegration-5.22.0

in the  kde-plasma/breeze-5.5.5 and kde-plasma/oxygen-5.5.5 Ebuilds.

Is this specific dependency in the two files really necessary?
Comment 7 Michael Palimaka (kensington) gentoo-dev 2016-07-06 10:22:56 UTC
(In reply to Frank Krömmelbein from comment #6)
> I must sadly correct myself. On my second stable PC, portage complains about
> kde-frameworks/frameworkintegration-5.23.0
> 
> caused by the RDEPEND line:
> <kde-frameworks/frameworkintegration-5.22.0
> 
> in the  kde-plasma/breeze-5.5.5 and kde-plasma/oxygen-5.5.5 Ebuilds.
> 
> Is this specific dependency in the two files really necessary?

IIRC yes as some bits were moved around between different packages upstream.
Comment 8 Johannes Huber gentoo-dev 2016-07-18 20:29:20 UTC
Created attachment 441044 [details]
kf-5.23.0-stabilisation v4

bug #589054 =kde-frameworks/karchive-5.23-r1
Comment 9 Michael Palimaka (kensington) gentoo-dev 2016-07-25 18:33:51 UTC
amd64/x86 stable