Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 585794 - app-misc/gcalcli should depend on <=dev-python/oauth2client-1.4.12
Summary: app-misc/gcalcli should depend on <=dev-python/oauth2client-1.4.12
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Robin Johnson
Keywords: NeedPatch
Depends on:
Reported: 2016-06-13 09:46 UTC by Aurélien Francillon
Modified: 2017-08-15 23:36 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---

gcalcli-3.3.2.ebuild.patch (gcalcli-3.3.2.ebuild.patch,472 bytes, patch)
2016-06-13 10:10 UTC, Aurélien Francillon
Details | Diff
The patch. (gcalcli-3.3.2-run-flow.patch,1.28 KB, patch)
2016-09-22 00:01 UTC, jorgicio
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Aurélien Francillon 2016-06-13 09:46:26 UTC

gcalcli does not work with later versions of oauthclient:

this was fixed by upstream install script:

But needs to be reflected in gentoo ebuild (until a long term solution is found).

Ebuild patch attached.

Best regards, 
Comment 1 Michael 'veremitz' Everitt 2016-06-13 10:02:57 UTC
Gentoo ebuild doesn't currently depend on oauthclient, but perhaps this could be facilitated with an appropriate USE flag.

No patch currently attached, but passing to Rob anyway.
Comment 2 Aurélien Francillon 2016-06-13 10:10:21 UTC
Created attachment 437352 [details, diff]

Sorry here is the patch.
Comment 3 Aurélien Francillon 2016-06-13 10:11:55 UTC
In addition to this, it seem that dev-python/google-api-python-client-1.3.1 is needed, instead of the stable 1.5.0. With the stable version the following error occurs (non fatal): 

# gcalcli agenda                                                                                                                        WARNING:root:No module named contrib.locked_file
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/googleapiclient/discovery_cache/", line 38, in autodetect
    from . import file_cache
  File "/usr/lib64/python2.7/site-packages/googleapiclient/discovery_cache/", line 32, in <module>
    from oauth2client.contrib.locked_file import LockedFile
ImportError: No module named contrib.locked_file

These seem to be related problems.
Comment 4 jorgicio 2016-09-22 00:01:29 UTC
Created attachment 447274 [details, diff]
The patch.

There's a workaround to fix that and doesn't need an specific version of oauth2client.

There goes the patch. Tested here with oauth2client-2.2.0 and working.
Comment 5 Aurélien Francillon 2017-01-31 15:58:17 UTC
Thanks for the patch, this worked well for me. 

However this does not seem to be a perfect solution (problems with newer auths):

This has been solved in the tree... not sure which release includes this patch however.
Comment 6 Mateusz Lenik 2017-02-18 20:05:59 UTC
Looks like version 3.4.0 was released. Maybe adding ebuild for 3.4.0 solves this without forcing an old version of the library?
Comment 7 Ferenc Erki 2017-03-25 21:37:50 UTC
I've opened bug 613850 for a version bump to 3.4.0, including a fix for this too.
Comment 8 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2017-08-15 23:36:48 UTC