Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 58569 - php-gtk should not require apache
Summary: php-gtk should not require apache
Status: RESOLVED DUPLICATE of bug 1343
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: PPC Linux
: High normal (vote)
Assignee: PHP Bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-07-27 10:35 UTC by Michal Suchanek
Modified: 2005-07-17 13:06 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michal Suchanek 2004-07-27 10:35:31 UTC
I did emerge pptp-php-gtk and apache got installed.
It is fine to use php without a web server or in cgi only (server independent) so unless I have chosen apache support I should not get it.


Reproducible: Didn't try
Steps to Reproduce:
1.
2.
3.




# emerge info
Portage 2.0.50-r9 (default-ppc-2004.1, gcc-3.3.3, glibc-2.3.3.20040420-r0,
2.6.7-gentoo-r11)
=================================================================
System uname: 2.6.7-gentoo-r11 ppc 745/755
Gentoo Base System version 1.5.1
distcc 2.16 powerpc-unknown-linux-gnu (protocols 1 and 2) (default port 3632)
[disabled]
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.5-r1
ACCEPT_KEYWORDS="ppc ~ppc"
AUTOCLEAN="yes"
CFLAGS="-O3 -mcpu=750 -pipe"
CHOST="powerpc-unknown-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -mcpu=750 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg ccache digest fixpackages"
GENTOO_MIRRORS="ftp://ftp.sh.cvut.cz/MIRRORS/gentoo/gentoo
http://ftp.snt.utwente.nl/pub/os/linux/gentoo
http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/
ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo
ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X Xaw3d alsa audiofile berkdb bzlib caps cdr cpdflib crypt cups curl
dedicated dga dio directfb divx4linux doc dvb dvd dvdr encode esd ethereal fam
fbcon flac flash foomaticdb ftp gb gd gdbm ggi gif gnome gphoto2 gpm gstreamer
gtk gtk2 gtkhtml guile hardened hardenedphp iconv icq imagemagick imap imlib
ipv6 jabber jpeg kde lcms ldap libgda libwww linguas_cs linguas_cs_CZ.UTF-8
linguas_cz_CZ linguas_en linguas_en_US linguas_en_US.UTF-8 mad maildir mikmod
ming mitshm mmap motif mozilla mpeg nas ncurses netcdf nls nocd offensive
oggvorbis opengl oss pam pcntl pcre pdflib perl pic pie png posix ppc ppds
python quicktime readline recode ruby samba sasl sdl session shared slang slp
snmp sockets speex spell ssl svg sysvipc szip tcpd tetex tidy tiff truetype
unicode usb video_cards_rage128 videos vxwindows wmf xinerama xml xml2 xmlrpc
xmms xosd xv xvid zlib"
Comment 1 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2004-08-07 13:17:42 UTC
it's not coming in as part of PHP from what I can find.
php-gtk lists a DEPEND on dev-php/php and an RDEPEND on virtual/php.

perhaps you have mod_php as your virtual/php?
Comment 2 Michal Suchanek 2004-08-09 13:33:41 UTC
Perhaps portage did select mod_php as virtual/php when php was going to be installed.
I think I did not have anything like apache or php brfore I installed the pptp-php-gtk script.
btw if I did have mod_php already I probably would have apache too and it would not get installed.
Comment 3 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2004-08-09 14:02:31 UTC
i can't see anything in the dependancy tree at all that brings apache in.
I'm going to pass this to the dev-portage people.
Comment 4 Marius Mauch (RETIRED) gentoo-dev 2004-08-09 14:50:01 UTC
it's the php-ext-source eclass, it RDEPENDS on virtual/php which points to dev-php/mod_php by default.
(Yes, it's a portage problem that it doesn't recognize the PROVIDE from dev-php/php, feel free to mark it as a dupe of #1343)
Comment 5 Michal Suchanek 2004-08-09 15:32:56 UTC
looks like that

*** This bug has been marked as a duplicate of 1343 ***