Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 584892 - app-office/libreoffice-5.1.2.2: building w/gcc-6: configure: error: KDE version too old
Summary: app-office/libreoffice-5.1.2.2: building w/gcc-6: configure: error: KDE versi...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Office Team
URL:
Whiteboard:
Keywords: PATCH, UPSTREAM
Depends on:
Blocks: gcc-6
  Show dependency tree
 
Reported: 2016-06-03 01:32 UTC by Peter Levine
Modified: 2016-07-03 20:10 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
libreoffice-5.1.2.2-gcc6.patch (libreoffice-5.1.2.2-gcc6.patch,2.18 KB, patch)
2016-06-03 01:32 UTC, Peter Levine
Details | Diff
libreoffice-5.1.2.2-gcc6.patch (libreoffice-5.1.2.2-gcc6.patch,1.07 KB, patch)
2016-06-03 01:41 UTC, Peter Levine
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Levine 2016-06-03 01:32:30 UTC
Created attachment 436234 [details, diff]
libreoffice-5.1.2.2-gcc6.patch

Building app-office/libreoffice-5.1.2.2 with gcc-6.1.0 fails in the configure phase with:

> checking whether KDE is >= 4.2... configure: error: KDE version too old

Fixed upstream: https://cgit.freedesktop.org/libreoffice/core/commit/configure.ac?id=91fcc0032c2d0d343b914dfe3bea0b0bf1589e91
Comment 1 Peter Levine 2016-06-03 01:41:45 UTC
Created attachment 436236 [details, diff]
libreoffice-5.1.2.2-gcc6.patch

No need to patch configure since eautoreconf is always run.
Comment 2 Mark Wright gentoo-dev 2016-06-05 09:24:14 UTC
(In reply to Peter Levine from comment #1)
> Created attachment 436236 [details, diff] [details, diff]
> libreoffice-5.1.2.2-gcc6.patch
> 
> No need to patch configure since eautoreconf is always run.

The same problem occurs with app-office/libreoffice-5.1.3.2 without the patch.  With the patch (id=436236) app-office/libreoffice-5.1.3.2 builds fine with gcc version 6.1.0 (Gentoo Hardened 6.1.0 p1.1), thanks.
Comment 3 Andreas Sturmlechner gentoo-dev 2016-06-05 09:43:05 UTC
Fix is already in libreoffice 5.2 branch, stable branch ebuild available in tree.
Comment 4 Andreas K. Hüttel gentoo-dev 2016-07-03 20:10:54 UTC
(In reply to Andreas Sturmlechner from comment #3)
> Fix is already in libreoffice 5.2 branch, stable branch ebuild available in
> tree.

Backport added to 5.1.4 and 5.1.9999