Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 584848 - x11-misc/shared-mime-info-1.6 : checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool
Summary: x11-misc/shared-mime-info-1.6 : checking for XML::Parser... configure: error:...
Status: RESOLVED DUPLICATE of bug 596664
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-02 12:38 UTC by Toralf Förster
Modified: 2016-10-09 09:54 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
config.log (config.log,18.64 KB, text/plain)
2016-06-02 12:38 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,11.54 KB, text/plain)
2016-06-02 12:38 UTC, Toralf Förster
Details
environment (environment,74.14 KB, text/plain)
2016-06-02 12:38 UTC, Toralf Förster
Details
x11-misc:shared-mime-info-1.6:20160602-002603.log (x11-misc:shared-mime-info-1.6:20160602-002603.log,3.95 KB, text/plain)
2016-06-02 12:38 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2016-06-02 12:38:24 UTC
checking for perl... /usr/bin/perl
checking for perl >= 5.8.1... 5.24.0
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/x11-misc/shared-mime-info-1.6/work/shared-mime-info-1.6/config.log


$ cat emerge-info.txt
  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named amd64-13.0-no-multilib-unstable_20160601-230800) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------

  make.conf: USE="sse2 pax_kernel xtpax -cdinstall -oci8 -bindist aes-ni alisp cups dnssec dot emacs ftp -graphtft gstreamer gtkstyle havege help javafx javaxml kerberos libinput mbox mpeg3 -nls obj odbc php pkcs11 png policykit printsupport qt3support rendering -scripts sockets spice sql -sse4_2 system-libs threads traceroute uml -utils uxa v4l -vala vim vlc widgets X -xcb xmp zenmap zip"

  -----------------------------------------------------------------

Portage 2.2.28 (python 2.7.10-final-0, default/linux/amd64/13.0/no-multilib, gcc-4.9.3, glibc-2.23-r2, 4.5.5-hardened-r2 x86_64)
=================================================================
System uname: Linux-4.5.5-hardened-r2-x86_64-Intel-R-_Core-TM-_i7-3770_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16157888 total,   3307768 free
KiB Swap:   16777212 total,  16726788 free
Timestamp of repository gentoo: Wed, 01 Jun 2016 22:04:54 +0000
sh bash 4.3_p42-r2
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p42-r2::gentoo
dev-lang/perl:            5.24.0::gentoo
dev-lang/python:          2.7.10-r1::gentoo, 3.4.3-r1::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.21::gentoo
sys-apps/sandbox:         2.10-r2::gentoo
sys-devel/autoconf:       2.69-r2::gentoo
sys-devel/automake:       1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo, 5.3.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2-r2::gentoo
sys-kernel/linux-headers: 4.6::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: 1

local
    location: /usr/local/portage
    masters: gentoo
    priority: 2

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--verbose-conflicts --color=n --nospinner --tree --quiet-build"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox parallel-fetch preserve-libs protect-owned sandbox sfperms strict test-fail-continue unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X acl aes-ni alisp amd64 berkdb bzip2 cli cracklib crypt cups cxx dnssec dot dri emacs fortran ftp gdbm gstreamer gtkstyle havege help iconv ipv6 javafx javaxml kerberos libinput mbox mmx mmxext modules mpeg3 ncurses nptl obj odbc openmp pam pax_kernel pcre php pkcs11 png policykit printsupport qt3support readline rendering seccomp session sockets spice sql sse sse2 ssl system-libs tcpd threads traceroute uml unicode uxa v4l vim vlc widgets xattr xmp xtpax zenmap zip zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2016-06-02 12:38:27 UTC
Created attachment 436172 [details]
config.log
Comment 2 Toralf Förster gentoo-dev 2016-06-02 12:38:29 UTC
Created attachment 436174 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2016-06-02 12:38:32 UTC
Created attachment 436176 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2016-06-02 12:38:34 UTC
Created attachment 436178 [details]
x11-misc:shared-mime-info-1.6:20160602-002603.log
Comment 5 Jeroen Roovers gentoo-dev 2016-06-02 12:55:59 UTC

*** This bug has been marked as a duplicate of bug 41124 ***
Comment 6 Toralf Förster gentoo-dev 2016-06-04 19:04:21 UTC
run today into the same issue for a newly setup image:
 amd64-gnome-unstable_20160604-185706
Comment 7 Pacho Ramos gentoo-dev 2016-06-12 11:24:27 UTC
perl-cleaner shouldn't be needed if subslot rebuilds are working ok :/
Comment 8 Toralf Förster gentoo-dev 2016-06-27 13:09:32 UTC
happened today again at image amd64-plasma-unstable_20160627-095633 while upgrading @world for the first time:

>>> Jobs: 103 of 261 complete, 1 running            Load avg: 7.12, 9.67, 9.36
>>> Jobs: 103 of 261 complete, 1 running, 1 failed  Load avg: 7.12, 9.67, 9.36
>>> Jobs: 103 of 261 complete, 1 failed             Load avg: 7.12, 9.67, 9.36

 * Package:    x11-misc/shared-mime-info-1.6
 * Repository: gentoo
 * Maintainer: freedesktop-bugs@gentoo.org
 * USE:        abi_x86_64 amd64 elibc_glibc kernel_linux userland_GNU
 * FEATURES:   preserve-libs sandbox userpriv usersandbox
>>> Unpacking source...
>>> Unpacking shared-mime-info-1.6.tar.xz to /var/tmp/portage/x11-misc/shared-mime-info-1.6/work
>>> Source unpacked in /var/tmp/portage/x11-misc/shared-mime-info-1.6/work
>>> Preparing source in /var/tmp/portage/x11-misc/shared-mime-info-1.6/work/shared-mime-info-1.6 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/x11-misc/shared-mime-info-1.6/work/shared-mime-info-1.6 ...
./configure --prefix=/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --disable-dependency-tracking --disable-silent-rules --libdir=/usr/lib64 --disable-default-make-check --disable-update-mimedb
checking for a BSD-compatible install... /var/tmp/portage/._portage_reinstall_.aiopt6bo/bin/ebuild-helpers/xattr/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
...
checking for msgfmt... /usr/bin/msgfmt
checking for gmsgfmt... /usr/bin/gmsgfmt
checking for perl... /usr/bin/perl
checking for perl >= 5.8.1... 5.24.0
checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool

!!! Please attach the following file when seeking support:
Comment 9 Kent Fredric (IRC: kent\n) gentoo-dev 2016-10-09 09:54:00 UTC

*** This bug has been marked as a duplicate of bug 596664 ***