Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 584348 - app-editors/atom-1.7.4-r1: runtime error: "Uncaught (in promise) Error: Fetching local packages failed."
Summary: app-editors/atom-1.7.4-r1: runtime error: "Uncaught (in promise) Error: Fetch...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Cynede
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-27 16:51 UTC by Dennis Schridde
Modified: 2019-08-04 08:54 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Schridde 2016-05-27 16:51:40 UTC
Atom gets stuck when opening Settings > Updates, showing "Checking for updates…" without progressing any further.

On the console it outputs:

# atom -f                                                                                                                                   
[16219:0527/184443:ERROR:browser_main_loop.cc(203)] Running without the SUID sandbox! See https://code.google.com/p/chromium/wiki/LinuxSUIDSandboxDevelopment for more information on developing with the sandbox on.
App load time: 743ms
[16219:0527/184445:INFO:CONSOLE(52)] "Window load time: 786ms", source: file:///usr/lib64/atom/app.asar/static/index.js (52)
[16219:0527/184446:INFO:CONSOLE(55)] "Linter-Rust: package loaded, ready to get initialized by AtomLinter.", source: $HOME/.atom/packages/linter-rust/lib/init.coffee (55)
[16219:0527/184448:INFO:CONSOLE(21638)] "atom-parinfer v1.14.0 activated", source: $HOME/.atom/packages/Parinfer/lib/atom-parinfer.js (21638)
[16219:0527/184449:INFO:CONSOLE(0)] "/deep/ combinator is deprecated. See https://www.chromestatus.com/features/6750456638341120 for more details.", source:  (0)
[16219:0527/184450:INFO:CONSOLE(0)] "::shadow pseudo-element is deprecated. See https://www.chromestatus.com/features/6750456638341120 for more details.", source:  (0)
[16219:0527/184450:INFO:CONSOLE(695)] "Uncaught (in promise) Error: Fetching local packages failed.", source: /usr/lib64/atom/app.asar/node_modules/settings-view/lib/package-manager.js (695)
[16219:0527/184450:INFO:CONSOLE(695)] "Uncaught (in promise) Error: Fetching local packages failed.", source: /usr/lib64/atom/app.asar/node_modules/settings-view/lib/package-manager.js (695)
[16219:0527/184451:INFO:CONSOLE(113)] "Fetching local packages failed.", source: /usr/lib64/atom/app.asar/node_modules/settings-view/lib/main.js (113)

# emerge --info nodejs electron app-editors/atom
Portage 2.3.0_rc1 (python 2.7.10-final-42, default/linux/amd64/13.0/desktop/plasma/systemd, gcc-5.3.0, glibc-2.23-r2, 4.6.0-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.6.0-gentoo-x86_64-AMD_A10-7800_Radeon_R7,_12_Compute_Cores_4C+8G-with-gentoo-2.2
KiB Mem:    15381060 total,   2073632 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Fri, 27 May 2016 15:15:01 +0000
sh bash 4.3_p42-r2
ld GNU ld (Gentoo 2.25 p1.2) 2.25
ccache version 3.2.5 [disabled]
app-shells/bash:          4.3_p42-r2::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.0::gentoo
dev-lang/python:          2.7.11-r2::gentoo, 3.4.3-r7::gentoo, 3.5.1-r2::gentoo
dev-util/ccache:          3.2.5::gentoo
dev-util/cmake:           3.5.2-r1::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/sandbox:         2.10-r2::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.11.6-r2::gentoo, 1.12.6-r1::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25-r1::gentoo
sys-devel/gcc:            5.3.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.2-r1::gentoo
sys-kernel/linux-headers: 4.6::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r2::gentoo
Repositories:

gentoo
    location: /var/cache/portage/gentoo
    sync-type: rsync
    sync-uri: rsync://rsync.de.gentoo.org/gentoo-portage
    priority: -1000

kde
    location: /var/lib/layman/kde
    sync-type: laymansync
    sync-uri: git://anongit.gentoo.org/proj/kde.git
    masters: gentoo
    priority: 50

sage-on-gentoo
    location: /var/lib/layman/sage-on-gentoo
    sync-type: laymansync
    sync-uri: git://github.com/cschwan/sage-on-gentoo.git
    masters: gentoo science
    priority: 50

science
    location: /var/lib/layman/science
    sync-type: laymansync
    sync-uri: git://anongit.gentoo.org/proj/sci.git
    masters: gentoo
    priority: 50

local
    location: /var/cache/portage/local
    masters: gentoo
    priority: 100

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-pipe -O2 -march=bdver3"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.0/ext-active/ /etc/php/cgi-php7.0/ext-active/ /etc/php/cli-php7.0/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-pipe -O2 -march=bdver3"
DISTDIR="/var/cache/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going --nospinner"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildsyspkg cgroup compressdebug config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox news parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ http://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/ http://distfiles.gentoo.org"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
MAKEOPTS="-j3"
PKGDIR="/var/cache/portage/packages"
PORTAGE_COMPRESS="xz"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac aacplus aacs acl acpi alsa amd64 appindicator archive audit avahi bash-completion bdplus berkdb bluetooth bluray branding bzip2 cairo caps cdda cddb cdio cdr celt cjk cli colord conntrack cracklib crypt cups cxx d3d9 dbus declarative dirac dri dts dvb dvd dvdr egl emboss encode exif fam fax ffmpeg firefox flac fontconfig fortran fribidi gdbm geoclue geolocation gif git glamor gles gmp gpm gstreamer gtk gtk3 harfbuzz ibus iconv ipv6 jpeg jpeg2k kde kipi ladspa latex lcms ldap libinput libnotify libproxy libsecret lua_target_lua5-2 lv2 lz4 lzma lzo mad mercurial mmx mmxext mng modemmanager modplug modules mp3 mp4 mpeg mplayer mtp multilib multitarget mysql ncurses netlink networkmanager nls nptl ogg openal opencl openexr opengl openmax openmp opus pam pango pcap pch pcre pdf phonon plasma png policykit ppds pulseaudio qml qt3support qt4 qt5 readline rtmp samba scanner schroedinger sctp sdl seccomp semantic-desktop session speex spell sse sse2 ssl startup-notification svg systemd tcpd theora threads tiff truetype udev udisks unicode upnp upnp-av upower usb v4l v4l2 vaapi vdpau vorbis vpx wavpack wayland webp widgets x264 x265 xattr xcb xcomposite xinerama xml xrandr xscreensaver xv xvid xz zeroconf zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="stage words flow sheets gemini" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx fma3 fma4 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 xop" DRACUT_MODULES="btrfs caps systemd" ELIBC="glibc" ENLIGHTENMENT_MODULES="*" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="coreboot efi-64 pc" INPUT_DEVICES="joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de en en_GB ar fa tr" LIRC_DEVICES="devinput" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4 pypy pypy3" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="amdgpu radeon radeonsi" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

net-libs/nodejs-5.10.1::gentoo was built with the following:
USE="icu npm snapshot ssl -debug -doc -test" ABI_X86="64" CPU_FLAGS_X86="sse2" PYTHON_TARGETS="python2_7"


dev-util/electron-0.36.12-r1::gentoo was built with the following:
USE="cups proprietary-codecs pulseaudio system-ffmpeg tcmalloc -custom-cflags -gnome -gnome-keyring -hidpi -kerberos -lto (-neon) -pic (-selinux) -test" ABI_X86="64" LINGUAS="ar de en_GB fa tr -am -bg -bn -ca -cs -da -el -es -es_LA -et -fi -fil -fr -gu -he -hi -hr -hu -id -it -ja -kn -ko -lt -lv -ml -mr -ms -nb -nl -pl -pt_BR -pt_PT -ro -ru -sk -sl -sr -sv -sw -ta -te -th -uk -vi -zh_CN -zh_TW"


app-editors/atom-1.7.4-r1::gentoo was built with the following:
USE="" ABI_X86="64"
Comment 1 Dennis Schridde 2016-05-27 16:53:55 UTC
When I switch from the Updates menu to Packages, I see following additional output on the console:
[16219:0527/185227:INFO:CONSOLE(330)] "Fetching local packages failed.", source: /usr/lib64/atom/app.asar/node_modules/settings-view/lib/installed-packages-panel.js (330)
[16219:0527/185227:INFO:CONSOLE(331)] "Uncaught (in promise) TypeError: Cannot read property 'hide' of undefined", source: /usr/lib64/atom/app.asar/node_modules/settings-view/lib/installed-packages-panel.js (331)
Comment 2 Elvis Pranskevichus 2016-05-31 21:06:23 UTC
I cannot reproduce this.

Does "apm upgrade --list" work?  Does this occur with a fresh .atom directory?
Comment 3 Dennis Schridde 2016-06-01 08:02:19 UTC
(In reply to Elvis Pranskevichus from comment #2)
> I cannot reproduce this.
> 
> Does "apm upgrade --list" work?

# apm upgrade --list
Package Updates Available (0)
└── (empty)

Upgrading on the command line worked. Just the Atom editor itself was affected.

>  Does this occur with a fresh .atom
> directory?

I did not try.
Comment 4 Elvis Pranskevichus 2017-03-30 13:19:14 UTC
Please confirm this is still an issue with the latest version of atom in the tree.