Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 584182 - ERROR: net-libs/webkit-gtk-2.10.9::gentoo failed (compile phase)
Summary: ERROR: net-libs/webkit-gtk-2.10.9::gentoo failed (compile phase)
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-26 10:50 UTC by fkhp
Modified: 2016-05-28 15:59 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
info (webkit-gtk.info,5.50 KB, text/plain)
2016-05-26 10:50 UTC, fkhp
Details
pqv (webkit-gtk.pqv,295 bytes, text/plain)
2016-05-26 10:51 UTC, fkhp
Details
log (webkit-gtk.build.log.gz,75.44 KB, application/x-gzip)
2016-05-26 10:54 UTC, fkhp
Details
env (webkit-gtk.env,194.67 KB, text/plain)
2016-05-26 10:54 UTC, fkhp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fkhp 2016-05-26 10:50:54 UTC
Created attachment 435450 [details]
info

`slow_path_next_generic_enumerator_pname' referenced in section `.text' of /var/tmp/portage/net-libs/webkit-gtk-2.10.9/temp/cc1fQ7tA.ltrans0.ltrans.o: defined in discarded section `.text' of Source/JavaScriptCore/CMakeFiles/JavaScriptCore.dir/runtime/CommonSlowPaths.cpp.o (symbol from plugin)
collect2: error: ld returned 1 exit status
ninja: build stopped: subcommand failed.
 * ERROR: net-libs/webkit-gtk-2.10.9::gentoo failed (compile phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line  133:  Called src_compile
 *   environment, line 5138:  Called cmake-utils_src_compile
 *   environment, line 1421:  Called _cmake_execute_optionally 'src_compile'
 *   environment, line  543:  Called enable_cmake-utils_src_compile
 *   environment, line 1909:  Called cmake-utils_src_make
 *   environment, line 1436:  Called _cmake_ninja_src_make
 *   environment, line  599:  Called die
 * The specific snippet of code:
 *       "$@" || die
Comment 1 fkhp 2016-05-26 10:51:44 UTC
Created attachment 435452 [details]
pqv
Comment 2 fkhp 2016-05-26 10:54:14 UTC
Created attachment 435454 [details]
log
Comment 3 fkhp 2016-05-26 10:54:44 UTC
Created attachment 435456 [details]
env
Comment 4 fkhp 2016-05-26 14:00:09 UTC
it still fail after remove -flto -ffat-lto-objects and change -O2 to -O1.
Comment 5 Pacho Ramos gentoo-dev 2016-05-28 15:59:10 UTC
Try on a system recompiled without LTO