Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 583576 - root login or su - required to install dev-libs/cyrus-sasl-2.1.26-r9(r10)
Summary: root login or su - required to install dev-libs/cyrus-sasl-2.1.26-r9(r10)
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: AMD64 Linux
: Normal major (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2016-05-20 12:39 UTC by B Nice
Modified: 2018-02-08 20:08 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description B Nice 2016-05-20 12:39:36 UTC
Unless the system is running under the root login or su -, both versions of sys-libs/cyrus-sasl-2.1.26-r9(r10) fail to unpack.  This is on a ~amd64 system.

The error as a sudo user is:
sudo emerge cyrus-sasl

>>> Emerging (1 of 1) dev-libs/cyrus-sasl-2.1.26-r10::gentoo
* cyrus-sasl-2.1.26.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...
* Using: icedtea-bin-8
>>>Unpacking source...
>>>Unpacking cyrus-sasl-2.1.26.tar.gz to /var/tmp/portage/dev-libs/cyrus-sasl-2.1.26-r10/work

gzip: stdout: Broken pipe
* ERROR: dev-libs/cyrus-sasl-2.1.26-r10::gentoo failed (unpack phase):
*  unpack: failure unpacking cyrus-sasl-2.1.26.tar.gz
* Call stack:
*       ,  line  133:  Called src_unpack
*               environment,  line 5528:  Called default
*,  line  805:  Called default_src_unpack
*,  line  832:  Called __eapi0_src_unpack
*,  line  736:  Called unpack 'cyrus-sasl-2.1.26.tar.gz'
*,  line  386:  Called __unpack_tar 'gzip -d'
*,  line  317:  Called __assert_sigpipe_ok 'unpack: failure unpacking cyrus-sasl-2.1.26.tar.gz'
*,  line   41:  Called __helpers_die 'unpack: failure unpacking cyrus-sasl-2.1.26.tar.gz'
*   line  117:  Called die
* The specific snippet of code:
*              die "$@"
* If you need support, post the output of 'emerge --info'=dev-libs/cyrus-sasl-2.1.26-r10::gentoo'',
* the complete build log and the output of 'emerge -pqv '=dev-libs/cyrus-sasl-2.1.26-r10::gentoo''.
!!! When you file a bug report, please include the following information:
GENTOO_VM=iceadtea-bin-8 CLASSPATH="" JAVA_HOME="/opt/iceadtead-bin-3.0.1"
JAVACFLAGS="-source 1.4 -target 1.4" COMPILER=""
and of course the output of emerge --info =cyrus-sasl-2.1.26

emerge --info

Portage 2.3.0_rc1 (python 3.4.3-final-0, default/linux/amd64/13.0/desktop/plasma, gcc-5.3.0, glibc-2.23-r2, 4.6.0-gentoo x86_64)
System uname: Linux-4.6.60-gentoo-x86_64-Intel-R-_Core-TM-_i5-6200U_CPU_@_2.30GHz-with-gentoo-2.2
KiB Mem:     8096212 total,   2792304 free
KiB Swap:   16777212 total,  16776644 free
Timestamp of repository gentoo: Fri, 20 May 2016 11:00:01 +0000
sh bash 4.3_p42-r2
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p42-r2::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.0::gentoo
dev-lang/python:          2.7.11-r2::gentoo, 3.4.3-r7::gentoo
dev-util/cmake:           3.5.2::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.20.5::gentoo
sys-apps/sandbox:         2.10-r2::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.11.6-r2::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.6::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r2::gentoo

    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000

ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -pipe -march=native"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=native"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
USE="X a52 aac acl acpi alsa also amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cryptsetup cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif glamor gpm gtk iconv ipv6 java jpeg kde kipi lcms ldap libnotify lm_sensors mad mmx mmxext mng modules mp3 mp4 mpeg multilib ncurses networkmanager nls nptl offensive ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds pulseaudio qml qt3support qt4 qt5 readline samba sdl seccomp semantic-desktop session spell sse sse2 ssl startup-notification svg synaptics tcpd tiff truetype udev udisks unicode upnp upower usb vorbis widgets wifi wxwidgets x264 x265 xattr xcb xcomposite xinerama xml xscreensaver xv xvid zeroconf zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 Mike Gilbert gentoo-dev 2016-05-20 19:06:15 UTC
It sounds like you may have some bad permissions on /usr/portage/distfiles/cyrus-sasl-2.1.26.tar.gz. Make sure the portage user has read access to this file.
Comment 2 B Nice 2016-05-20 20:22:32 UTC
I wouldn't think it should make any difference as it's the sudo user who's permissions should matter, but here is the ls -las

5100 -rw-rw-r-- 1 portage portage 5220231 Feb 22 2013 /usr/portage/distfiles/cyrus-sasl-2.1.26.tar.gz

The other files in the folder have the exact same permissions and install using sudo emerge with no issues.
Comment 3 Mike Gilbert gentoo-dev 2016-05-20 21:15:36 UTC
(In reply to B Nice from comment #2)
> I wouldn't think it should make any difference as it's the sudo user who's
> permissions should matter, but here is the ls -las

The unpack phase always runs as the portage user when the userpriv feature is enabled.
Comment 4 Mike Gilbert gentoo-dev 2016-05-20 21:21:33 UTC
This package unpacks without an issue using sudo on my system. This is probably a configuration problem somewhere on your system; maybe you have some odd environment variable set, or some resource limit is killing the tar process.
Comment 5 B Nice 2016-05-20 23:57:45 UTC
It may be, but there are a number of people who are having the same issue who probably don't have the same configuration.

In fact out of four systems I have running Gentoo, only one has the issue.  The only thing that is out of the norm for the system with this issue, is that it is a pure ~amd64 system.  Could it be due to an unstable bzip or tar?
Comment 6 Alex Xu (Hello71) 2016-05-30 14:39:49 UTC
I'm going to wager a guess that either a resource limit or memory is being exceeded.
Comment 7 B Nice 2016-05-30 16:30:58 UTC
That is possible.  I only have 8GB of RAM and 16GB of swap, so it may have exceeded the space available to non-root users.  Since I don't have a quota system set-up on this machine, this e-build managed to do what libreoffice and firefox builds couldn't.

It may be worthwhile to contact the other people on the forum thread to see what their system set-ups are like.
Comment 8 Moran Z. 2017-02-14 10:09:27 UTC
I've Solved This Issue By Re-Building (On Another Computer - with 'buildpkg' FEATURE Turned-On) & Re-Installing (The Resulting Binary Package...) a Few Packages :

bash ( <- This One Seem To Have Actually Caused This Issue )


Also, I've Deleted PORTAGE Temp. Dir. ( e.g. : /var/tmp/portage ) - Thus Enabling a Clean Re-Creation of It By PORTAGE' "emerge".

Comment 9 Róbert Čerňanský 2018-02-08 20:08:40 UTC
Bug still appears.  I've stumbled upon it during profile switch to 17.0 while doing emerge -e @world via ssh then 'su -'.  Using sudo, or screen session did not work either.  Running emerge from remote graphical emacs (eshell) worked for me.


CFLAGS="-O2 -march=core-avx-i -mcx16 -msahf -maes -mpclmul -mpopcnt -mavx -msse4
.2 -msse4.1 -mfsgsbase -mrdrnd -mf16c --param l1-cache-size=32 --param l1-cache-
line-size=64 --param l2-cache-size=3072 -fweb -pipe"

Stable amd64 system.