Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 582686 - sys-block/thin-provisioning-tools-0.5.3: build w/gcc-6 fails: error: cannot convert 'persistent_data::btree<1u, thin_provisioning::device_tree_detail::device_details_traits>::maybe_value {aka boost::optional<thin_provisioning::device_tree_d
Summary: sys-block/thin-provisioning-tools-0.5.3: build w/gcc-6 fails: error: cannot c...
Status: RESOLVED DUPLICATE of bug 598424
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-6
  Show dependency tree
 
Reported: 2016-05-10 20:59 UTC by Peter Levine
Modified: 2017-03-06 22:37 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
thin-provisioning-tools-0.5.3-gcc6.patch (thin-provisioning-tools-0.5.3-gcc6.patch,886 bytes, patch)
2016-05-10 21:04 UTC, Peter Levine
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Levine 2016-05-10 20:59:51 UTC
Using gcc-6* to compile sys-block/thin-provisioning-tools-0.5.3 fails with:


error: cannot convert 'persistent_data::btree<1u, thin_provisioning::device_tree_detail::device_details_traits>::maybe_value {aka boost::optional<thin_provisioning::device_tree_d
Comment 1 Peter Levine 2016-05-10 21:04:01 UTC
Created attachment 433886 [details, diff]
thin-provisioning-tools-0.5.3-gcc6.patch

A patch to compile thin-provisioning-tools-0.5.3 with gcc-6*.  boost::optional doesn't seem to implicitly cast to bool so this patch just applies some explicitly casts.
Comment 2 SpanKY gentoo-dev 2016-05-10 22:52:14 UTC
please test/check thin-provisioning-tools-0.6.1 as that's the latest in the tree.  if that still fails, upstream is github, so it should be trivial for you to fork & get your patch merged there (i got a few PRs accepted in the last few days).
Comment 3 Peter Levine 2016-05-11 01:10:38 UTC
(In reply to SpanKY from comment #2)
> please test/check thin-provisioning-tools-0.6.1 as that's the latest in the
> tree.  if that still fails, upstream is github, so it should be trivial for
> you to fork & get your patch merged there (i got a few PRs accepted in the
> last few days).

Hmmm.  Looks like it was already resolved in git, seemingly for a separate issue, by forcing g++-98 dialect:

https://github.com/jthornber/thin-provisioning-tools/commit/8b792f5c79b68a63afbe155fc3924b3a0a750e24
Comment 4 Oleksii 2016-08-31 15:06:26 UTC
Hello there!

This bug affects me also
Mein output of 'emerge --info'
https://paste.pound-python.org/show/A4dXW34qq4nxwGIg1Bcj

Also I have installed GCC 6.2.0 and sys-block/thin-provisioning-tools-0.6.1
Nothing fixed. Please as was 6.2.0 released, prepare patch.
Thank You!
Comment 5 Peter Levine 2016-08-31 20:32:23 UTC
(In reply to Oleksii from comment #4)
> Hello there!
> 
> This bug affects me also
> Mein output of 'emerge --info'
> https://paste.pound-python.org/show/A4dXW34qq4nxwGIg1Bcj
> 
> Also I have installed GCC 6.2.0 and sys-block/thin-provisioning-tools-0.6.1
> Nothing fixed. Please as was 6.2.0 released, prepare patch.
> Thank You!

Or put thin-provisioning-tools-0.6.2 or thin-provisioning-tools-0.6.3 in the portage tree since this was fixed in 0.6.2-rc3.
Comment 6 Harri Nieminen (Moiman) 2017-03-05 17:46:25 UTC
This is duplicate of bug 598424
Comment 7 SpanKY gentoo-dev 2017-03-06 22:37:16 UTC
(In reply to moikkis from comment #6)

thanks.  this one is older, but that one is fixed, so easier to dupe that way.

*** This bug has been marked as a duplicate of bug 598424 ***