Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 582132 - x11-drivers/xf86-video-virtualbox-4.3.32 fails with emake error. Syntax error in code.
Summary: x11-drivers/xf86-video-virtualbox-4.3.32 fails with emake error. Syntax error...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: AMD64 Linux
: Normal major with 1 vote (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
: 588620 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-05-05 06:26 UTC by disabled_f2d52e90f935aa7979f6b5802d606a2ea8ef2c07
Modified: 2019-09-17 03:38 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
error information (deleted)
2016-05-05 18:55 UTC, disabled_f2d52e90f935aa7979f6b5802d606a2ea8ef2c07
Details

Note You need to log in before you can comment on or make changes to this bug.
Description disabled_f2d52e90f935aa7979f6b5802d606a2ea8ef2c07 2016-05-05 06:26:10 UTC
Not a great experience when your first time you try gentoo, people in irc say you found a bug.

it's a syntax error in the code.  'new' cannot be used as an identifier (i.e. variable name) in C++
Comment 1 Jonas Stein gentoo-dev 2016-05-05 12:06:26 UTC
Thank you for your report. I share your experience. With gentoo you get very young source code and can help developers to improve programs upstream. Most developers do not care about upstream bugs found in debian stable.

This bug should be reported upstream, would you do this?
 Besides that I will assign this bug report to the package maintainer. Perhaps there will be an easy (patch or stabilization) solution too.
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2016-05-05 12:09:58 UTC
Well it's hard to deal with a bug report without having the actual build.log file attached.
I suggest to not report this to upstream unless it can be reprodced in the 5.0.x version series as well and is clearly not a bug introduced by us. We build the different virtualbox parts quite differently from how upstream wants them to be built.
Comment 3 disabled_f2d52e90f935aa7979f6b5802d606a2ea8ef2c07 2016-05-05 18:55:08 UTC
Created attachment 433316 [details]
error information

I've included the build.log, ebuild environment, and emerge --info as 3 separate text documents. If you need anything else, I can provide.
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2016-05-06 09:42:53 UTC
Can you please test the virtualbox-modules-4.3.36 package? I'm quite sure that 4.3.32 is too old for a 4.4.x linux kernel.
Comment 5 Alexey Min 2016-05-08 18:27:05 UTC
You will laugh but this can be easily fixed by modifying linux kernel 4.4 source (the line where "new" is mentioned), just rename "new" to something other. This line is fine when compild with C compiler, but xf86-video-virtualbox is compiled with g++...

The file is:
/lib/modules/4.4.6-gentoo/build/include/linux/string.h

The line is:
char *strreplace(char *s, char old, char new); // new is a reserved keyword in C++
If you replace it with:
char *strreplace(char *s, char old, char new_c); // for example

then xf86-video-virtualbox will compile fine.
Comment 6 Brian Evans Gentoo Infrastructure gentoo-dev 2016-07-11 20:22:55 UTC
*** Bug 588620 has been marked as a duplicate of this bug. ***
Comment 7 Ryan Harris 2016-07-22 02:06:21 UTC
Looks like virtualbox added a fix for this though I'm not familiar with their releases so i don't know if it's out in a newer version yet.

https://www.virtualbox.org/changeset/57184/vbox
Comment 8 Alec Warner archtester Gentoo Infrastructure gentoo-dev Security 2019-09-17 03:35:40 UTC
The content of attachment 433316 [details] has been deleted for the following reason:

GDPR request.