Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 582046 - sys-apps/help2man-1.47.3 : configure: error: perl module Locale::gettext required
Summary: sys-apps/help2man-1.47.3 : configure: error: perl module Locale::gettext requ...
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-04 07:39 UTC by Toralf Förster
Modified: 2016-05-05 08:26 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
config.log (config.log,10.27 KB, text/plain)
2016-05-04 07:39 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,17.38 KB, text/plain)
2016-05-04 07:39 UTC, Toralf Förster
Details
environment (environment,73.51 KB, text/plain)
2016-05-04 07:39 UTC, Toralf Förster
Details
sys-apps:help2man-1.47.3:20160504-032453.log (sys-apps:help2man-1.47.3:20160504-032453.log,2.89 KB, text/plain)
2016-05-04 07:39 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2016-05-04 07:39:41 UTC
checking for library containing dlsym... -ldl
checking for library containing bindtextdomain... none required
configure: error: perl module Locale::gettext required

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/sys-apps/help2man-1.47.3/work/help2man-1.47.3/config.log


$ cat emerge-info.txt
  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named amd64-13.0-unstable_20160503-211155) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------

  make.conf: USE="mmx sse sse2 pax_kernel xtpax -cdinstall -oci8 -bindist cairo cddb cgi clang csc cups curl custom-cflags fontconfig freetds gd gif git gles2 gnomecanvas gstreamer haptic help inifile javaxml ldap mbox minizip -multitarget opengl php pkcs11 postscript -pyqt4 qt3support qt4 rdoc scrypt sdl smartcard -sqlite3 sse4 sse4_1 -svg -system-cairo -system-harfbuzz system-libvpx system-sqlite wma xmlreader -xscreensaver xslt xvfb -xz"

  -----------------------------------------------------------------
Portage 2.2.28 (python 3.4.3-final-0, default/linux/amd64/13.0, gcc-4.9.3, glibc-2.23-r2, 4.4.8-hardened-r1 x86_64)
=================================================================
System uname: Linux-4.4.8-hardened-r1-x86_64-Intel-R-_Core-TM-_i7-3770_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16157888 total,   2928936 free
KiB Swap:   16777212 total,  16704596 free
Timestamp of repository gentoo: Wed, 04 May 2016 00:23:54 +0000
sh bash 4.3_p42-r2
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p42-r2::gentoo
dev-lang/perl:            5.22.2::gentoo
dev-lang/python:          2.7.11-r2::gentoo, 3.4.3-r7::gentoo
dev-util/cmake:           3.5.2::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.20.5::gentoo
sys-apps/sandbox:         2.10-r2::gentoo
sys-devel/autoconf:       2.69-r2::gentoo
sys-devel/automake:       1.14.1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo, 5.3.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.5::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.de.gentoo.org/gentoo-portage/
    priority: 1

local
    location: /usr/local/portage
    masters: gentoo
    priority: 2

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--verbose-conflicts --color=n --nospinner --tree --quiet-build --accept-properties=-interactive --accept-restrict=-fetch"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="acl amd64 berkdb bzip2 cairo cddb cgi clang cli cracklib crypt csc cups curl custom-cflags cxx dri fontconfig fortran freetds gd gdbm gif git gles2 gnomecanvas gstreamer haptic help iconv inifile ipv6 javaxml ldap mbox minizip mmx mmxext modules multilib ncurses nls nptl opengl openmp pam pax_kernel pcre php pkcs11 postscript qt3support qt4 rdoc readline scrypt sdl seccomp session smartcard sse sse2 sse4 sse4_1 ssl system-libvpx system-sqlite tcpd unicode wma xattr xmlreader xslt xtpax xvfb zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_GB" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2016-05-04 07:39:44 UTC
Created attachment 433160 [details]
config.log
Comment 2 Toralf Förster gentoo-dev 2016-05-04 07:39:46 UTC
Created attachment 433162 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2016-05-04 07:39:49 UTC
Created attachment 433164 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2016-05-04 07:39:52 UTC
Created attachment 433166 [details]
sys-apps:help2man-1.47.3:20160504-032453.log
Comment 5 Lars Wendler (Polynomial-C) gentoo-dev 2016-05-04 07:44:22 UTC

*** This bug has been marked as a duplicate of bug 41124 ***
Comment 6 SpanKY gentoo-dev 2016-05-05 01:36:58 UTC
another day, another help2man-xml-parser-bug :)

dev-perl/Locale-gettext has a subslot dep on perl, so i suspect/hope this should stop showing up -- when perl updates, it should force a rebuild of Locale-gettext
Comment 7 Toralf Förster gentoo-dev 2016-05-05 08:26:15 UTC
gah - for the record:
I do code around that issue long time ago in my tinderbox, but made a thinko, fixed in https://github.com/toralf/tinderbox/commit/a0d0c337a96029c695f4739aa4f5c061a335b6a8