Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 58161 - libtool-1.5.2-r5 patches need to be ported to 1.5.10
Summary: libtool-1.5.2-r5 patches need to be ported to 1.5.10
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo's Team for Core System packages
Depends on:
Reported: 2004-07-24 04:45 UTC by Stefan Briesenick (RETIRED)
Modified: 2004-11-09 19:37 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

emerge info (info,2.88 KB, text/plain)
2004-07-24 04:46 UTC, Stefan Briesenick (RETIRED)
fam-2.7.0-r1.ebuild (fam-2.7.0-r1.ebuild,2.29 KB, text/plain)
2004-07-24 05:49 UTC, Stefan Briesenick (RETIRED)
fam-2.7.0-r1.ebuild.patch (fam-2.7.0-r1.ebuild.patch,3.39 KB, patch)
2004-07-24 05:51 UTC, Stefan Briesenick (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Briesenick (RETIRED) gentoo-dev 2004-07-24 04:45:31 UTC
emerge fam on one of my machines produces this:


all the libraries are w/o .so so it is broken.
looks like bug 40901

the only thing i've done is to re-emerge fam. On my other machine, I don't have the problem.

Reproducible: Always
Steps to Reproduce:
Comment 1 Stefan Briesenick (RETIRED) gentoo-dev 2004-07-24 04:46:06 UTC
Created attachment 36052 [details]
emerge info
Comment 2 Stefan Briesenick (RETIRED) gentoo-dev 2004-07-24 04:47:20 UTC
btw: if you fix this ebuild, then please add the USE-flags "static" and "pic" so the obsolete .a file isn't created anymore.
Comment 3 Stefan Briesenick (RETIRED) gentoo-dev 2004-07-24 05:16:29 UTC
BINGO! found the problem!

-> cp /usr/share/libtool/ .

is missing *before* elibtoolize.

I do some other fixes/enhancements on this ebuild 
and then I attach it. Gimme a few mins. ;-)
Comment 4 Stefan Briesenick (RETIRED) gentoo-dev 2004-07-24 05:49:59 UTC
Created attachment 36056 [details]

new fixed and enhanced ebuild. ChangeLog follows...
Comment 5 Stefan Briesenick (RETIRED) gentoo-dev 2004-07-24 05:51:17 UTC
Created attachment 36057 [details, diff]

diff only. apply it to original fam-2.7.0-r1.ebuild
Comment 6 Stefan Briesenick (RETIRED) gentoo-dev 2004-07-24 05:55:50 UTC

- fixed libtool problem (see above)

- moved the fam.conf patch to unpack() and changed "dosed" to "sed -i" because "dosed" didn't work, the fam.conf were unchanged!

- added "static" and "pic" USE-flags (in the same manner as libsndfile)

- check if "/etc/init.d/fam" exists and only then show temporary warning

please check it and put it into portage ASAP as *-r2.

Comment 7 Stefan Briesenick (RETIRED) gentoo-dev 2004-07-29 17:29:48 UTC
same problem with media-libs/libmpeg2! :-/

Comment 8 Stefan Briesenick (RETIRED) gentoo-dev 2004-07-29 17:36:40 UTC
same problem, same solution:

-> cp /usr/share/libtool/ .
is missing *before* elibtoolize.

Comment 9 Stefan Briesenick (RETIRED) gentoo-dev 2004-07-29 17:43:46 UTC
something really strage is broken on my machine. On others, it's ok. I try to re-emerge libtool & friends.
Comment 10 Stefan Briesenick (RETIRED) gentoo-dev 2004-07-29 17:59:03 UTC
next candidate media-video/mjpegtools.

But I checked some other tools, and it is NOT a general problem. Most packages build correct.
Comment 11 Stefan Briesenick (RETIRED) gentoo-dev 2004-07-29 18:12:03 UTC
cp /usr/share/libtool/ .
before "autoreconf || die" helped. :-/
Comment 12 Stefan Briesenick (RETIRED) gentoo-dev 2004-07-29 18:33:30 UTC
ok, I re-emerged libtool, autoconf and automake.

NOW it seems to work again as excpected. the /usr/share/libtool/ thingy isn't needed anymore. So my main problem seems to be solved.

nonetheless, my enhancement to fam still exists and wants to be in portage. :-D
but you can remove the line out of my ebuild!
Comment 13 Stefan Briesenick (RETIRED) gentoo-dev 2004-07-29 18:43:15 UTC

libtool-1.5.2-r5 works
libtool-1.5.6 seems NOT to work

I don't know why, but I had 1.5.6 on my PC before I re-emerged libtool.
Comment 14 foser (RETIRED) gentoo-dev 2004-08-03 15:22:07 UTC
been away for a while, catching up on bugmail. Looks like it might be a general libtool problem by the comments you made.
Comment 15 SpanKY gentoo-dev 2004-08-04 10:42:34 UTC
this happened to libtool-1.5.2 and we fixed it somewhere along the way to 1.5.2-r5

libtool-1.5.6 is marked -* for a reason; as to how it got onto your machine, who knows
Comment 16 Stefan Briesenick (RETIRED) gentoo-dev 2004-08-04 11:29:10 UTC
ok, ok, but it wasn't a good idea to obsolete the whole fam-ebuild! There're some more enhancements! ;-)

just drop the thingy, but keep the rest!

or should I open a new bug for it?
Comment 17 SpanKY gentoo-dev 2004-08-04 12:19:23 UTC
this bug is about getting libtool-1.5.6 to act just as well as 1.5.2-r5 does ... that means running `libtoolize` and all that is not an acceptable solution in ebuilds ...

if the fam ebuilds posted here fixed something unrelated to libtool, then please file another bug and assign it to

sorry if i missed something :)
Comment 18 SpanKY gentoo-dev 2004-11-09 19:37:52 UTC
ok, the .so variable changed between 1.5.2 and 1.5.6

updated the patch ... libtool-1.5.10 should be usuable now