Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 581058 - net-libs/osptoolkit-4.1.5 : osptransapi.c:1040:13: error: non-floating-point argument in call to function ‘__builtin_isnan’
Summary: net-libs/osptoolkit-4.1.5 : osptransapi.c:1040:13: error: non-floating-point ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-5 gcc-5-stable
  Show dependency tree
 
Reported: 2016-04-24 14:06 UTC by Toralf Förster
Modified: 2017-02-12 11:33 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-history.txt (emerge-history.txt,290.33 KB, text/plain)
2016-04-24 14:06 UTC, Toralf Förster
Details
environment (environment,76.21 KB, text/plain)
2016-04-24 14:06 UTC, Toralf Förster
Details
net-libs:osptoolkit-4.1.5:20160424-110237.log (net-libs:osptoolkit-4.1.5:20160424-110237.log,7.53 KB, text/plain)
2016-04-24 14:06 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2016-04-24 14:06:17 UTC
x86_64-pc-linux-gnu-gcc -march=native -O2 -pipe -DOPENSSL_NO_KRB5 -D_POSIX_THREADS -D_REENTRANT -DOSP_SDK -DOSP_ALLOW_DUP_TXN -DOSP_NO_DELETE_CHECK  -Wall -D_GNU_SOURCE -fPIC  -I../crypto -I../include -c osptransapi.c
osptransapi.c: In function ‘OSPPTransactionAccumulateTwoWayDelay’:
osptransapi.c:1040:13: error: non-floating-point argument in call to function ‘__builtin_isnan’
             OSPM_ISNAN(metrics.mean, tnisnan);
             ^
Makefile:63: recipe for target 'osptransapi.o' failed


$ cat emerge-info.txt
  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named amd64-desktop-unstable_20160420-104159) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------

  make.conf: USE="mmx sse sse2 pax_kernel xtpax -cdinstall -oci8 -bindist aes-ni apache -avx -btrfs cddb dot -drmkms dvb ftp graphtft gui havege imap javaxml -libressl mbox mikmod mysqli obj ois opencv pkcs11 -qt5 smartcard sql -sqlite3 sse4 ssh-askpass ssl thinkpad v4l2 vaapi -x265 xmlreader xslt xvfb"

  -----------------------------------------------------------------
Portage 2.2.28 (python 2.7.11-final-0, default/linux/amd64/13.0/desktop, gcc-5.3.0, glibc-2.23-r2, 4.4.8-hardened x86_64)
=================================================================
System uname: Linux-4.4.8-hardened-x86_64-Intel-R-_Core-TM-_i7-3770_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16157888 total,    990428 free
KiB Swap:   16777212 total,  16727404 free
Timestamp of repository gentoo: Sun, 24 Apr 2016 09:03:49 +0000
sh bash 4.3_p42-r2
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
distcc 3.2rc1 x86_64-pc-linux-gnu [disabled]
ccache version 3.2.5 [disabled]
app-shells/bash:          4.3_p42-r2::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.22.1::gentoo
dev-lang/python:          2.7.11-r2::gentoo, 3.4.3-r7::gentoo
dev-util/ccache:          3.2.5::gentoo
dev-util/cmake:           3.5.2::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.20.5::gentoo
sys-apps/sandbox:         2.10-r2::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r2::gentoo
sys-devel/automake:       1.11.6-r2::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo, 5.3.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.5::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.de.gentoo.org/gentoo-portage/
    priority: 1

local
    location: /usr/local/portage
    masters: gentoo
    priority: 2

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/stunnel/stunnel.conf /usr/share/gnupg/qualified.txt /var/lib/redmine/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /var/lib/redmine/config/locales /var/lib/redmine/config/settings.yml"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--verbose-conflicts --color=n --nospinner --tree --quiet-build --accept-properties=-interactive --accept-restrict=-fetch"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi aes-ni alsa amd64 apache berkdb bluetooth branding bzip2 cairo cdda cddb cdr cli consolekit cracklib crypt cups cxx dbus dot dri dts dvb dvd dvdr emboss encode exif fam firefox flac fortran ftp gdbm gif glamor gpm graphtft gtk gui havege iconv imap ipv6 javaxml jpeg lcms ldap libnotify mad mbox mikmod mmx mmxext mng modules mp3 mp4 mpeg multilib mysqli ncurses nls nptl obj ogg ois opencv opengl openmp pam pango pax_kernel pcre pdf pkcs11 png policykit ppds qt3support qt4 readline sdl seccomp session smartcard spell sql sse sse2 sse4 ssh-askpass ssl startup-notification svg tcpd thinkpad tiff truetype udev udisks unicode upower usb v4l2 vaapi vorbis wxwidgets x264 xattr xcb xml xmlreader xslt xtpax xv xvfb xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_GB" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2016-04-24 14:06:20 UTC
Created attachment 431800 [details]
emerge-history.txt
Comment 2 Toralf Förster gentoo-dev 2016-04-24 14:06:23 UTC
Created attachment 431802 [details]
environment
Comment 3 Toralf Förster gentoo-dev 2016-04-24 14:06:25 UTC
Created attachment 431804 [details]
net-libs:osptoolkit-4.1.5:20160424-110237.log
Comment 4 Charlie Gehlin 2016-04-28 07:23:15 UTC
4.1.5 being from 2013, I tried to emerge the latest, 4.11.1, by just changing the filename of .ebuild-file (and changed S_DATE="20160223") in my local overlay, it still generates the same error. ~amd64, gcc-5.3.0
Comment 5 Pacho Ramos gentoo-dev 2017-01-11 09:12:42 UTC
CCing treecleaners
Comment 6 David Seifert gentoo-dev 2017-02-12 10:01:33 UTC
commit dda894edbd7a7d611fbec0c3c18bce3c5f66ca5d
Author: David Seifert <soap@gentoo.org>
Date:   Sun Feb 12 10:56:29 2017 +0100

    net-libs/osptoolkit: Version bump to 4.13.0
    
    * Also fix GCC 5 bug
    Bug: https://bugs.gentoo.org/show_bug.cgi?id=581058
Comment 7 David Seifert gentoo-dev 2017-02-12 11:33:10 UTC
commit 7bf5750ecf710d2c2a7fab98934dc752a04ff368
Author: David Seifert <soap@gentoo.org>
Date:   Sun Feb 12 11:12:07 2017 +0100

    net-libs/osptoolkit: Remove old
    
    Bug: https://bugs.gentoo.org/show_bug.cgi?id=581058

commit e95ff41ff0d06a36d1870a0c73c2392f794a531d
Author: David Seifert <soap@gentoo.org>
Date:   Sun Feb 12 11:10:51 2017 +0100

    profiles: Mask depending on net-libs/osptoolkit for stable