Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 580906 - sddm shows blank screen on start
Summary: sddm shows blank screen on start
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: Normal minor (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2016-04-23 08:45 UTC by Daiajo Tibdixious
Modified: 2016-06-02 02:49 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

sddm.log.bz2 (sddm.log.bz2,722 bytes, application/x-bzip)
2016-04-23 08:45 UTC, Daiajo Tibdixious
emerge --info (info,5.25 KB, text/plain)
2016-04-23 08:49 UTC, Daiajo Tibdixious
output of eix plasma-meta (plasma.txt,472 bytes, text/plain)
2016-04-25 08:52 UTC, Daiajo Tibdixious
sddm.log from test on 2nd June (sddm.log,3.46 KB, text/plain)
2016-06-02 02:49 UTC, Daiajo Tibdixious

Note You need to log in before you can comment on or make changes to this bug.
Description Daiajo Tibdixious 2016-04-23 08:45:19 UTC
Created attachment 431610 [details]

After upgrading to kde plasma 5.5.5, sddm just shows a blank screen and hangs. kdm shows a pop up with something like "no greter defined, check config", when clicked it goes to the blank screen andf hangs.
I have tried with no /etc/sddm.condf and with one that has
Comment 1 Daiajo Tibdixious 2016-04-23 08:49:06 UTC
Created attachment 431612 [details]
emerge --info
Comment 2 Andreas Sturmlechner gentoo-dev 2016-04-23 08:50:01 UTC
* check sddm user is in the video group
* check that /etc/sddm.conf exists
* check that xinerama is not configured in xorg.conf
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2016-04-23 09:00:47 UTC
This doesn't look like an x11-misc/sddm problem at all.
Comment 4 Daiajo Tibdixious 2016-04-23 09:18:51 UTC
sddm was not in video group, added it
/etc/sddm.conf does exist (I created it earlier)
xinerama is not mentioned in /etc/X11/xorg.conf
The same blank (black) screen results after /etc/init.d/xdm start

I had logged into my user acount, done startx (which worked normally),
then on killing the main xwindow, it did not exit, instead 
showing the same blank screen that the display managers show.
Comment 5 Daiajo Tibdixious 2016-04-25 08:49:52 UTC
If I login to my user account and type
startx startkde
The same blank screen results. Which suggests KDE just won't start.

Also kde-base/plasma-meta (and several other KDE packages) have a '?'
status in eix. Normally there is a '*'.
I an't copy/paste at the moment, so I've attached an example.
Comment 6 Daiajo Tibdixious 2016-04-25 08:52:29 UTC
Created attachment 431922 [details]
output of eix plasma-meta
Comment 7 Alex Xu (Hello71) 2016-04-27 14:41:35 UTC
for fix eix, use "eix-sync" instead of "emerge --sync".

to fix sddm, run "emerge -uDN @world".
Comment 8 Daiajo Tibdixious 2016-04-29 06:40:24 UTC
I have emerge --sync & eix-update in a cron job, which apparently hasn't been running, but thats another issue.
I set my profile to just kde (not plasma), removed kde & reinstalled kde-meta.
If I usd sddm as the display manger I still get a blank screen.
However using kdm I am now able to start KDE.
So I still have a problem with sddm but don't really care, as I'm not using it.
Comment 9 Daiajo Tibdixious 2016-06-02 02:48:20 UTC
After a KDE upgrade (4.14.3-r1 now) I tried sddm again, with the same results, just a blank screen displayed.Switched back to kdm and KDE starts normally.
This is annoying to test because I have to hold the power button to force a power off, there seems no normal way to return to the console, after the blank screen is reached.

emerge --info
Portage 2.2.28 (python 3.4.3-final-0, default/linux/amd64/13.0/desktop/kde, gcc-4.9.3, glibc-2.22-r4, 4.4.6-gentoo x86_64)
System uname: Linux-4.4.6-gentoo-x86_64-AMD_FX-tm-8350_Eight-Core_Processor-with-gentoo-2.2
KiB Mem:    16432580 total,  15113604 free
KiB Swap:     506040 total,    506040 free
Timestamp of repository gentoo: Wed, 01 Jun 2016 16:15:01 +0000
sh bash 4.3_p42-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p42-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.10-r1::gentoo, 3.4.3-r1::gentoo
dev-util/cmake:           3.3.1-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.19.1::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r4::gentoo

    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000

    location: /usr/local/portage
    masters: gentoo

CFLAGS="-O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
USE="X a52 aac acl acpi alsa amd64 branding bzip2 cairo cdda cdr cli consolekit cracklib crypt css cxx dbus declarative dhcp dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif glamor gnutls gpm gtk iconv icu ipv6 java jpeg kde kipi lcms ldap libnotify mad mmx mmxext mng modules mp3 mp4 mpeg multilib mysql ncurses nls nptl nsplugin ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds qt3support qt4 qt5 readline script sdl seccomp semantic-desktop session spell sql sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vim-syntax vorbis wxwidgets x264 xattr xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx fma3 fma4 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 xop" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en_GB" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="ati fglrx radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 10 Daiajo Tibdixious 2016-06-02 02:49:32 UTC
Created attachment 436124 [details]
sddm.log from test on 2nd June