Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 580736 - app-office/wps-office- fails to start on hardened (all components)
Summary: app-office/wps-office- fails to start on hardened (all ...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Pacho Ramos
Keywords: NeedPatch
Depends on:
Reported: 2016-04-21 14:22 UTC by Gerold Schellstede
Modified: 2018-09-15 11:39 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Gerold Schellstede 2016-04-21 14:22:16 UTC

recently I installed WPS-Office, but all of its components fail to start. To get some hints I started them trough the xfce-terminal. Here all components (wpp, et, wps) shows the same failure:

/usr/bin/et: line 38: 13111 Segmentation fault  ${gInstallPath}/office6/${gApp} ${gOptExt} ${gOpt} "$@"

If one tries again, the only thing which changes is the 5digits number after "line 38:". 

Eventually it is worth to mention that I am on hardened (hardened-kernel and toolchain with PaX, but not SeLinux or something like that), but googeling shows that there are also users on other distros with this problem. 

Thanks in advance
Comment 1 Jonas Stein gentoo-dev 2016-04-24 19:25:19 UTC
I tried to reproduce the reported bug. And got

 * QA Notice: The following files contain writable and executable sections
 *  Files with such sections will not work properly (or at all!) on some
 *  architectures/operating systems.  A bug should be filed at
 * to make sure the issue is fixed.
 *  For more information, see:
 *  Please include the following list of files in your report:
 *  Note: Bugs should be filed for the respective maintainers
 *  of the package in question and not hardened@g.o.
 * RWX --- --- opt/kingsoft/wps-office/office6/

I am not sure, if this leads to the same source of trouble, or should be filed in a new bug. Most likely the problems come from upstream and should be solved there instead of the ebuild. 

If you are user of wps, could you try to collect more information? 
Does the older ebuild work for you?
Please attach the complete build info and logfiles.
Comment 2 Pacho Ramos gentoo-dev 2016-04-24 20:06:33 UTC
It works fine for me on a non-hardened system
Comment 3 Gerold Schellstede 2016-04-25 08:59:00 UTC
@Jonas Stein You were right: The bug seems to be hardened-related. 

dmesg shows

[ 2363.669154] wpp[7453]: segfault at bbadbeef ip 000074c6933cf5ae sp 0000764c7da31ab0 error 6 in[74c69222e000+19a7000]
[ 2415.831310] wps[7484]: segfault at bbadbeef ip 00006508532eb5ae sp 0000711cad7f9f20 error 6 in[65085214a000+19a7000]
[ 2630.808972] et[7751]: segfault at bbadbeef ip 00006d6d1de1d5ae sp 000078226497d260 error 6 in[6d6d1cc7c000+19a7000]
Comment 4 Pacho Ramos gentoo-dev 2016-04-26 18:31:18 UTC
@hardened, I am not sure how to handle this problem with hardened :/ (and not, we cannot use system qt libs because it relies on some features from the wps version)
Comment 5 Magnus Granberg gentoo-dev 2016-04-26 19:46:22 UTC
(In reply to Pacho Ramos from comment #4)
> @hardened, I am not sure how to handle this problem with hardened :/ (and
> not, we cannot use system qt libs because it relies on some features from
> the wps version)
I think the wps version is compile with jit as we disable it. most likliy have some asm files that missing gnu stack fix.
Do pax mark the bins with m fix it?
Comment 6 Gerold Schellstede 2016-04-27 09:28:33 UTC
What do you mean with the "bins"

#paxctl-ng -v /usr/bin/wps
	ELF ERROR: elf_kind() fail: this is not an elf file.
	PT_PAX    : not found
	XATTR_PAX : not found

and "#paxctl-ng -m /usr/bin/wps" does not help.