Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 580014 - sys-apps/coreutils-8.25: mountlist.c:(.text+0x2ae): undefined reference to `makedev'
Summary: sys-apps/coreutils-8.25: mountlist.c:(.text+0x2ae): undefined reference to `m...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: Normal major (vote)
Assignee: Gentoo's Team for Core System packages
URL: https://lists.gnu.org/archive/html/bu...
Whiteboard:
Keywords:
: 580068 (view as bug list)
Depends on:
Blocks: glibc-sysmacros
  Show dependency tree
 
Reported: 2016-04-14 21:57 UTC by Christopher Dale
Modified: 2016-04-16 06:30 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Coreutils environment (coreutils_env.txt,89.00 KB, text/plain)
2016-04-14 21:58 UTC, Christopher Dale
Details
Coreutils build (coreutils_build.txt,58.08 KB, text/plain)
2016-04-14 21:59 UTC, Christopher Dale
Details
Coreutils pqv (coreutils_pqv.txt,240 bytes, text/plain)
2016-04-14 21:59 UTC, Christopher Dale
Details
Coreutils info (coreutils_info.txt,5.53 KB, text/plain)
2016-04-14 21:59 UTC, Christopher Dale
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Dale 2016-04-14 21:57:12 UTC
After switching profiles from gnome-systemd to systemd, I attempted to perform an emptytree re-compilation of @system and got an error when I hit coreutils. I'm not sure if the profile switch was the culprit, or if perhaps it would have happened sooner if I had attempted an empty-tree rebuild.

...
  CCLD     src/chcon
lib/libcoreutils.a(mountlist.o): In function `read_file_system_list':
mountlist.c:(.text+0x2ae): undefined reference to `makedev'
collect2: error: ld returned 1 exit status
Makefile:7698: recipe for target 'src/df' failed
make[2]: *** [src/df] Error 1
make[2]: *** Waiting for unfinished jobs....
  CCLD     src/chgrp
  CCLD     src/chmod
make[2]: Leaving directory '/var/tmp/portage/sys-apps/coreutils-8.25/work/coreutils-8.25'
Makefile:11298: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/sys-apps/coreutils-8.25/work/coreutils-8.25'
Makefile:5844: recipe for target 'all' failed
make: *** [all] Error 2

Reproducible: Always

Steps to Reproduce:
1. Switch profiles from gnome-systemd to systemd (possibly)
2. Attempt `emerge -e @system`
Actual Results:  
The build of coreutils fails with the following error:

...
  CCLD     src/chcon
lib/libcoreutils.a(mountlist.o): In function `read_file_system_list':
mountlist.c:(.text+0x2ae): undefined reference to `makedev'
collect2: error: ld returned 1 exit status
Makefile:7698: recipe for target 'src/df' failed
make[2]: *** [src/df] Error 1
make[2]: *** Waiting for unfinished jobs....
  CCLD     src/chgrp
  CCLD     src/chmod
make[2]: Leaving directory '/var/tmp/portage/sys-apps/coreutils-8.25/work/coreutils-8.25'
Makefile:11298: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/sys-apps/coreutils-8.25/work/coreutils-8.25'
Makefile:5844: recipe for target 'all' failed
make: *** [all] Error 2

Expected Results:  
I am able to get through an empty-tree rebuild without any errors.

Running:

* Chrome
* Gnome (and all the stuff that comes with it)
* Gnome-terminal
* Evolution
Comment 1 Christopher Dale 2016-04-14 21:58:56 UTC
Created attachment 430518 [details]
Coreutils environment

Coreutils environment
Comment 2 Christopher Dale 2016-04-14 21:59:12 UTC
Created attachment 430520 [details]
Coreutils build

Coreutils build
Comment 3 Christopher Dale 2016-04-14 21:59:27 UTC
Created attachment 430522 [details]
Coreutils pqv

Coreutils pqv
Comment 4 Christopher Dale 2016-04-14 21:59:41 UTC
Created attachment 430524 [details]
Coreutils info

Coreutils info
Comment 5 Cyril 2016-04-15 05:42:34 UTC
Confirmed here with glibc-2.23-r1
Comment 6 Tobias Klausmann gentoo-dev 2016-04-15 08:20:03 UTC
It looks like the definition of makedev was moved to sys/sysmacros.h. Whether that mens that sys/types.h should include sysmacros.h or if coreutils should include it, I don't know.
Comment 7 SpanKY gentoo-dev 2016-04-16 05:19:17 UTC
the coreutils guys had discussed this on the mailing list and said it shouldn't be a problem, but i guess i didn't check it explicitly myself
Comment 8 SpanKY gentoo-dev 2016-04-16 05:19:23 UTC
*** Bug 580068 has been marked as a duplicate of this bug. ***
Comment 9 SpanKY gentoo-dev 2016-04-16 06:30:57 UTC
patch sent upstream and fix in 8.25 ebuild:
https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=74ca4a1e0ebd5a86cd91442851b93829645dd674