Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 580012 - media-libs/xine-lib-1.2.6-r1 fails to build - implicit declaration of function 'major'
Summary: media-libs/xine-lib-1.2.6-r1 fails to build - implicit declaration of functio...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL: https://bugs.xine-project.org/show_bu...
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-sysmacros
  Show dependency tree
 
Reported: 2016-04-14 21:53 UTC by Bartosz Szreder
Modified: 2018-04-27 20:13 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build log fragment (file_580012.txt,1.87 KB, text/plain)
2016-04-14 21:53 UTC, Bartosz Szreder
Details
emerge --info (info,5.74 KB, text/plain)
2016-04-14 21:55 UTC, Bartosz Szreder
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bartosz Szreder 2016-04-14 21:53:18 UTC
Created attachment 430512 [details]
build log fragment

xine-lib fails on building src/xine-utils/xine_check.c (see attached build log fragment).

Failure is caused by implicit declaration of function major(). Looking at "man major" suggests that xine_check.c is missing #include <sys/types.h> but on my system (linux-headers-4.5) the proper header file is in fact <sys/sysmacros.h>. Adding such #include directive to xine_check.c makes the build complete successfully.
Comment 1 Bartosz Szreder 2016-04-14 21:55:25 UTC
Created attachment 430514 [details]
emerge --info
Comment 2 Bartosz Szreder 2016-04-14 21:59:19 UTC
Adding as a blocker to #575232