Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 578828 - x11-drivers/nvidia-drivers-364.12-r1 requires CONFIG_DRM_FBDEV_EMULATION, FB_MODE_HELPERS
Summary: x11-drivers/nvidia-drivers-364.12-r1 requires CONFIG_DRM_FBDEV_EMULATION, FB_...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: David Seifert
URL:
Whiteboard:
Keywords:
: 578830 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-04-02 12:05 UTC by C. Wijtmans
Modified: 2021-03-02 20:24 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description C. Wijtmans 2016-04-02 12:05:30 UTC
When this config is not set the drm module will miss symbols and not load. 

[    3.199840] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  364.12  Wed Mar 16 20:44:12 PDT 2016
[    3.208952] nvidia_drm: Unknown symbol drm_atomic_helper_plane_destroy_state (err 0)
[    3.209008] nvidia_drm: Unknown symbol drm_kms_helper_poll_fini (err 0)
[    3.209049] nvidia_drm: Unknown symbol drm_kms_helper_poll_disable (err 0)
[    3.209089] nvidia_drm: Unknown symbol drm_kms_helper_poll_init (err 0)
[    3.209131] nvidia_drm: Unknown symbol drm_atomic_helper_disable_plane (err 0)
[    3.209184] nvidia_drm: Unknown symbol drm_atomic_helper_cleanup_planes (err 0)
[    3.209238] nvidia_drm: Unknown symbol drm_helper_hpd_irq_event (err 0)
[    3.211937] nvidia_drm: Unknown symbol drm_atomic_helper_crtc_destroy_state (err 0)
[    3.211993] nvidia_drm: Unknown symbol drm_atomic_helper_connector_dpms (err 0)
[    3.212048] nvidia_drm: Unknown symbol drm_atomic_helper_check (err 0)
[    3.212088] nvidia_drm: Unknown symbol drm_atomic_helper_connector_destroy_state (err 0)
[    3.212143] nvidia_drm: Unknown symbol drm_atomic_helper_plane_duplicate_state (err 0)
[    3.212204] nvidia_drm: Unknown symbol drm_atomic_helper_plane_reset (err 0)
[    3.212244] nvidia_drm: Unknown symbol drm_atomic_helper_prepare_planes (err 0)
[    3.212300] nvidia_drm: Unknown symbol drm_helper_mode_fill_fb_struct (err 0)
[    3.212344] nvidia_drm: Unknown symbol drm_atomic_helper_set_config (err 0)
[    3.212384] nvidia_drm: Unknown symbol drm_atomic_helper_connector_duplicate_state (err 0)
[    3.212439] nvidia_drm: Unknown symbol drm_atomic_helper_crtc_reset (err 0)
[    3.212483] nvidia_drm: Unknown symbol drm_kms_helper_hotplug_event (err 0)
[    3.212525] nvidia_drm: Unknown symbol drm_atomic_helper_swap_state (err 0)
[    3.212566] nvidia_drm: Unknown symbol drm_atomic_helper_page_flip (err 0)
[    3.212606] nvidia_drm: Unknown symbol drm_atomic_helper_connector_reset (err 0)
[    3.212660] nvidia_drm: Unknown symbol drm_atomic_helper_crtc_duplicate_state (err 0)
[    3.212714] nvidia_drm: Unknown symbol drm_atomic_helper_update_plane (err 0)
Comment 1 C. Wijtmans 2016-04-02 13:37:56 UTC
*** Bug 578830 has been marked as a duplicate of this bug. ***
Comment 2 rx80 2016-04-02 13:48:21 UTC
I can confirm that CONFIG_DRM_FBDEV_EMULATION, FB_MODE_HELPERS are needed.
Comment 3 C. Wijtmans 2016-04-02 14:16:03 UTC
Only CONFIG_DRM_FBDEV_EMULATION is neccesary for building and loading the drm module. However CONFIG_FB_MODE_HELPERS did not help my situation of xcom2 saying my gfx card is not support and low fps in ns2.
Comment 4 Nick Reale 2016-04-10 15:41:55 UTC
I found the FBDEV thing last week, but I do not have FB_MODE_HELPERS in my kernel and haven't had a single issue or error with the drivers
Comment 5 Ionen Wolkens 2021-03-02 20:20:06 UTC
I believe this may have been only relevant when using modeset=1

Either way, addition of DRM and DRM_KMS_HELPER would ensure everything is available:
https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=b69bae801a904d7f31145bfba5a50f11a9cbbdf7

DRM_KMS_HELPER notably pulls DRM_FBDEV_EMULATION, so I'll mark this fixed.
Comment 6 Ionen Wolkens 2021-03-02 20:24:42 UTC
However, the DRM_KMS_HELPER config option being not directly available is another issue, bug #603818 is still open about this.