Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 578550 - app-admin/collectd-5.5.1-r2 forces selection of collectd_plugins_smart
Summary: app-admin/collectd-5.5.1-r2 forces selection of collectd_plugins_smart
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Johan Bergström
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-03-29 19:26 UTC by Chris Mayo
Modified: 2016-04-01 10:57 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Mayo 2016-03-29 19:26:25 UTC
Missing ? in REQUIRED_USE :

	collectd_plugins_smart			( udev )"



!!! The ebuild selected to satisfy "collectd" has unmet requirements.
- app-admin/collectd-5.5.1-r2::gentoo USE="contrib -debug filecaps -java perl (-selinux) -static-libs udev" ABI_X86="64" COLLECTD_PLUGINS="-aggregation -amqp -apache -apcups -ascent -battery -bind -ceph -cgroups -conntrack -contextswitch cpu -cpufreq -csv -curl -curl_json -curl_xml -dbi -df disk -dns -drbd -email -entropy -ethstat -exec -fhcount -filecount -fscache -genericjmx -gmond hddtemp -interface -ipc -ipmi -iptables -ipvs -irq -java -load -log_logstash -logfile -lvm -madwifi -match_empty_counter -match_hashed -match_regex -match_timediff -match_value -mbmon -md -memcachec -memcached memory -modbus -multimeter -mysql -netlink -network -nfs -nginx -notify_desktop -notify_email -ntpd -numa -nut -olsrd -onewire -openldap -openvpn -oracle -perl -ping -postgresql -powerdns -processes -protocols python -redis -routeros -rrdcached rrdtool sensors -serial -sigrok -smart snmp -statsd -swap syslog -table -tail -tail_csv -target_notification -target_replace -target_scale -target_set -tcpconns -teamspeak2 -ted -thermal -threshold -tokyotyrant -turbostat -unixsock -uptime -users -uuid -varnish -virt -vmem -vserver -wireless -write_graphite -write_http -write_kafka -write_log -write_redis -write_riemann -write_sensu -write_tsdb -zfs_arc -zookeeper" PYTHON_SINGLE_TARGET="-python2_7 -python3_4 python3_5" PYTHON_TARGETS="python2_7 -python3_4 python3_5"

  The following REQUIRED_USE flag constraints are unsatisfied:
    collectd_plugins_smart

  The above constraints are a subset of the following complete expression:
    collectd_plugins_genericjmx? ( java ) collectd_plugins_java? ( java ) collectd_plugins_python? ( exactly-one-of ( python_single_target_python2_7 python_single_target_python3_4 python_single_target_python3_5 ) python_single_target_python2_7? ( python_targets_python2_7 ) python_single_target_python3_4? ( python_targets_python3_4 ) python_single_target_python3_5? ( python_targets_python3_5 ) ) collectd_plugins_smart ( udev )
Comment 1 Christian Zuckschwerdt 2016-03-30 12:46:51 UTC
This is due to a typo in collectd-5.5.1-r2.ebuild line 143: 

collectd_plugins_smart ( udev )"

should be

collectd_plugins_smart? ( udev )"
Comment 2 zasire 2016-03-31 12:47:43 UTC
Can confirm this error.
Comment 3 Sam Jorna (wraeth) gentoo-dev 2016-03-31 22:42:15 UTC
This was resolved in PR 1171 and the below commit. Please sync your tree and retest.


commit 6be31c5ac3704fdf57a3ec5a4f746bebd2f0f346
Author: Thomas D <whissi@whissi.de>
Date:   Thu Mar 31 13:03:38 2016 +0200

    app-admin/collectd: Fix REQUIRED_USE

    REQUIRED_USE of "udev" is only required when smart plugin was selected by
    the user (forgotten "?").

    Closes: https://github.com/gentoo/gentoo/pull/1171
    Package-Manager: portage-2.2.28
    Signed-off-by: Sam Jorna <wraeth@gentoo.org>
Comment 4 Christian Zuckschwerdt 2016-04-01 06:02:24 UTC
Tested successful. Resolved.
Comment 5 Thomas Deutschmann gentoo-dev Security 2016-04-01 10:57:11 UTC
Thank you for the feedback.