Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 57828 - Portage should record USE flags used when creating binary packages
Summary: Portage should record USE flags used when creating binary packages
Status: RESOLVED DUPLICATE of bug 2272
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-07-21 02:13 UTC by Edvard Fagerholm
Modified: 2005-07-17 13:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Edvard Fagerholm 2004-07-21 02:13:24 UTC
If you compile a binary package, then portage should record the USE flags used when compiling that package into the package binary. This would help building automated installations in a heterogeneous environment. The typical case is that you have packages A and B. With default USE flags, A would depend on B, but you don't want A to use B even though you're going to install B on some computers. So you build a binary package with:

USE="-B" emerge -b A

Now you can't run emerge -K A on a computer where you don't need B at all (even though the binary package A does nothing with B), without having B installed, or you need to supply the USE flag again. The whole process is very frustrating, because you need to record every special USE flag you've used to compile every package...

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Brian Harring gentoo-dev 2004-07-22 00:48:54 UTC
Err... It *is* recorded in the tbz2.
What you're after is the ability to depend (or rdepend in your case) on packages w/ a use flag enabled, which is a dupe.

*** This bug has been marked as a duplicate of 2272 ***