Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 576320 - x11-misc/sddm-0.13.0-r2 fails to install systemd service file
Summary: x11-misc/sddm-0.13.0-r2 fails to install systemd service file
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Jauhien Piatlicki (RETIRED)
URL:
Whiteboard:
Keywords:
: 576358 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-03-03 03:27 UTC by Wes
Modified: 2016-03-03 16:13 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wes 2016-03-03 03:27:59 UTC
sddm 0.13.0-r2 fails to install the systemd service file when using the systemd USE flag.  -r1 does.  The key difference I can see is the removal of cmake-utils functions src_configure()

<               $(cmake-utils_use_no systemd SYSTEMD)
---
>               -DNO_SYSTEMD=$(usex systemd)
Comment 1 Wes 2016-03-03 03:28:49 UTC
...the removal of cmake-utils functions *in* src_configure()
Comment 2 tman 2016-03-03 07:24:00 UTC
i can also confirm this problem.

same problem here
Comment 3 Andreas Sturmlechner gentoo-dev 2016-03-03 09:00:46 UTC
Inverted logic is inverted - sorry about that.

See also: https://github.com/gentoo/gentoo/pull/964
Comment 4 Wes 2016-03-03 11:20:39 UTC
Thanks Andreas
Comment 5 Aaron Bauman Gentoo Infrastructure gentoo-dev Security 2016-03-03 13:21:56 UTC
Please see proxies PR on Github which fixes the issue.
Comment 6 Michael Palimaka (kensington) gentoo-dev 2016-03-03 15:30:04 UTC
Thanks, PR merged.

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=9b371d67fbad2960d893b0e1343d7ecb818f96ff
Comment 7 Michael Palimaka (kensington) gentoo-dev 2016-03-03 16:13:21 UTC
*** Bug 576358 has been marked as a duplicate of this bug. ***