Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 575918 - media-libs/libcanberra: circular dependency with =x11-libs/gtk+-3.16.*:3[examples]
Summary: media-libs/libcanberra: circular dependency with =x11-libs/gtk+-3.16.*:3[exam...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-28 16:24 UTC by Alessandro Barbieri
Modified: 2021-05-01 02:44 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (file_575918.txt,20.63 KB, text/plain)
2016-02-28 16:24 UTC, Alessandro Barbieri
Details
environment (environment,136.67 KB, text/plain)
2016-02-28 16:34 UTC, Alessandro Barbieri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alessandro Barbieri 2016-02-28 16:24:56 UTC
Created attachment 426910 [details]
build.log

Can't emerge libcanberra because can't find gdk/gdkx.h

but

locate gdkx.h
/usr/include/gtk-2.0/gdk/gdkx.h

and

equery belongs -e /usr/include/gtk-2.0/gdk/gdkx.h
 * Searching for /usr/include/gtk-2.0/gdk/gdkx.h ... 
x11-libs/gtk+-2.24.28-r1 (/usr/include/gtk-2.0/gdk/gdkx.h)

see attachments for details
Comment 1 Alessandro Barbieri 2016-02-28 16:26:44 UTC
emerge --info '=media-libs/libcanberra-0.30-r5::gentoo'

Portage 2.2.26 (python 2.7.10-final-0, default/linux/x86/13.0, gcc-4.9.3, glibc-2.21-r2, 4.1.5-rt-gnu-rt5 i686)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.1.5-rt-gnu-rt5-i686-Intel-R-_Pentium-R-_4_CPU_2.80GHz-with-gentoo-2.2
KiB Mem:     3102368 total,    705060 free
KiB Swap:    5767160 total,   5765292 free
Timestamp of repository gentoo: Sun, 28 Feb 2016 03:00:01 +0000
sh bash 4.3_p42-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p42-r1::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.10-r1::gentoo, 3.4.3-r1::gentoo
dev-util/cmake:           3.3.1-r1::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.19.1::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.13.4::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.21-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

sage-on-gentoo
    location: /var/lib/layman/sage-on-gentoo
    masters: gentoo science
    priority: 0

octave
    location: /var/lib/layman/octave
    masters: gentoo
    priority: 1

science
    location: /var/lib/layman/science
    masters: gentoo
    priority: 2

ros-overlay
    location: /var/lib/layman/ros-overlay
    masters: gentoo
    priority: 3

R_Overlay
    location: /var/lib/layman/R_Overlay
    masters: gentoo
    priority: 4

dlang
    location: /var/lib/layman/dlang
    masters: gentoo
    priority: 5

x-portage
    location: /usr/local/portage
    masters: gentoo science
    priority: 6

GentooCNC
    location: /usr/local/src/gentoocnc-code/overlay
    masters: gentoo
    priority: 7

ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CC="gcc"
CFLAGS="-Os -march=native -mtune=native -mfpmath=sse -fweb -fomit-frame-pointer -fipa-pta -fisolate-erroneous-paths-attribute -fsched-stalled-insns-dep -fsched-pressure -fsched-spec-load -fsched-spec-load-dangerous -fsched-stalled-insns"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/hsqldb /var/spool/munin-async/.ssh"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXX="g++"
CXXFLAGS="-Os -march=native -mtune=native -mfpmath=sse -fweb -fomit-frame-pointer -fipa-pta -fisolate-erroneous-paths-attribute -fsched-stalled-insns-dep -fsched-pressure -fsched-spec-load -fsched-spec-load-dangerous -fsched-stalled-insns"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y --complete-graph --backtrack=30 --jobs=2 --verbose-conflicts"
FCFLAGS="-Os -march=native -mtune=native -mfpmath=sse -fweb -fomit-frame-pointer -fipa-pta -fisolate-erroneous-paths-attribute -fsched-stalled-insns-dep -fsched-pressure -fsched-spec-load -fsched-spec-load-dangerous -fsched-stalled-insns"
FEATURES="assume-digests binpkg-logs candy config-protect-if-modified distlocks ebuild-locks fakeroot fixlafiles installsources ipc-sandbox merge-sync network-sandbox news parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-Os -march=native -mtune=native -mfpmath=sse -fweb -fomit-frame-pointer -fipa-pta -fisolate-erroneous-paths-attribute -fsched-stalled-insns-dep -fsched-pressure -fsched-spec-load -fsched-spec-load-dangerous -fsched-stalled-insns"
GENTOO_MIRRORS="ftp://gentoo.imj.fr/pub/gentoo/"
LANG="it_IT.utf8"
LDFLAGS="-Os -march=native -mtune=native -mfpmath=sse -fweb -fomit-frame-pointer -fipa-pta -fisolate-erroneous-paths-attribute -fsched-stalled-insns-dep -fsched-pressure -fsched-spec-load -fsched-spec-load-dangerous -fsched-stalled-insns"
PKGDIR="/usr/portage/packages"
PORTAGE_COMPRESS=""
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="3dfx R X Xaw3d a52 aac aacplus aacs aalib acl acpi adns afs alsa alsa-plugin amr amrenc animgif apm apng armadillo aspell atm audit bash-completion bazaar bcmath berkdb bidi blas bluetooth boost branding bs2b btrfs bzip2 cairo canusb caps cdda cdio cdr cdrom celt cholmod cilk cjk clang cli cracklib cron crypt css cups curl curlwrappers cvs cxx dbi dbm dbus deblob dga dirac djvu doc double-precision dri dts dv dvb dvd dvdr emf encode enscript equalizer evdev examples exif faac fam fastcgi fbcon ffmpeg fftw flac flint flite floppy fltk fontconfig fortran frei0r fribidi ftp fuse gcj gd gdbm gif git glpk glut gme gmp gnuplot gpm gps graphite graphviz gsl gsm gstreamer guile gzip hddtemp hdf5 heterogeneous hscolour http2 iconv icu idn iec61883 ieee1394 imagemagick imlib infiniband int64 ipv6 ipython jack java jbig jit joystick jpeg jpeg2k json ladspa lame lapack latex lcms libass libcaca libffi libnotify librtmp libsamplerate libsoxr libv4l lirc llvm lm_sensors low-memory lto lua luatex lv2 lvm lzma lzo mad maildir man manhole math mathml matplotlib matroska matrox memlimit mercurial metalink metis mhash midi mikmod mime mmap mms mmx mng modplug modules motif mouse mp3 mp4 mpeg mtp musepack nas ncurses netboot netcdf network nfs nls nntp nptl ocaml octave offensive ogg openal opencv openexr opengl openmp opus osc osmesa pam pcmcia pcre pda perl png portmidi postproc postscript ppds pulseaudio pypy python qhull quad quicktime quvi raw rdesktop readline realtime rtmp samba sandbox scanner schroedinger scipy sdl seccomp sensord sensors session shorten slp smartcard sox sparse speex spell sse sse2 ssl subversion svg szip taglib tcl tcpd theora tiff timidity tk truetype tty-helpers twolame udev udisks unicode upnp upnp-av upower usb v4l v4l2 vaapi valgrind vdpau video vim vim-pager vim-plugin vim-syntax vnc vorbis vpx vtk wav wavpack wayland webcam webkit webp wifi wmf x264 x265 x86 xattr xcomposite xetex xft xine xinerama xml xpm xvd xvid xz zeitgeist zip zlib zsh-completion zvbi" ABI_X86="32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="proxy proxy_ajp proxy_balancer proxy_connect proxy_ftp proxy_http actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="it_IT it en en_GB" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="jython2_7 pypy pypy3 python3_4 python2_7" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 2 Alessandro Barbieri 2016-02-28 16:33:22 UTC
emerge -pqv '=media-libs/libcanberra-0.30-r5::gentoo'
[ebuild  N    ] media-libs/libcanberra-0.30-r5  USE="alsa gstreamer gtk gtk3 pulseaudio sound udev -gnome -oss -tdb"
Comment 3 Alessandro Barbieri 2016-02-28 16:34:08 UTC
Created attachment 426916 [details]
environment
Comment 4 Pacho Ramos gentoo-dev 2016-02-28 16:46:31 UTC
You should also have:
/usr/include/gtk-3.0/gdk/gdkx.h

from gtk+:3.0
Comment 5 Alessandro Barbieri 2016-03-02 15:55:09 UTC
I solved re emerging gtk+3 without examples use flag
The problem was caused by a circular dependency: gtk+3 needed libcanberra and libcanberra needed gtk+3 but the first emerge was always libcanberra (gtk+3 not installed) so the issue.
Comment 6 Pacho Ramos gentoo-dev 2016-03-04 09:13:29 UTC
Looking to the deps in gtk+ ebuild, it shouldn't need libcanberra, what error were you getting?
Comment 7 Alessandro Barbieri 2016-03-04 16:12:15 UTC
(In reply to Pacho Ramos from comment #6)
> Looking to the deps in gtk+ ebuild, it shouldn't need libcanberra, what
> error were you getting?

https://gitweb.gentoo.org/repo/gentoo.git/tree/x11-libs/gtk+/gtk+-3.16.7.ebuild#n80
Comment 8 Pacho Ramos gentoo-dev 2016-03-05 10:19:53 UTC
I am looking to 3.18.7
Comment 9 Gilles Dartiguelongue gentoo-dev 2016-10-02 16:56:22 UTC
We should just stop trying to build examples.
Comment 10 Matt Turner gentoo-dev 2021-05-01 02:44:46 UTC
No libcanberra dep since 3.16.