Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 575614 - dev-libs/glib-2.46.2-r1 causes breakages on musl-amd64
Summary: dev-libs/glib-2.46.2-r1 causes breakages on musl-amd64
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo musl team
Depends on:
Blocks: musl-porting
  Show dependency tree
Reported: 2016-02-25 08:10 UTC by tt_1
Modified: 2016-06-25 09:29 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

build logs of gdk-pixbuff, atk and harfbuzz as an example (glib-musl-bug.tar.bz2,14.79 KB, application/octet-stream)
2016-02-25 08:10 UTC, tt_1
patch from alpine (0001-Revert-Move-quark-initialization-to-a-constructor.patch,2.81 KB, patch)
2016-02-25 08:15 UTC, tt_1
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description tt_1 2016-02-25 08:10:29 UTC
Created attachment 426484 [details]
build logs of gdk-pixbuff, atk and harfbuzz as an example

I made a list of packages which are failing since the recent gnome-3.18.0 went stable


this seems to be due to dev-libs/glib-2.46.2-r1

As an example I attached three build logs
Comment 1 tt_1 2016-02-25 08:15:45 UTC
Created attachment 426486 [details, diff]
patch from alpine

this patch for glib works for me, all the failed packages do compile
Comment 2 Anthony Basile gentoo-dev 2016-02-25 09:50:29 UTC
(In reply to tt_1 from comment #1)
> Created attachment 426486 [details, diff] [details, diff]
> patch from alpine
> this patch for glib works for me, all the failed packages do compile

do you know if alpine has pushed that upstream.  i hit the same and was in the middle of debugging your bug report came in.
Comment 3 tt_1 2016-02-25 11:05:51 UTC
I really don't know if the alpine team already has upstreamed this patch, but I guess it is more of a hack as it reverts the commit and doesn't find a better solution for both glibc and non-glibc systems. At least it hasn't been merged in the glib git at
Comment 4 tt_1 2016-02-25 11:19:03 UTC
It is this commit here, according to the description they want to see the code to be removed.
Comment 5 Anthony Basile gentoo-dev 2016-02-28 19:22:57 UTC
Okay this one is on the overlay but I don't now what to do with it because its not upstreamable.  You may want to talk to Nathan Copa of alpine and see if we can't confinve them otherwise.  Else maybe we'll have to talk to Rich Felker about the issue.
Comment 6 tt_1 2016-03-01 19:25:25 UTC
I guess it would be the best to open a bug on the glib bugtracker, don't you think? Because this is code which upstream wants to see deleted, they propably haven't thought about musl specific things. And I wonder if this bug can be solved by patching musl accordingly? 

Anyway, I'm not exactly qualified to solve this problem, don't know much about programming but do enjoy to break stuff and report it later on. 

The ebuild hasn't yet been pushed to the overlay, you propably forgot to include it in the longish commits a few days ago?
Comment 7 Felix Janda 2016-03-25 06:57:09 UTC
alpine has now upgraded to glib-2.48.0 removing the patch. This seems
to indicate that it is no longer needed for 2.48.0.
Comment 8 Aric Belsito 2016-04-24 04:09:01 UTC

Can confirm, this is fixed in glib-2.48.0
Comment 9 Pacho Ramos gentoo-dev 2016-06-25 09:29:23 UTC
should be solved in 2.48