Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 573668 - sys-apps/sysvinit-2.88-r8 inittab spawning agetty twice on same console
Summary: sys-apps/sysvinit-2.88-r8 inittab spawning agetty twice on same console
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-02 13:24 UTC by Daniel Kenzelmann
Modified: 2016-02-05 08:28 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Login problems (agetty1.jpg,249.86 KB, image/jpeg)
2016-02-03 07:37 UTC, Tear♪
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Kenzelmann 2016-02-02 13:24:09 UTC
It seems that the line that was added with bug 506030 is causing issues at least within a QEMU vm which I connect to via SPICE.
(strangely placed text, login prompt appearing again after logging in.. )


The following two lines are in /etc/inittab which seem to both use the same console?

x1:12345:respawn:/sbin/agetty 38400 console linux
c1:12345:respawn:/sbin/agetty 38400 tty1 linux

When commenting out the second line, the issue disappears:
x1:12345:respawn:/sbin/agetty 38400 console linux
#c1:12345:respawn:/sbin/agetty 38400 tty1 linux

Reproducible: Always
Comment 1 equeim 2016-02-02 13:46:30 UTC
Same issue on my desktop.
Comment 2 Daniel Kenzelmann 2016-02-02 16:30:22 UTC
(In reply to Daniel Kenzelmann from comment #0)
> It seems that the line that was added with bug 506030 is causing issues at
> least within a QEMU vm which I connect to via SPICE.
> (strangely placed text, login prompt appearing again after logging in.. )
> 
> 
> The following two lines are in /etc/inittab which seem to both use the same
> console?
> 
> x1:12345:respawn:/sbin/agetty 38400 console linux
> c1:12345:respawn:/sbin/agetty 38400 tty1 linux
> 
> When commenting out the second line, the issue disappears:
> x1:12345:respawn:/sbin/agetty 38400 console linux
> #c1:12345:respawn:/sbin/agetty 38400 tty1 linux
> 
> Reproducible: Always

Of course, commenting out the first line (the one that was inserted with bug 506030 ) instead of the second should also fix this.
Comment 3 Fred Krogh 2016-02-02 18:34:49 UTC
This bug had me pulling my hair (what's left of it) out.  See
https://forums.gentoo.org/viewtopic.php?p=7875498#7875498
This one is serious when this is updated along with a lot of other stuff, and then a reboot is done sometime later.
Comment 4 Gary E. Miller 2016-02-03 00:08:43 UTC
(In reply to Daniel Kenzelmann from comment #0)
> It seems that the line that was added with bug 506030 is causing issues at
> least within a QEMU vm which I connect to via SPICE.
> (strangely placed text, login prompt appearing again after logging in.. )

After tearing my hair out for a bit, I downgraded to 2.88-r7, good thing I
was not in a rush.


> The following two lines are in /etc/inittab which seem to both use the same
> console?

Agreed.

> x1:12345:respawn:/sbin/agetty 38400 console linux
> c1:12345:respawn:/sbin/agetty 38400 tty1 linux
> 
> When commenting out the second line, the issue disappears:
> x1:12345:respawn:/sbin/agetty 38400 console linux
> #c1:12345:respawn:/sbin/agetty 38400 tty1 linux

I disagree with your solution.  my guess is that the first one needs to be commented out.  Otherwise, if you CTRL-ALT-2 to the second console then x1 and c2 will both be on the second console.

Given all the time I've already wasted on this today I'll just stick with the downgrade for now.

And who do I beat with a fish?
Comment 5 Tear♪ 2016-02-03 07:37:27 UTC
Created attachment 424518 [details]
Login problems

Attempting to log in after booting the computer. The agetty(s) race for I/O and ask for password either 2 or 0 times.
Comment 6 Patrick Lauer gentoo-dev 2016-02-03 08:57:45 UTC
Masked for now.
Comment 7 Lars Wendler (Polynomial-C) gentoo-dev 2016-02-03 15:14:41 UTC
commit 4f5d287a02f221da9ffc9ee48917157de6165921
Author: Lars Wendler <polynomial-c@gentoo.org>
Date:   Wed Feb 3 16:10:31 2016

    sys-apps/sysvinit: Revbump to fix bug #573668

    Bumped to EAPI-5. Minor ebuild improvements.

    Package-Manager: portage-2.2.27
    Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Comment 8 Gary E. Miller 2016-02-05 02:01:17 UTC
(In reply to Lars Wendler (Polynomial-C) from comment #7)
> commit 4f5d287a02f221da9ffc9ee48917157de6165921
> Author: Lars Wendler <polynomial-c@gentoo.org>
> Date:   Wed Feb 3 16:10:31 2016
> 
>     sys-apps/sysvinit: Revbump to fix bug #573668
> 
>     Bumped to EAPI-5. Minor ebuild improvements.
> 
>     Package-Manager: portage-2.2.27
>     Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>

I can confirm -r9 this update.  Works fine for me.