Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 573596 - net-misc/vpnc: crashes regularly
Summary: net-misc/vpnc: crashes regularly
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Lorand Jakab
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-01 14:59 UTC by Andrey Utkin
Modified: 2016-11-05 18:16 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Utkin gentoo-dev 2016-02-01 14:59:41 UTC
net-misc/vpnc-0.5.3_p550:0

 # grep 'vpnc[[]' /var/log/messages
Jan 25 03:19:25 zver vpnc[5153]: select: Interrupted system call
Jan 25 03:19:25 zver vpnc[5153]: terminated by signal: 15
Jan 25 19:19:53 zver vpnc[5141]: connection terminated by dead peer detection
Jan 26 11:48:48 zver /etc/init.d/vpnc[29041]: status: crashed
Jan 27 00:18:55 zver vpnc[29236]: select: Interrupted system call
Jan 27 00:18:55 zver vpnc[29236]: terminated by signal: 15
Jan 27 02:52:54 zver vpnc[5356]: connection terminated by dead peer detection
Jan 27 17:41:03 zver /etc/init.d/vpnc[4996]: start-stop-daemon: failed to start `/usr/sbin/vpnc'
Jan 27 17:41:03 zver /etc/init.d/vpnc[4975]: ERROR: vpnc failed to start
Jan 27 21:14:22 zver vpnc[5154]: connection terminated by dead peer detection
Jan 29 09:14:27 zver /etc/init.d/vpnc[5277]: start-stop-daemon: failed to start `/usr/sbin/vpnc'
Jan 29 09:14:27 zver /etc/init.d/vpnc[5256]: ERROR: vpnc failed to start
Jan 29 17:39:32 zver /etc/init.d/vpnc[6735]: WARNING: vpnc has already been started
Jan 29 17:47:55 zver vpnc[5208]: select: Interrupted system call
Jan 29 17:47:55 zver vpnc[5208]: terminated by signal: 15
Jan 29 21:05:02 zver /etc/init.d/vpnc[12258]: status: crashed
Jan 29 21:05:04 zver /etc/init.d/vpnc[12279]: start-stop-daemon: no matching processes found
Feb  1 13:30:46 zver /etc/init.d/vpnc[5260]: start-stop-daemon: failed to start `/usr/sbin/vpnc'
Feb  1 13:30:46 zver /etc/init.d/vpnc[5239]: ERROR: vpnc failed to start
Feb  1 15:00:33 zver /etc/init.d/vpnc[9314]: status: crashed
Feb  1 15:00:36 zver /etc/init.d/vpnc[9336]: start-stop-daemon: no matching processes found
Feb  1 16:19:17 zver /etc/init.d/vpnc[12032]: status: crashed
Feb  1 16:19:19 zver /etc/init.d/vpnc[12053]: start-stop-daemon: no matching processes found
Feb  1 16:20:03 zver vpnc[12223]: select: Interrupted system call
Feb  1 16:20:03 zver vpnc[12223]: terminated by signal: 15


Reproducible: Always

Steps to Reproduce:
I connect to corporate Cisco VPN.
Actual Results:  
Frequently I find the VPN service in crashed state.


Please explain how can I increase verbosity of the service to provide you with good info.
Comment 1 Patrice Clement gentoo-dev 2016-02-07 22:46:43 UTC
Did you talk to upstream about that issue?
Comment 2 Andrey Utkin gentoo-dev 2016-02-08 03:25:09 UTC
(In reply to Patrice Clement from comment #1)
> Did you talk to upstream about that issue?

Not yet.
Have just emailed to vpnc-devel@unix-ag.uni-kl.de
Comment 3 Andrey Utkin gentoo-dev 2016-11-05 18:16:01 UTC
Using net-misc/openconnect since then, works stable.