Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 573504 - ncurses-6.0 SLOT move from 5 to 0 while it shouldn't have, removing all ncurses library
Summary: ncurses-6.0 SLOT move from 5 to 0 while it shouldn't have, removing all ncurs...
Status: RESOLVED OBSOLETE
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Ebuild Support (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-31 15:15 UTC by Nicolas Porcel
Modified: 2016-09-20 19:49 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge.info,6.62 KB, application/x-info)
2016-01-31 15:15 UTC, Nicolas Porcel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas Porcel 2016-01-31 15:15:47 UTC
Created attachment 424324 [details]
emerge --info

Hello,

I had ncurses-6.0 and ncurses-6.0-r1 installed in my system. ncurses-6.0 is supposed to be SLOT 5/6 and pull ncurses-6.0-r1 for compatibility reasons, while ncurses-6.0-r1 is supposed to be SLOT 0/6. However, after a portage sync, a slotmove (Q3-2015) from 5/6 to 0/6 was applied to ncurses-6.0 but the SLOT was in the ebuild file was still 5/6.

Then, when I installed a new package the next day, this automatically triggered package auto-clean (does it always do that?) and removed ncurses-6.0 (and not ncurses-6.0-r1) as they are in the same SLOT. The problem is than ncurses-6.0 does nothing except pulling ncurses-6.0-r1, so it completely removed ncurses library and broke my entire system.

I guess the real problem here is why there is no slotmove 0 to 5 for ncurses-6.0 in 2015-Q4, and why did an old slotmove was applied? For the last question, a lot of upgrade happened in ncurses-6.0 since the last few months without any problem.

I got a BTRFS snapshot of my system before the event so I can easily reproduce if needed.

Best regards,

Nicolas
Comment 1 Steve Arnold archtester gentoo-dev 2016-03-29 20:09:58 UTC
This also happened on trimslice (armv7 w/o neon) the other day, didn't really have a chance to look at it yet, but it's dorked (can't even login remotely now).  Trying to manually restore my console/tty data now...
Comment 2 Steve Arnold archtester gentoo-dev 2016-04-01 17:11:15 UTC
Booted from SDCard and emerged -K the package built previously => fixed.
Comment 3 Nicolas Porcel 2016-09-20 19:49:52 UTC
There has been no updates for more than 5 months, so I am closing this bug report.