Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 572330 - dev-libs/libev should depend on !<sys-libs/glibc-2.9_p20081201
Summary: dev-libs/libev should depend on !<sys-libs/glibc-2.9_p20081201
Status: UNCONFIRMED
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: Prefix Support (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Prefix
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-01-19 07:59 UTC by Marko Vendelin
Modified: 2017-01-05 16:23 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marko Vendelin 2016-01-19 07:59:50 UTC
While trying to update dev-python/pyzmq , I stumbled on dependency on dev-libs/libev . In turn, dev-libs/libev depends on sys-libs/glibc . glibc seems to be masked all throughout in Prefix. So, probably dev-libs/libev dependency on glibc should be removed.

Reproducible: Always

Steps to Reproduce:
1. equery g dev-libs/libev
2.
3.
Actual Results:  
 * Searching for libev in dev-libs ...

 * dependency graph for dev-libs/libev-4.15-r1
 `--  dev-libs/libev-4.15-r1  amd64 
   `--  sys-libs/glibc-9999  (>=sys-libs/glibc-2.9_p20081201) M[package.mask] 
   `--  sys-devel/automake-1.13.4  (>=sys-devel/automake-1.13) ~amd64-linux 
   `--  sys-devel/automake-1.14.1  (>=sys-devel/automake-1.14) ~amd64-linux 
   `--  sys-devel/autoconf-2.69  (>=sys-devel/autoconf-2.69) ~amd64-linux 
   `--  sys-devel/libtool-2.4.6-r1  (>=sys-devel/libtool-2.4) ~amd64-linux 
[ dev-libs/libev-4.15-r1 stats: packages (6), max depth (1) ]

 * dependency graph for dev-libs/libev-4.19
 `--  dev-libs/libev-4.19  amd64 
   `--  sys-libs/glibc-9999  (>=sys-libs/glibc-2.9_p20081201) M[package.mask] 
   `--  sys-devel/automake-1.13.4  (>=sys-devel/automake-1.13) ~amd64-linux 
   `--  sys-devel/automake-1.14.1  (>=sys-devel/automake-1.14) ~amd64-linux 
   `--  sys-devel/autoconf-2.69  (>=sys-devel/autoconf-2.69) ~amd64-linux 
   `--  sys-devel/libtool-2.4.6-r1  (>=sys-devel/libtool-2.4) ~amd64-linux 
[ dev-libs/libev-4.19 stats: packages (6), max depth (1) ]

 * dependency graph for dev-libs/libev-4.20
 `--  dev-libs/libev-4.20  M[package.mask] 
   `--  sys-libs/glibc-9999  (>=sys-libs/glibc-2.9_p20081201) M[package.mask] 
   `--  sys-devel/automake-1.13.4  (>=sys-devel/automake-1.13) ~amd64-linux 
   `--  sys-devel/automake-1.14.1  (>=sys-devel/automake-1.14) ~amd64-linux 
   `--  sys-devel/autoconf-2.69  (>=sys-devel/autoconf-2.69) ~amd64-linux 
   `--  sys-devel/libtool-2.4.6-r1  (>=sys-devel/libtool-2.4) ~amd64-linux 
[ dev-libs/libev-4.20 stats: packages (6), max depth (1) ]

 * dependency graph for dev-libs/libev-4.22
 `--  dev-libs/libev-4.22  ~amd64 
   `--  sys-libs/glibc-9999  (>=sys-libs/glibc-2.9_p20081201) M[package.mask] 
   `--  sys-devel/automake-1.13.4  (>=sys-devel/automake-1.13) ~amd64-linux 
   `--  sys-devel/automake-1.14.1  (>=sys-devel/automake-1.14) ~amd64-linux 
   `--  sys-devel/autoconf-2.69  (>=sys-devel/autoconf-2.69) ~amd64-linux 
   `--  sys-devel/libtool-2.4.6-r1  (>=sys-devel/libtool-2.4) ~amd64-linux 
[ dev-libs/libev-4.22 stats: packages (6), max depth (1) ]
Comment 1 Felix Janda 2016-01-19 15:16:37 UTC
libev only depends on glibc when the use flag elibc_glibc is set, which
should be masked on prefix profiles. Please post your emerge --info.
Comment 2 Marko Vendelin 2016-01-19 16:31:36 UTC
Here it is:

emerge --info
Portage 2.2.20-prefix (python 2.7.11-final-0, prefix/linux/amd64, gcc-4.8.4, unavailable, 4.1.12-gentoo x86_64)
=================================================================
System uname: Linux-4.1.12-gentoo-x86_64-Intel-R-_Xeon-R-_CPU_E5-2650_v2_@_2.60GHz-with-gentoo-2.2
KiB Mem:   264652820 total, 190772524 free
KiB Swap:    8000360 total,   8000360 free
Timestamp of repository gentoo_prefix: Tue, 19 Jan 2016 06:55:44 +0000
sh bash 4.3_p39
ld GNU ld (Gentoo 2.24 p1.3) 2.24
distcc 3.2rc1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.3_p39::gentoo_prefix
dev-lang/perl:            5.22.1::gentoo_prefix
dev-lang/python:          2.7.11::gentoo_prefix
dev-util/cmake:           3.4.1::gentoo_prefix
dev-util/pkgconfig:       0.29::gentoo_prefix
sys-devel/autoconf:       2.69::gentoo_prefix
sys-devel/automake:       1.14.1::gentoo_prefix, 1.15::gentoo_prefix
sys-devel/binutils:       2.24-r2::gentoo_prefix
sys-devel/gcc:            4.8.4::gentoo_prefix
sys-devel/gcc-config:     1.8-r1::gentoo_prefix
sys-devel/libtool:        2.4.6-r1::gentoo_prefix
sys-devel/make:           4.1-r1::gentoo_prefix
sys-kernel/linux-headers: 4.4::gentoo_prefix (virtual/os-headers)
Repositories:

gentoo_prefix
    location: /shared/envs/sysbio/gentoo-1512/usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.prefix.bitzolder.nl/gentoo-portage-prefix
    priority: -1000
    aliases: gentoo

prefix_sysbio_local
    location: /shared/envs/sysbio/gentoo-1512/usr/local/portage/local
    masters: gentoo_prefix
    priority: 0

science
    location: /shared/envs/sysbio/gentoo-1512/var/lib/layman/science
    masters: gentoo_prefix
    priority: 1

ACCEPT_KEYWORDS="~amd64-linux"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -O2 -march=native -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -O2 -march=native -pipe"
DISTDIR="/shared/envs/sysbio/gentoo-1512/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs case-insensitive-fs config-protect-if-modified distlocks ebuild-locks fixlafiles force-prefix merge-sync news parallel-fetch preserve-libs protect-owned sfperms strict unknown-features-warn unmerge-logs unmerge-orphans unprivileged userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j16"
PKGDIR="/shared/envs/sysbio/gentoo-1512/usr/portage/packages"
PORTAGE_CONFIGROOT="/shared/envs/sysbio/gentoo-1512/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/shared/envs/sysbio/gentoo-1512/var/tmp"
USE="X aes amd64 avx berkdb bzip2 cli cracklib crypt cxx dri fortran gdbm iconv ipv6 mmx mmxext modules ncurses nls nptl openmp pcre popcnt prefix prefix-guest readline seccomp session sse sse2 sse3 sse4_1 sse4_2 ssl ssse3 tcpd tiff unicode xattr zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="intel i915 i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 3 Fabian Groffen gentoo-dev 2016-01-19 19:46:00 UTC
(In reply to Felix Janda from comment #1)
> libev only depends on glibc when the use flag elibc_glibc is set, which
> should be masked on prefix profiles. Please post your emerge --info.

Eh, no.  Prefix on Linux has elibc_glibc.

At this point it's more interesting to know what it needs glibc for.
Comment 4 Felix Janda 2016-01-19 19:52:02 UTC
I see: profiles/prefix/linux sets ELIBC="glibc" and sys-libs/glibc-0
is package.provided. So the profile assumes that the host linux system
uses glibc but does not make any assumptions on its version. So the
libev ebuild wants >=sys-libs/glibc-2.9_p20081201 and resulting in this
bug.

I think that the glibc dependency can be removed as you suggested. The
check was added because of bug 283558 (missing SFD_* constants in
<signalfd.h> for glibc-2.8). The underlying issue seems to be fixed in
libev since these constants are only used in ev.c, which also contains

#if EV_USE_SIGNALFD
/* our minimum requirement is glibc 2.7 which has the stub, but not the header */
# include <stdint.h>
# ifndef SFD_NONBLOCK
#  define SFD_NONBLOCK O_NONBLOCK
# endif
# ifndef SFD_CLOEXEC
#  ifdef O_CLOEXEC
#   define SFD_CLOEXEC O_CLOEXEC
#  else
#   define SFD_CLOEXEC 02000000
#  endif
# endif