Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 572254 - sys-apps/sandbox-2.10-r1 fails test script/11
Summary: sys-apps/sandbox-2.10-r1 fails test script/11
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Sandbox (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sandbox Maintainers
Depends on:
Reported: 2016-01-18 10:26 UTC by Paolo Pedroni
Modified: 2021-10-22 08:40 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

sandbox-2.10-r1:20160118-102005.log.gz (sandbox-2.10-r1:20160118-102005.log.gz,22.58 KB, application/gzip)
2016-01-18 10:26 UTC, Paolo Pedroni
build.log (file_572254.txt,57.42 KB, text/plain)
2016-10-27 17:56 UTC, ephemer0l
emerge ---info sys-apps/sandbox-2.10-r1 (file_572254.txt,5.83 KB, text/plain)
2016-10-27 17:57 UTC, ephemer0l

Note You need to log in before you can comment on or make changes to this bug.
Description Paolo Pedroni 2016-01-18 10:26:56 UTC
Created attachment 423236 [details]

 55: script/7                                        ok
 54: script/6                                        ok
 51: script/3                                        ok
 50: script/2                                        ok
 56: script/8                                        ok
 52: script/4                                        ok
 60: script/12                                       ok
 57: script/9                                        ok
 59: script/11                                       FAILED (
 63: symlink/1                                       ok
 64: symlinkat/1                                     ok
 61: script/13                                       ok
 67: unlinkat/1                                      ok
 65: unlink/1                                        ok
 66: unlink_static/1                                 ok
 68: unlinkat/2                                      ok
 62: signal_static/1                                 ok
 69: unlinkat/3                                      ok
 70: unlinkat/4                                      ok
 58: script/10                                       ok
 72: utimensat/2                                     ok
 71: utimensat/1                                     ok
 73: utimensat/3                                     ok
 75: utimensat_static/1                              ok
 76: utimensat_static/2                              ok
 77: vfork/1                                         ok
 74: utimensat/4                                     ok
 53: script/5                                        ok

## ------------- ##
## Test results. ##
## ------------- ##

ERROR: All 77 tests were run,
1 failed unexpectedly.
## -------------------------- ##
## testsuite.log was created. ##
## -------------------------- ##

Please send `tests/testsuite.log' and all information you think might help:

   To: <>
   Subject: [sandbox 2.10] testsuite: 59 failed

You may investigate any problem if you feel able to do so, in which
case the test suite provides a good starting point.  Its output may
be found below `tests/testsuite.dir'.

Makefile:1232: recipe for target 'check-local' failed
make[3]: *** [check-local] Error 1
Makefile:1104: recipe for target 'check-am' failed
make[2]: *** [check-am] Error 2
Makefile:484: recipe for target 'check-recursive' failed
make[1]: *** [check-recursive] Error 1
Makefile:775: recipe for target 'check' failed
make: *** [check] Error 2
emake failed
 * ERROR: sys-apps/sandbox-2.10-r1::gentoo failed (test phase):
 *   (no error message)

# cat /var/tmp/portage/sys-apps/sandbox-2.10-r1/work/build-amd64/tests/testsuite.dir/59/testsuite.log
#                             -*- compilation -*-
59. testing script/11 ...
/var/tmp/portage/sys-apps/sandbox-2.10-r1/work/sandbox-2.10/tests/ \
        env \
                SANDBOX_LOG="$PWD/sandbox.log" \
                        addpredict / \; \
                        addwrite "${PWD%/*}" \; \
                        set -x \; \
 . $abs_top_srcdir/tests/
+ . /var/tmp/portage/sys-apps/sandbox-2.10-r1/work/sandbox-2.10/tests/
++ '[' no = yes ']'
++ mkdir subdir
++ ln -s subdir/target symlink
++ adddeny /var/tmp/portage/sys-apps/sandbox-2.10-r1/work/build-amd64/tests/testsuite.dir/59/subdir
++ export SANDBOX_DENY=:/var/tmp/portage/sys-apps/sandbox-2.10-r1/work/build-amd64/tests/testsuite.dir/59/subdir
++ SANDBOX_DENY=:/var/tmp/portage/sys-apps/sandbox-2.10-r1/work/build-amd64/tests/testsuite.dir/59/subdir
++ echo blah
++ '[' 0 -eq 0 ']'
++ exit 1
/var/tmp/portage/sys-apps/sandbox-2.10-r1/work/sandbox-2.10/tests/ exit code was 1, expected 0
59. 59. script/11 ( FAILED (

# emerge --info =sys-apps/sandbox-2.10-r1
Portage 2.2.26 (python 2.7.10-final-0, default/linux/amd64/13.0/desktop/plasma/systemd, gcc-4.9.3, glibc-2.21-r1, 4.1.12-gentoo x86_64)
                         System Settings
System uname: Linux-4.1.12-gentoo-x86_64-Intel-R-_Core-TM-_i7-2600_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16125308 total,   3993008 free
KiB Swap:    8171516 total,   8171516 free
Timestamp of repository gentoo: Mon, 18 Jan 2016 08:45:01 +0000
sh dash
ld GNU gold (Gentoo 2.25.1 p1.1 2.25.1) 1.11
distcc 3.2rc1 x86_64-pc-linux-gnu [enabled]
ccache version 3.1.9 [disabled]
app-shells/bash:          4.3_p42-r1::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.22.1::gentoo
dev-lang/python:          2.7.10-r1::gentoo, 3.4.3-r1::gentoo
dev-util/ccache:          3.1.9-r4::gentoo
dev-util/cmake:           3.3.1-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r1::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.21-r1::gentoo

    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000

    location: /var/lib/layman/kde
    sync-type: git
    sync-uri: git://
    masters: gentoo kde
    priority: 0

    location: /usr/local/portage
    masters: gentoo
    priority: 1

CFLAGS="-O2 -pipe -march=sandybridge -msahf --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -flto=8 -fuse-linker-plugin -floop-interchange -floop-strip-mine -floop-block -fgraphite-identity"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=sandybridge -msahf --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -flto=8 -fuse-linker-plugin -floop-interchange -floop-strip-mine -floop-block -fgraphite-identity"
EMERGE_DEFAULT_OPTS="--keep-going y --with-bdeps y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs cgroup compress-build-logs config-protect-if-modified distcc distlocks ebuild-locks ipc-sandbox merge-sync news parallel-fetch protect-owned sandbox sfperms split-elog split-log strict test unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu -Wl,--sort-common -flto=8 -fuse-linker-plugin -floop-interchange -floop-strip-mine -floop-block -fgraphite-identity"
MAKEOPTS="-j11 -l8"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac aalib acl acpi adns alsa amd64 ao audiofile bash-completion bluetooth branding bzip2 cairo caps cdda cddb cdparanoia cdr cli cracklib crypt css cups curl cxx dbus declarative dga djvu dri dts dvd dvdr emboss encode exif expat fbcon ffmpeg fftw firefox flac fontconfig foomaticdb fortran ftp gd gdbm geoip gif gimp glamor gmp gnutls gphoto2 gpm graphviz gtk handbook iconv icu idn imagemagick imlib ipv6 java javascript jbig jpeg jpeg2k kde kipi lame lcms libass libcaca libnotify libsamplerate lm_sensors lua lzma lzo mad mmap mmx mmxext mng modules mp3 mp4 mpeg mplayer multilib musicbrainz ncurses nls nptl nsplugin offensive ogg openal openexr opengl openmp pam pango pcre pdf phonon plasma png policykit postscript ppds pulseaudio qml qt3support qt4 qt5 rdesktop readline recode samba sctp sdl seccomp semantic-desktop session sndfile sockets speex spell sqlite sse sse2 ssl startup-notification subversion svg symlink syslog systemd sysvipc taglib theora threads tidy tiff truetype udev udisks unicode upower usb vaapi vcd vim-syntax vnc vorbis wayland widgets win32codecs wmf wxwidgets x264 xattr xcb xcomposite xine xinerama xml xpm xscreensaver xv xvid yahoo zlib" ABI_X86="64" ALSA_CARDS="hda-intel virmidi" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="kodak ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="nlpsolver" LINGUAS="it" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4 pypy pypy3" RUBY_TARGETS="ruby21" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

# emerge -1pqv =sys-apps/sandbox-2.10-r1
[ebuild     U ] sys-apps/sandbox-2.10-r1 [2.6-r1] USE="(multilib)"
Comment 1 SpanKY gentoo-dev 2016-02-21 08:30:40 UTC
does it fail every time ?

what does `ls -ld /dev/fd /dev/std*` look like on your system ?
Comment 2 Paolo Pedroni 2016-02-22 11:36:00 UTC
(In reply to SpanKY from comment #1)
> does it fail every time ?

As far as I can remeber, yes: I have 7 failure logs in /var/log/portage/build/sys-apps

> what does `ls -ld /dev/fd /dev/std*` look like on your system ?

# ls -ld /dev/fd /dev/std*
lrwxrwxrwx 1 root root 13 19 feb 17.53 /dev/fd -> /proc/self/fd
lrwxrwxrwx 1 root root 15 19 feb 17.53 /dev/stderr -> /proc/self/fd/2
lrwxrwxrwx 1 root root 15 19 feb 17.53 /dev/stdin -> /proc/self/fd/0
lrwxrwxrwx 1 root root 15 19 feb 17.53 /dev/stdout -> /proc/self/fd/1
Comment 3 eroen 2016-04-18 21:21:39 UTC
I see the same failure on one (hardened) system, it happens every time for versions with the broken symlink stuff tested in I am unable to reproduce it elsewhere on other systems, though.

occam ~ # ls -ld /dev/fd /dev/std*
lrwxrwxrwx 1 root root 13 03-31 18:53 /dev/fd -> /proc/self/fd
lrwxrwxrwx 1 root root 15 03-31 18:53 /dev/stderr -> /proc/self/fd/2
lrwxrwxrwx 1 root root 15 03-31 18:53 /dev/stdin -> /proc/self/fd/0
lrwxrwxrwx 1 root root 15 03-31 18:53 /dev/stdout -> /proc/self/fd/1
Comment 4 ephemer0l 2016-10-27 17:56:09 UTC
Created attachment 451652 [details]

# ls -ld /dev/fd /dev/std*
lrwxrwxrwx 1 root root 13 Oct 26 20:15 /dev/fd -> /proc/self/fd
lrwxrwxrwx 1 root root 15 Oct 26 20:15 /dev/stderr -> /proc/self/fd/2
lrwxrwxrwx 1 root root 15 Oct 26 20:15 /dev/stdin -> /proc/self/fd/0
lrwxrwxrwx 1 root root 15 Oct 26 20:15 /dev/stdout -> /proc/self/fd/1
Comment 5 ephemer0l 2016-10-27 17:57:55 UTC
Created attachment 451654 [details]
emerge ---info sys-apps/sandbox-2.10-r1
Comment 6 SpanKY gentoo-dev 2021-10-22 04:49:34 UTC
does this still fail with the latest releases ?
Comment 7 Paolo Pedroni 2021-10-22 07:11:37 UTC
(In reply to SpanKY from comment #6)
> does this still fail with the latest releases ?

Current stable tests fine. Thank you.