Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 572116 - app-portage/gentoolkit-0.3.1 revdep-rebuild ignores SEARCH_DIRS_MASK
Summary: app-portage/gentoolkit-0.3.1 revdep-rebuild ignores SEARCH_DIRS_MASK
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Tools (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage Tools Team
URL:
Whiteboard:
Keywords: InVCS
: 599034 (view as bug list)
Depends on: 346443
Blocks: 579176
  Show dependency tree
 
Reported: 2016-01-16 16:40 UTC by cyshei
Modified: 2017-01-06 23:02 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description cyshei 2016-01-16 16:40:02 UTC
In the man page for the new Python-based revdep-rebuild, it still mentions SEARCH_DIRS_MASK, but it doesn't actually work.  revdep-rebuild.sh still honors SEARCH_DIRS_MASK. 

Reproducible: Always

Steps to Reproduce:
1. Install dev-util/nvidia-cuda-toolkit.
2. Run revdep-rebuild with SEARCH_DIRS_MASK set to "/opt/cuda"
Actual Results:  
Revdep-rebuild tries to rebuild nvidia-cuda-toolkit

Expected Results:  
Revdep-rebuild should not try to rebuild nvidia-cuda-toolkit

Portage 2.2.26 (python 3.4.3-final-0, default/linux/amd64/13.0/desktop/gnome/systemd, gcc-5.3.0, glibc-2.22-r1, 4.1.12-gentoo x86_64)
=================================================================
System uname: Linux-4.1.12-gentoo-x86_64-Intel-R-_Core-TM-_i7-3770_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    32861956 total,  28760572 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Sat, 16 Jan 2016 15:23:05 +0000
sh bash 4.3_p42-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
distcc 3.2rc1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.3_p42-r1::gentoo
dev-lang/perl:            5.22.1::gentoo
dev-lang/python:          2.7.11-r2::gentoo, 3.4.3-r7::gentoo
dev-util/cmake:           3.4.1::gentoo
dev-util/pkgconfig:       0.29::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.20.2::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r1::gentoo
sys-devel/automake:       1.10.3-r2::gentoo, 1.11.6-r2::gentoo, 1.12.6-r1::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r1::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo, 5.3.0::gentoo
sys-devel/gcc-config:     1.8::gentoo
sys-devel/libtool:        2.4.6-r1::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r1::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/gentoo
    priority: -1000

x-portage
    location: /usr/local/portage
    masters: gentoo
    priority: 0

vmware
    location: /var/lib/layman/vmware
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=ivybridge -mmmx -msse -msse2 -msse3 -mssse3 -mcx16 -msahf -maes -mpclmul -mpopcnt -mavx -msse4.2 -msse4.1 -mrdrnd -mf16c -mfsgsbase -mfxsr -mxsave -mxsaveopt --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -mtune=ivybridge -fstack-protector-strong"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=ivybridge -mmmx -msse -msse2 -msse3 -mssse3 -mcx16 -msahf -maes -mpclmul -mpopcnt -mavx -msse4.2 -msse4.1 -mrdrnd -mf16c -mfsgsbase -mfxsr -mxsave -mxsaveopt --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=8192 -mtune=ivybridge -fstack-protector-strong"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.ussg.indiana.edu/ http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 ao berkdb bluetooth bluray branding bzip2 cairo cdda cdr cjk cli colord cracklib crypt cups cxx dbus dri dts dvd dvdr eds emacs emboss encode evo exif fam ffmpeg firefox flac fortran fuse gdbm gif glamor gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk iconv introspection ipv6 jpeg kde lcms ldap libnotify libsecret mad mmx mmxext mng modules mp3 mp4 mpeg multilib musepack nautilus ncurses networkmanager nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pulseaudio qt3support qt4 readline sdl seccomp session smp spell sse sse2 ssl startup-notification svg systemd tcpd threads tiff tracker truetype udev udisks unicode upower usb vaapi vdpau vorbis wifi wxwidgets x264 xattr xcb xft xinerama xml xv xvid zlib zsh-completion" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64 pc" INPUT_DEVICES="keyboard mouse evdev vmmouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21 ruby22" USERLAND="GNU" VIDEO_CARDS="intel i965 vesa vmware nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Andreas Proteus 2016-01-20 09:38:35 UTC
Same problem here.
I have SEARCH_DIRS_MASK="/usr/local"
but the new revdep-rebuild searches through /usr/local 
and reports orphaned files.

The old version revdep-rebuild.sh works as expected.
Comment 2 Brian Dolbec gentoo-dev 2016-05-18 14:59:32 UTC
I have made several commits fixing the search mask capabilities.

The final one:

https://gitweb.gentoo.org/proj/gentoolkit.git/commit/?id=6f47784b6a706a51bddfdb0056b3d078a16ab80d

Please test the changes by emerging gentoolkit-9999 to confirm the masking is working correctly for the next release.  I'd like to know that I found them all.
Comment 3 cyshei 2016-05-18 22:24:56 UTC
Unfortunately, it still doesn't seem to work as expected for me:

% sudo env SEARCH_DIRS_MASK="/opt/cuda" revdep-rebuild -i
 * This is the new python coded version
 * Please report any bugs found using it.
 * The original revdep-rebuild script is installed as revdep-rebuild.sh
 * Please file bugs at: https://bugs.gentoo.org/
 * Collecting system binaries and libraries
 * Checking dynamic linking consistency
 * Assign files to packages

emerge  --oneshot --complete-graph=y dev-util/nvidia-cuda-toolkit:0/7.5.18
Calculating dependencies -^C

% sudo env SEARCH_DIRS_MASK="/opt/cuda" revdep-rebuild.sh -i
 * Configuring search environment for revdep-rebuild

 * Checking reverse dependencies
 * Packages containing binaries and libraries broken by a package update
 * will be emerged.

 * Collecting system binaries and libraries
 * Generated new 1_files.rr
 * Collecting complete LD_LIBRARY_PATH
 * Generated new 2_ldpath.rr
 * Checking dynamic linking consistency
[ 100% ]                 

 * Dynamic linking on your system is consistent... All done. 

% eix -e gentoolkit
[I] app-portage/gentoolkit
     Available versions:  0.3.0.8-r2 (~)0.3.0.9 (~)0.3.0.9-r1 0.3.0.9-r2 (~)0.3.1-r1 (**)9999 {PYTHON_TARGETS="pypy python2_7 python3_3 python3_4 python3_5"}
     Installed versions:  9999(06:20:11 PM 05/18/2016)(PYTHON_TARGETS="python2_7 python3_4 -pypy -python3_3 -python3_5")
     Homepage:            https://www.gentoo.org/proj/en/portage/tools/index.xml
     Description:         Collection of administration scripts for Gentoo
Comment 4 Gangræna Gorgeous 2016-07-09 09:16:23 UTC
LD_LIBRARY_MASK is ignored too
# cat /etc/revdep-rebuild/60-java
LD_LIBRARY_MASK="libjvm.so libjawt.so"

# revdep-rebuild
 * This is the new python coded version
 * Please report any bugs found using it.
 * The original revdep-rebuild script is installed as revdep-rebuild.sh
 * Please file bugs at: https://bugs.gentoo.org/
 * Collecting system binaries and libraries
 * Checking dynamic linking consistency
 * Assign files to packages

emerge  --oneshot --complete-graph=y dev-java/icedtea:8 dev-java/swt:3.8 x11-wm/wmii:0
Comment 5 Brian Dolbec gentoo-dev 2016-07-09 17:23:45 UTC
Please test the newly release gentoolkit-0.3.2.  LD_LIBRARY_MASK are being used in the code.
Comment 6 Brian Dolbec gentoo-dev 2016-11-06 15:50:45 UTC
*** Bug 599034 has been marked as a duplicate of this bug. ***
Comment 7 Volker Eckert 2017-01-04 12:13:38 UTC
Seems not to be finally fixed in gentoolkit-0.3.2-r1 (latest stable as of now):

# eix -e gentoolkit
[I] app-portage/gentoolkit
     Verfügbare Versionen:   0.3.0.8-r2 0.3.0.9-r2 ~0.3.1.1 ~0.3.2 0.3.2-r1 ~0.3.3 **9999 {PYTHON_TARGETS="pypy python2_7 python3_4 python3_5"}
     Installierte Versionen: 0.3.2-r1(13:43:40 19.12.2016)(PYTHON_TARGETS="python2_7 python3_4 -pypy -python3_5")
     Startseite:             https://wiki.gentoo.org/wiki/Project:Portage-Tools
     Beschreibung:           Collection of administration scripts for Gentoo

# env SEARCH_DIRS_MASK="/usr/lib64/opera" revdep-rebuild -i -- -p
 * This is the new python coded version
 * Please report any bugs found using it.
 * The original revdep-rebuild script is installed as revdep-rebuild.sh
 * Please file bugs at: https://bugs.gentoo.org/
 * Collecting system binaries and libraries
 * Checking dynamic linking consistency
 * Assign files to packages

emerge -p --oneshot --complete-graph=y www-client/opera:0

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] www-client/opera-12.16_p1860-r1
# env SEARCH_DIRS_MASK="/usr/lib64/opera" revdep-rebuild.sh -i -- -p
 * Configuring search environment for revdep-rebuild

 * Checking reverse dependencies
 * Packages containing binaries and libraries broken by a package update
 * will be emerged.

 * Collecting system binaries and libraries
 * Generated new 1_files.rr
 * Collecting complete LD_LIBRARY_PATH
 * Generated new 2_ldpath.rr
 * Checking dynamic linking consistency
[ 100% ]                 

 * Dynamic linking on your system is consistent... All done.
#
Comment 8 Brian Dolbec gentoo-dev 2017-01-04 22:34:59 UTC
There have been several more fixes to revdep-rebuild for the new 03.3. release that was done last week.  Please test that one to see if it still errors.

We will call for that one to become stable after the customary 30 day waiting period.
Comment 9 Volker Eckert 2017-01-06 18:25:17 UTC
Yes, that works for me:

#  revdep-rebuild -V
revdep-rebuild 0.3.3
#  revdep-rebuild -- -p
 * This is the new python coded version
 * Please report any bugs found using it.
 * The original revdep-rebuild script is installed as revdep-rebuild.sh
 * Please file bugs at: https://bugs.gentoo.org/
 * Checking dynamic linking consistency

Your system is consistent
Comment 10 Brian Dolbec gentoo-dev 2017-01-06 23:02:24 UTC
Fixed in gentoolkit-0.3.3