Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 571990 - app-text/calibre-2.47.0 with dev-qt/qtwebkit-5.5.1 - ImportError: cannot import name QWebView
Summary: app-text/calibre-2.47.0 with dev-qt/qtwebkit-5.5.1 - ImportError: cannot impo...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Ian Stakenvicius (RETIRED)
Depends on:
Reported: 2016-01-15 12:49 UTC by N. Andrew Walsh
Modified: 2017-04-25 13:01 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---

build.log (build.log,75.06 KB, text/plain)
2016-01-15 12:50 UTC, N. Andrew Walsh

Note You need to log in before you can comment on or make changes to this bug.
Description N. Andrew Walsh 2016-01-15 12:49:34 UTC
This may be the case for other versions of qtwebkit-5.5.*, but the ebuild fails at two points in the final stages, with undefined references: both 'completion' and 'desktop integration' fail to complete.

Reproducible: Always

Steps to Reproduce:
1. emerge qtwebkit-5.5.1
2. emerge calibre-2.47.0
3. emo tears as your dreams are mercilessly crushed by undefined references.
Actual Results:  
The following in the log:

Installing resources to /var/tmp/portage/app-text/calibre-2.47.0/image/usr/share/calibre
Setting up command-line completion...
Installing bash completion to: /var/tmp/portage/app-text/calibre-2.47.0/image/usr/share/bash-completion/completions/calibre

____________________ WARNING ____________________
Setting up completion failed with error:
        Traceback (most recent call last):
          File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/src/calibre/", line 748, in setup_completion
            write_completion(bash_comp_dest, zsh)
          File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/src/calibre/", line 506, in write_completion
            from calibre.gui2.viewer.main import option_parser as viewer_op
          File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/src/calibre/gui2/viewer/", line 13, in <module>
            from calibre.gui2.viewer.ui import Main as MainWindow
          File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/src/calibre/gui2/viewer/", line 11, in <module>
            from PyQt5.Qt import (
        ImportError: cannot import name QWebView

Setting up desktop integration...

____________________ WARNING ____________________
Setting up desktop integration failed with error:
        Traceback (most recent call last):
          File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/src/calibre/", line 820, in setup_desktop_integration
            from calibre.ebooks.oeb.polish.main import SUPPORTED
          File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/src/calibre/ebooks/oeb/polish/", line 15, in <module>
            from calibre.ebooks.oeb.polish.stats import StatsCollector
          File "/var/tmp/portage/app-text/calibre-2.47.0/work/calibre-2.47.0/src/calibre/ebooks/oeb/polish/", line 18, in <module>
            from PyQt5.QtWebKitWidgets import QWebPage, QWebView
        ImportError: /usr/lib64/ undefined symbol: _ZN7leveldb2DB4OpenERKNS_7OptionsERKSsPPS0_

Creating un-installer: /var/tmp/portage/app-text/calibre-2.47.0/image/usr/bin/calibre-uninstall
Installing calibre environment module: /var/tmp/portage/app-text/calibre-2.47.0/image/usr/lib64/python2.7/site-packages/

calibre successfully installed. You can start it by running the command calibre

There were 2 warning(s):

* Setting up completion failed with error:

* Setting up desktop integration failed with error:

mv: cannot stat ?/var/tmp/portage/app-text/calibre-2.47.0/temp/fake_homedir/.local/share/mime/packages/*?: No such file or directory

Expected Results:  
ebook-based literary pleasures. 

build.log will be attached in full. Here's emerge --info:

# emerge --info
Portage 2.2.26 (python 3.5.1-final-0, default/linux/amd64/13.0, gcc-5.3.0, glibc-2.22-r1, 4.4.0-gentoo x86_64)
System uname: Linux-4.4.0-gentoo-x86_64-AMD_Phenom-tm-_9950_Quad-Core_Processor-with-gentoo-2.2
KiB Mem:     4056560 total,    242036 free
KiB Swap:    2929668 total,   2815708 free
Timestamp of repository gentoo: Thu, 14 Jan 2016 06:45:02 +0000
sh bash 4.3_p42-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
ccache version 3.2.4 [disabled]
app-shells/bash:          4.3_p42-r1::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.22.1::gentoo
dev-lang/python:          2.7.11-r2::gentoo, 3.4.3-r7::gentoo, 3.5.1-r2::gentoo
dev-util/ccache:          3.2.4::gentoo
dev-util/cmake:           3.4.1::gentoo
dev-util/pkgconfig:       0.29::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.20.1::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r1::gentoo
sys-devel/automake:       1.9.6-r3::gentoo, 1.10.3::gentoo, 1.11.6-r1::gentoo, 1.12.6::gentoo, 1.13.4::gentoo, 1.14.1::gentoo, 1.15-r1::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.8.4::gentoo, 4.9.3::gentoo, 5.3.0::gentoo
sys-devel/gcc-config:     1.8::gentoo
sys-devel/libtool:        2.4.6-r1::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r1::gentoo

    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000
    sync-rsync-vcs-ignore: true

    location: /usr/local/portage
    masters: gentoo
    priority: 0

    location: /var/lib/layman/emc
    masters: gentoo
    priority: 50

    location: /var/lib/layman/qt
    sync-type: git
    sync-uri: git://
    masters: gentoo
    priority: 50

    location: /var/lib/layman/rebutia
    sync-type: git
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1 Mendeley-EULA Google-TOS"
CFLAGS="-march=athlon64 -O2 -pipe"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=athlon64 -O2 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X Xaw3d a52 aac acl acpi aim alsa amd64 apm audiofile bash-completion berkdb bzip2 cairo cddb cdinstall cdparanoia cdr cli cracklib crypt css curl curlwrappers cxx dbus directfb dri dvd dvdr encode fbcon ffmpeg fftw firefox flac fortran ftp gdbm geoip gif gimp glut graphite gstreamer gtk hddtemp iconv icq ieee1394 imagemagick imap imlib ipv6 jack java javascript joystick jpeg kde kde4 lame latex ldap libsamplerate libwww lm_sensors mad matroska minimal mmx mmxext modules motif mp3 mpeg mplayer multilib ncurses nls nptl nsplugin offensive ogg openal opengl openmp openssl oscar pam pcre pdf perl png policykit posix python qt5 quicktime raw readline real rss scanner seccomp semantic-desktop session sndfile sockets speex spell sse sse2 ssl suid svg symlink syslog tcl tcpd tetex theora threads tidy tiff tk translucency truetype udev unicode usb vaapi vdpau videos vorbis win32codecs wmf wxwindows x264 xattr xcomposite xetex xine xml xpm xscreensaver xulrunner xv xvid zlib" ABI_X86="64 32" ALSA_CARDS="hda-intel usb-audio" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="3dnow 3dnowext mmx mmxext popcnt sse sse2 sse3 sse4a" CURL_SSL="openssl" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US en_US.utf8 de de_DE de_DE.utf8" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python3_5 python2_7" RUBY_TARGETS="ruby22" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 N. Andrew Walsh 2016-01-15 12:50:21 UTC
Created attachment 422970 [details]
Comment 2 N. Andrew Walsh 2016-01-15 12:52:25 UTC
NB: the last line of the log before the error message suggests that I'm also suffering from the same issue as bug 570536 (but I get substantially different error messages, so it probably isn't a dupe)
Comment 3 Frank Krömmelbein 2016-01-15 19:10:51 UTC
Maybe this bug could by fix with an version bump to latest version of calibre:

Release: 2.49 [15 Jan, 2016]
- Linux build: Update bundled version of Qt to 5.5.1
Comment 4 Jan-Matthias Braun 2016-01-19 15:25:05 UTC
(In reply to Frank Krömmelbein from comment #3)
> Maybe this bug could by fix with an version bump to latest version of
> calibre:
> Release: 2.49 [15 Jan, 2016]
> - Linux build: Update bundled version of Qt to 5.5.1

I tried it with a renamed ebuild and had no luck.

Disabling the headless extension works but seems more of a crude workaround.
Comment 5 Jan-Matthias Braun 2016-01-19 15:27:07 UTC
(In reply to Jan-Matthias Braun from comment #4)
> (In reply to Frank Krömmelbein from comment #3)
> > Maybe this bug could by fix with an version bump to latest version of
> > calibre:
> >
> > 
> > Release: 2.49 [15 Jan, 2016]
> > - Linux build: Update bundled version of Qt to 5.5.1
> I tried it with a renamed ebuild and had no luck.
> Disabling the headless extension works but seems more of a crude workaround.

Huh, sorry, wrong bug report. This is not really related... So please ignore my noise.
Comment 6 N. Andrew Walsh 2016-01-19 16:15:31 UTC
(In reply to Frank Krömmelbein from comment #3)
> Maybe this bug could by fix with an version bump to latest version of
> calibre:
> Release: 2.49 [15 Jan, 2016]
> - Linux build: Update bundled version of Qt to 5.5.1

Oddly, I tried remerging this a couple days ago (ie, version 2.47.0 from the tree), and it completed. My version still reports itself as 2.47.0, so I'm not sure what changed in the last week or so to make it work. Was a patch added without changing the version number?
Comment 7 Pavel Volkov 2016-03-03 08:04:56 UTC
I hit this and re-merging qtnetwork helped.
Comment 8 Jonas Stein gentoo-dev 2017-04-22 21:50:08 UTC
app-text/calibre-2.47.0 is not in the tree anymore.
Is this bug still present in >=app-text/calibre-2.78, or is it fixed already?
Comment 9 N. Andrew Walsh 2017-04-25 13:01:24 UTC
I just completed emerging calibre-2.80.0 without incident, so I'm guessing this issue is fixed. Cheers.