Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 571782 - app-portage/gentoolkit-0.3.1: revdep-rebuild tries to subscript a Nonetype
Summary: app-portage/gentoolkit-0.3.1: revdep-rebuild tries to subscript a Nonetype
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Tools (show other bugs)
Hardware: All Linux
: Normal critical (vote)
Assignee: Portage Tools Team
URL:
Whiteboard:
Keywords: InVCS
Depends on:
Blocks: 346443
  Show dependency tree
 
Reported: 2016-01-13 20:04 UTC by Jelte Fennema
Modified: 2017-11-08 19:58 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jelte Fennema 2016-01-13 20:04:49 UTC
When running the command mentioned in the news item about gcc and the new C++11 ABI from 2015-10-22 it crashed:

$ revdep-rebuild --library 'libstdc++.so.6' -- --exclude
 * This is the new python coded version
 * Please report any bugs found using it.
 * The original revdep-rebuild script is installed as revdep-rebuild.sh
 * Please files bugs at: https://bugs.gentoo.org/
 * Collecting system binaries and libraries
 * Checking dynamic linking consistency
 * Assign files to packages

 !!! Dependant orphaned files: No installed package was found for the following:
	* /opt/android-sdk-update-manager/tools/lib/libemugl_test_shared_library.so
	* /usr/lib64/gcc/x86_64-pc-linux-gnu/5.3.0/32/libasan.so.2.0.0
	* /usr/lib64/gcc/x86_64-pc-linux-gnu/5.3.0/liblsan.so.0.0.0
	* /usr/lib64/gcc/x86_64-pc-linux-gnu/5.3.0/32/libubsan.so.0.0.0
	* /usr/lib64/gcc/x86_64-pc-linux-gnu/5.3.0/libtsan.so.0.0.0
	* /usr/lib64/gcc/x86_64-pc-linux-gnu/5.3.0/plugin/libcc1plugin.so.0.0.0
	* /opt/android-sdk-update-manager/platform-tools/sqlite3
	* /opt/android-sdk-update-manager/platform-tools/hprof-conv
	* /opt/android-sdk-update-manager/platform-tools/fastboot
	* /opt/android-sdk-update-manager/tools/lib/lib64emugl_test_shared_library.so
	* /usr/lib64/gcc/x86_64-pc-linux-gnu/5.3.0/libcc1.so.0.0.0
	* /opt/android-sdk-update-manager/platform-tools/dmtracedump
	* /opt/android-sdk-update-manager/platform-tools/etc1tool
	* /usr/lib64/gcc/x86_64-pc-linux-gnu/5.3.0/libasan.so.2.0.0
	* /usr/lib64/gcc/x86_64-pc-linux-gnu/5.3.0/libubsan.so.0.0.0
	* /opt/android-sdk-update-manager/platform-tools/adb
Traceback (most recent call last):
  File "/usr/lib/python-exec/python3.4/revdep-rebuild", line 40, in <module>
    success = rebuild.main(rebuild.parse_options())
  File "/usr/lib64/python3.4/site-packages/gentoolkit/revdep_rebuild/rebuild.py", line 171, in main
    success = rebuild(logger, assigned, settings)
  File "/usr/lib64/python3.4/site-packages/gentoolkit/revdep_rebuild/rebuild.py", line 73, in rebuild
    _assigned = get_slotted_cps(assigned, logger)
  File "/usr/lib64/python3.4/site-packages/gentoolkit/revdep_rebuild/assign.py", line 106, in get_slotted_cps
    cp = parts[0] + '/' + parts[1]
TypeError: 'NoneType' object is not subscriptable


Reproducible: Always
Comment 1 Brian Dolbec gentoo-dev 2016-05-18 15:44:50 UTC
I added a trap for this type of error and output a warning with the invalid cpy that caused it.

I don't know what invalid package cpv caused it, but it will not stop it anymore.

Fixed in commit:
https://gitweb.gentoo.org/proj/gentoolkit.git/commit/?id=ecd20fa451e72e03aacd41c297b47de896043a5f
Comment 2 Paul Varner (RETIRED) gentoo-dev 2017-11-08 19:58:40 UTC
This has been fixed since gentoolkit-0.3.1.1