Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 57050 - bootsplash_resize not working correctly
Summary: bootsplash_resize not working correctly
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Michal Januszewski (RETIRED)
Depends on:
Reported: 2004-07-14 10:41 UTC by Jens Weibler
Modified: 2004-08-06 03:46 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

The generated config (bootsplash-1400x1050.cfg,2.14 KB, text/plain)
2004-07-15 00:26 UTC, Jens Weibler

Note You need to log in before you can comment on or make changes to this bug.
Description Jens Weibler 2004-07-14 10:41:22 UTC
bootsplash_resize seems not working correctly for my resolution (1400x1050).
E.g. the box is too little and the statusbar goes from top to bottom.. Tried it with the newest version of bootsplash (0.6.1-r4)

Reproducible: Always
Steps to Reproduce:
Comment 1 Michal Januszewski (RETIRED) gentoo-dev 2004-07-14 14:48:25 UTC
Please attach/send me the original config file and the config file generated by the bootsplash_resize script.
Comment 2 Jens Weibler 2004-07-15 00:26:09 UTC
Created attachment 35454 [details]
The generated config
Comment 3 Jens Weibler 2004-07-15 00:29:51 UTC
Comment on attachment 35454 [details]
The generated config

This config was generated from the normal gentoo-bootsplashtheme.. You can see
in line 32 that the coordinates are wrong (793 280 for 1400x1050 and in the
normal config for 1600x1200: 320 907)
Comment 4 Hector E. Gomez Morales 2004-07-30 20:29:04 UTC
I should add some other problems with bootsplash_resize, well i am installing gentoo in a new centrino laptop with a widthscreen (1280x800), so using the radeonfb I got my nice 1280x800 framebuffer then I run bootsplash_resize with no 
parameters so that it build the configs and images for my resolution. I continue with the standard configuration with bootsplash and reboot but got a error about no good signature found, then I checked the images and config.

hector@spivaka images $ identify silent-1280x800.jpg
silent-1280x800.jpg JPEG 1067x800+0+0 DirectClass 8-bit 25.7kb 0.000u 0:01

so you can see the created images is 1067x800 geometry no 1280x800 that is my framebuffer (I repeated giving this time the resolution to bootsplash but the same happens). What I think is that bootsplash_resize and convert only scale the image to the most close 4:3 ratio from the given geometry requested.
Comment 5 Michal Januszewski (RETIRED) gentoo-dev 2004-08-06 03:46:51 UTC
It should be fixed in 0.6.1-r5.