Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 569826 - mail-client/claws-mail-3.9.0 with net-libs/libetpan-1.6 - Error in `claws-mail': munmap_chunk(): invalid pointer: 0xNNNNN...
Summary: mail-client/claws-mail-3.9.0 with net-libs/libetpan-1.6 - Error in `claws-mai...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal critical (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on: CVE-2015-8614
Blocks:
  Show dependency tree
 
Reported: 2015-12-26 16:56 UTC by jhon
Modified: 2016-03-22 07:03 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jhon 2015-12-26 16:56:45 UTC
After updating libetpan to the latest stable version, the stable version of claws-mail (3.9.0) is crashing immediately after launch with the following error on my system (complete trace here - http://pastebin.com/XQPZS1iH):
$ claws-mail

** (claws-mail:791): WARNING **: IMAP: can't get cert

*** Error in `claws-mail': munmap_chunk(): invalid pointer: 0x0000000001638c8e ***

upgrading to a newer (claws-mail) version stops the crash, perhaps it's time to update stable ebuilds?

Reproducible: Always

Steps to Reproduce:
1.launch claws-mail
2.wait a couple of seconds while fetches mail
3.
Actual Results:  
crash

Expected Results:  
not crash
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2015-12-26 17:07:14 UTC
We're about to stabilize a newer version of claws-mail...
Comment 2 Steve Evans 2015-12-27 20:59:29 UTC
I see the same problem. After masking libetpan-1.6 and rebuilding it to go back to version 1.1 claws-mail works again.
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2015-12-27 21:28:34 UTC
(In reply to Steve Evans from comment #2)
> I see the same problem. After masking libetpan-1.6 and rebuilding it to go
> back to version 1.1 claws-mail works again.

That's a bad idea considering the TLS fixes which went into latest libetpan versions. You should rather upgrade claws-mail to at least version 3.13.1
Comment 4 Thomas M 2016-01-04 08:47:07 UTC
after updating i guess i got some similar error:

---
[09:27:36] IMAP4> 1 STARTTLS 
[09:27:36] IMAP4< 1 OK Begin TLS negotiation now 
imap-thread.c:1143:imap starttls run - end 0
imap-thread.c:404:generic_cb
imap-thread.c:1186:imap starttls - end

** (claws-mail:3883): WARNING **: IMAP: can't get cert

Speicherzugriffsfehler
---

(Speicherzugriffsfehler = segmentation fault)

i could solve the problem by installing libetpan-1.6 with useflag gnutls.

i would suggest to redo dependecy of claws-mail-3.9.0 to need libetpan with useflag gnutls if claws-mail is installed with useflags ssl and imap.

maybe someone can ensure if this solves the error with the munmap_chunk() message, too?
Comment 5 Johannes Hirte 2016-02-15 21:18:00 UTC
> i could solve the problem by installing libetpan-1.6 with useflag gnutls.
> 
> i would suggest to redo dependecy of claws-mail-3.9.0 to need libetpan with
> useflag gnutls if claws-mail is installed with useflags ssl and imap.
> 
> maybe someone can ensure if this solves the error with the munmap_chunk()
> message, too?

I can confirm that using gnutls fixes the segfault.
Comment 6 fanny 2016-03-01 21:56:28 UTC
I can confirm that using gnutls with libnetpan solves the munmap_chunk() error.
Comment 7 Lars Wendler (Polynomial-C) gentoo-dev 2016-03-22 07:03:35 UTC
claws-mail-3.9.0 has been removed from the tree.